From: Breno Leitao <leitao@debian.org>
To: "David S. Miller" <davem@davemloft.net>,
Eric Dumazet <edumazet@google.com>,
Jakub Kicinski <kuba@kernel.org>,
Paolo Abeni <pabeni@redhat.com>, Simon Horman <horms@kernel.org>,
Andrew Lunn <andrew+netdev@lunn.ch>
Cc: linux-kernel@vger.kernel.org, netdev@vger.kernel.org,
Breno Leitao <leitao@debian.org>,
kernel-team@meta.com, kuniyu@amazon.com,
ushankar@purestorage.com
Subject: [PATCH net-next v2 0/2] net: core: improvements to device lookup by hardware address.
Date: Mon, 10 Feb 2025 03:56:12 -0800 [thread overview]
Message-ID: <20250210-arm_fix_selftest-v2-0-ba84b5bc58c8@debian.org> (raw)
The first patch adds a new dev_getbyhwaddr() helper function for
finding devices by hardware address when the RTNL lock is held. This
prevents PROVE_LOCKING warnings that occurred when RTNL was held but the
RCU read lock wasn't. The common address comparison logic is extracted
into dev_comp_addr() to avoid code duplication.
The second patch adds missing documentation for the return value of
dev_getbyhwaddr_rcu(), fixing a warning reported by NIPA. The kdoc
comment now properly specifies that the function returns either a
pointer to net_device or NULL when no matching device is found.
Signed-off-by: Breno Leitao <leitao@debian.org>
---
Changes in v2:
- Fixed the documentation (Jakub)
- Renamed the function from dev_getbyhwaddr_rtnl() to dev_getbyhwaddr()
(Jakub)
- Exported the function in the header (Jakub)
- Link to v1: https://lore.kernel.org/r/20250207-arm_fix_selftest-v1-1-487518d2fd1c@debian.org
---
Breno Leitao (2):
net: document return value of dev_getbyhwaddr_rcu()
net: Add dev_getbyhwaddr_rtnl() helper
include/linux/netdevice.h | 2 ++
net/core/dev.c | 38 ++++++++++++++++++++++++++++++++++----
2 files changed, 36 insertions(+), 4 deletions(-)
---
base-commit: 0d5248724ed8bc68c867c4c65dda625277f68fbc
change-id: 20250207-arm_fix_selftest-ee29dbc33a06
Best regards,
--
Breno Leitao <leitao@debian.org>
next reply other threads:[~2025-02-10 11:56 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-02-10 11:56 Breno Leitao [this message]
2025-02-10 11:56 ` [PATCH net-next v2 1/2] net: document return value of dev_getbyhwaddr_rcu() Breno Leitao
2025-02-11 0:53 ` Kuniyuki Iwashima
2025-02-10 11:56 ` [PATCH net-next v2 2/2] net: Add dev_getbyhwaddr_rtnl() helper Breno Leitao
2025-02-11 1:03 ` Kuniyuki Iwashima
2025-02-11 11:38 ` Breno Leitao
2025-02-11 8:10 ` Uday Shankar
2025-02-11 11:36 ` Breno Leitao
2025-02-11 1:09 ` [PATCH net-next v2 0/2] net: core: improvements to device lookup by hardware address Kuniyuki Iwashima
2025-02-11 11:41 ` Breno Leitao
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250210-arm_fix_selftest-v2-0-ba84b5bc58c8@debian.org \
--to=leitao@debian.org \
--cc=andrew+netdev@lunn.ch \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=horms@kernel.org \
--cc=kernel-team@meta.com \
--cc=kuba@kernel.org \
--cc=kuniyu@amazon.com \
--cc=linux-kernel@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
--cc=ushankar@purestorage.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®