From: Konrad Dybcio <konradybcio@kernel.org>
To: Joerg Roedel <joro@8bytes.org>, Will Deacon <will@kernel.org>,
Robin Murphy <robin.murphy@arm.com>,
Rob Herring <robh@kernel.org>,
Krzysztof Kozlowski <krzk+dt@kernel.org>,
Conor Dooley <conor+dt@kernel.org>,
Konrad Dybcio <konradybcio@kernel.org>,
Rob Clark <robdclark@gmail.com>,
Abhinav Kumar <quic_abhinavk@quicinc.com>,
Dmitry Baryshkov <dmitry.baryshkov@linaro.org>,
Sean Paul <sean@poorly.run>, David Airlie <airlied@gmail.com>,
Simona Vetter <simona@ffwll.ch>,
Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
Maxime Ripard <mripard@kernel.org>,
Thomas Zimmermann <tzimmermann@suse.de>,
Robert Foss <rfoss@kernel.org>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Wesley Cheng <quic_wcheng@quicinc.com>,
Christian Marangi <ansuelsmth@gmail.com>,
Bjorn Andersson <andersson@kernel.org>,
Rohit Agarwal <quic_rohiagar@quicinc.com>,
Kyle Deng <quic_chunkaid@quicinc.com>,
Vinod Koul <vkoul@kernel.org>
Cc: Marijn Suijten <marijn.suijten@somainline.org>,
linux-arm-msm@vger.kernel.org, iommu@lists.linux.dev,
devicetree@vger.kernel.org, linux-kernel@vger.kernel.org,
dri-devel@lists.freedesktop.org,
freedreno@lists.freedesktop.org,
Krzysztof Kozlowski <krzysztof.kozlowski@linaro.org>,
linux-usb@vger.kernel.org,
Konrad Dybcio <konrad.dybcio@oss.qualcomm.com>
Subject: [PATCH 07/11] arm64: dts: qcom: qcs615: Rename AOSS_QMP to power-management
Date: Thu, 06 Mar 2025 19:11:19 +0100 [thread overview]
Message-ID: <20250306-topic-dt_bindings_fixups-v1-7-0c84aceb0ef9@oss.qualcomm.com> (raw)
In-Reply-To: <20250306-topic-dt_bindings_fixups-v1-0-0c84aceb0ef9@oss.qualcomm.com>
From: Konrad Dybcio <konrad.dybcio@oss.qualcomm.com>
The node is currently named power-controller, which requires the device
underneath is a power domain provider. Rename it to align with other
SoCs and resolve this sort of warnings:
power-controller@c300000: '#power-domain-cells' is a required property
Fixes: 0775021783b5 ("arm64: dts: qcom: qcs615: add AOSS_QMP node")
Signed-off-by: Konrad Dybcio <konrad.dybcio@oss.qualcomm.com>
---
arch/arm64/boot/dts/qcom/qcs615.dtsi | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm64/boot/dts/qcom/qcs615.dtsi b/arch/arm64/boot/dts/qcom/qcs615.dtsi
index ec427bb84ec8e88cc0f4b756adb4582897943b4f..dd7a25fb4763181c6fde3d4110ae629cc8903fb3 100644
--- a/arch/arm64/boot/dts/qcom/qcs615.dtsi
+++ b/arch/arm64/boot/dts/qcom/qcs615.dtsi
@@ -3203,7 +3203,7 @@ pdc: interrupt-controller@b220000 {
interrupt-controller;
};
- aoss_qmp: power-controller@c300000 {
+ aoss_qmp: power-management@c300000 {
compatible = "qcom,qcs615-aoss-qmp", "qcom,aoss-qmp";
reg = <0x0 0x0c300000 0x0 0x400>;
interrupts = <GIC_SPI 389 IRQ_TYPE_EDGE_RISING>;
--
2.48.1
next prev parent reply other threads:[~2025-03-06 18:12 UTC|newest]
Thread overview: 32+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-03-06 18:11 [PATCH 00/11] Various dt-bindings fixes Konrad Dybcio
2025-03-06 18:11 ` [PATCH 01/11] dt-bindings: iommu: qcom,iommu: Add optional TBU clock Konrad Dybcio
2025-03-07 21:55 ` Rob Herring (Arm)
2025-03-06 18:11 ` [PATCH 02/11] dt-bindings: display: msm: sm8350-mdss: Describe the CPU-CFG icc path Konrad Dybcio
2025-05-01 21:45 ` Dmitry Baryshkov
2025-03-06 18:11 ` [PATCH 03/11] dt-bindings: power: qcom,kpss-acc-v2: Add MSM8916 compatible Konrad Dybcio
2025-03-07 5:52 ` Dmitry Baryshkov
2025-03-07 11:07 ` Stephan Gerhold
2025-03-07 22:30 ` Konrad Dybcio
2025-03-12 15:12 ` Krzysztof Kozlowski
2025-03-13 22:53 ` Bjorn Andersson
2025-03-14 7:22 ` Krzysztof Kozlowski
2025-03-06 18:11 ` [PATCH 04/11] arm64: dts: qcom: msm8916: Fix KPSS ACC compatible Konrad Dybcio
2025-03-07 5:48 ` Dmitry Baryshkov
2025-03-06 18:11 ` [PATCH 05/11] arm64: dts: qcom: sdx75: Fix up the USB interrupt description Konrad Dybcio
2025-03-06 18:11 ` [PATCH 06/11] arm64: dts: qcom: sdx75: Rename AOSS_QMP to power-management Konrad Dybcio
2025-03-07 5:48 ` Dmitry Baryshkov
2025-03-06 18:11 ` Konrad Dybcio [this message]
2025-03-07 5:48 ` [PATCH 07/11] arm64: dts: qcom: qcs615: " Dmitry Baryshkov
2025-03-06 18:11 ` [PATCH 08/11] arm64: dts: qcom: sc8180x: " Konrad Dybcio
2025-03-07 5:48 ` Dmitry Baryshkov
2025-03-06 18:11 ` [PATCH 09/11] arm64: dts: qcom: x1e80100-dell-xps13-9345: Drop clock-names from PS8830 Konrad Dybcio
2025-03-07 5:51 ` Dmitry Baryshkov
2025-03-06 18:11 ` [PATCH 10/11] arm64: dts: qcom: x1e80100-romulus: " Konrad Dybcio
2025-03-07 5:49 ` Dmitry Baryshkov
2025-03-06 18:11 ` [PATCH 11/11] arm64: dts: qcom: x1e001de-devkit: " Konrad Dybcio
2025-03-07 5:50 ` Dmitry Baryshkov
2025-03-14 20:00 ` (subset) [PATCH 00/11] Various dt-bindings fixes Bjorn Andersson
2025-05-04 16:13 ` Dmitry Baryshkov
2025-05-05 11:56 ` Rob Herring
2025-05-05 14:18 ` Dmitry Baryshkov
2025-05-19 10:58 ` Dmitry Baryshkov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250306-topic-dt_bindings_fixups-v1-7-0c84aceb0ef9@oss.qualcomm.com \
--to=konradybcio@kernel.org \
--cc=airlied@gmail.com \
--cc=andersson@kernel.org \
--cc=ansuelsmth@gmail.com \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=dmitry.baryshkov@linaro.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=freedreno@lists.freedesktop.org \
--cc=gregkh@linuxfoundation.org \
--cc=iommu@lists.linux.dev \
--cc=joro@8bytes.org \
--cc=konrad.dybcio@oss.qualcomm.com \
--cc=krzk+dt@kernel.org \
--cc=krzysztof.kozlowski@linaro.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=maarten.lankhorst@linux.intel.com \
--cc=marijn.suijten@somainline.org \
--cc=mripard@kernel.org \
--cc=quic_abhinavk@quicinc.com \
--cc=quic_chunkaid@quicinc.com \
--cc=quic_rohiagar@quicinc.com \
--cc=quic_wcheng@quicinc.com \
--cc=rfoss@kernel.org \
--cc=robdclark@gmail.com \
--cc=robh@kernel.org \
--cc=robin.murphy@arm.com \
--cc=sean@poorly.run \
--cc=simona@ffwll.ch \
--cc=tzimmermann@suse.de \
--cc=vkoul@kernel.org \
--cc=will@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®