From: Greg KH <gregkh@linuxfoundation.org>
To: Siddarth G <siddarthsgml@gmail.com>
Cc: abbotti@mev.co.uk, hsweeten@visionengravers.com,
skhan@linuxfoundation.org, linux-kernel@vger.kernel.org,
ruffalolavoisier@gmail.com, colin.i.king@gmail.com,
n.zhandarovich@fintech.ru
Subject: Re: [PATCH v2] staging: comedi: remove redundant filename references in headers
Date: Tue, 11 Mar 2025 12:17:17 +0100 [thread overview]
Message-ID: <2025031113-resize-charbroil-0d6d@gregkh> (raw)
In-Reply-To: <20250311100741.11999-1-siddarthsgml@gmail.com>
On Tue, Mar 11, 2025 at 03:37:41PM +0530, Siddarth G wrote:
> checkpatch.pl reports the following warning in COMEDI subsystem files:
> WARNING: It's generally not useful to have the filename in the file
> These file headers contain redundant filename references (e.g., "* comedi_buf.c"
> in comedi_buf.c) which are unnecessary.
> This patch removes these references from 14 files to comply with kernel coding
> standards and eliminate the warnings.
>
> Signed-off-by: Siddarth G <siddarthsgml@gmail.com>
> ---
> Changes in v2:
> -Included the exact checkpatch.pl warning in the commit message for clarity.
> ---
> drivers/comedi/comedi_buf.c | 1 -
> drivers/comedi/comedi_fops.c | 1 -
> drivers/comedi/comedi_pci.c | 1 -
> drivers/comedi/comedi_pcmcia.c | 1 -
> drivers/comedi/comedi_usb.c | 1 -
> drivers/comedi/drivers.c | 1 -
> drivers/comedi/drivers/ni_routing/ni_device_routes.c | 1 -
> drivers/comedi/drivers/ni_routing/ni_device_routes.h | 1 -
> drivers/comedi/drivers/ni_routing/ni_route_values.c | 1 -
> drivers/comedi/drivers/ni_routing/ni_route_values.h | 1 -
> drivers/comedi/drivers/tests/comedi_example_test.c | 1 -
> drivers/comedi/drivers/tests/ni_routes_test.c | 1 -
> drivers/comedi/drivers/tests/unittest.h | 1 -
> drivers/comedi/range.c | 1 -
These files are not in the "staging" directory, so no need for staging/
to be in the subject line at all :(
Also, start by working on checkpatch cleanups in the drivers/staging/
directory, not elsewhere in the kernel tree, so you get experience in
doing all of this properly before moving out to other areas. Also, some
subsystems do not want checkpatch cleanups, so be careful.
thanks,
greg k-h
prev parent reply other threads:[~2025-03-11 11:17 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-03-11 10:07 Siddarth G
2025-03-11 11:17 ` Greg KH [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2025031113-resize-charbroil-0d6d@gregkh \
--to=gregkh@linuxfoundation.org \
--cc=abbotti@mev.co.uk \
--cc=colin.i.king@gmail.com \
--cc=hsweeten@visionengravers.com \
--cc=linux-kernel@vger.kernel.org \
--cc=n.zhandarovich@fintech.ru \
--cc=ruffalolavoisier@gmail.com \
--cc=siddarthsgml@gmail.com \
--cc=skhan@linuxfoundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®