mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Ingo Molnar <mingo@kernel.org>
To: linux-kernel@vger.kernel.org
Cc: Juergen Gross <jgross@suse.com>,
	"H . Peter Anvin" <hpa@zytor.com>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	Peter Zijlstra <peterz@infradead.org>,
	Borislav Petkov <bp@alien8.de>,
	Thomas Gleixner <tglx@linutronix.de>,
	Ingo Molnar <mingo@kernel.org>
Subject: [PATCH 49/49] x86/alternatives: Rename 'apply_relocation()' to 'text_poke_apply_relocation()'
Date: Fri, 28 Mar 2025 14:27:04 +0100	[thread overview]
Message-ID: <20250328132704.1901674-50-mingo@kernel.org> (raw)
In-Reply-To: <20250328132704.1901674-1-mingo@kernel.org>

Join the text_poke_*() API namespace.

Signed-off-by: Ingo Molnar <mingo@kernel.org>
---
 arch/x86/include/asm/text-patching.h | 2 +-
 arch/x86/kernel/alternative.c        | 6 +++---
 arch/x86/kernel/callthunks.c         | 6 +++---
 3 files changed, 7 insertions(+), 7 deletions(-)

diff --git a/arch/x86/include/asm/text-patching.h b/arch/x86/include/asm/text-patching.h
index 53ac94743e5d..335f88b54ed0 100644
--- a/arch/x86/include/asm/text-patching.h
+++ b/arch/x86/include/asm/text-patching.h
@@ -15,7 +15,7 @@
 
 extern void text_poke_early(void *addr, const void *opcode, size_t len);
 
-extern void apply_relocation(u8 *buf, const u8 * const instr, size_t instrlen, u8 *repl, size_t repl_len);
+extern void text_poke_apply_relocation(u8 *buf, const u8 * const instr, size_t instrlen, u8 *repl, size_t repl_len);
 
 /*
  * Clear and restore the kernel write-protection flag on the local CPU.
diff --git a/arch/x86/kernel/alternative.c b/arch/x86/kernel/alternative.c
index a855db342c6a..cd5b69b6eff8 100644
--- a/arch/x86/kernel/alternative.c
+++ b/arch/x86/kernel/alternative.c
@@ -340,7 +340,7 @@ static void __apply_relocation(u8 *buf, const u8 * const instr, size_t instrlen,
 	}
 }
 
-void apply_relocation(u8 *buf, const u8 * const instr, size_t instrlen, u8 *repl, size_t repl_len)
+void text_poke_apply_relocation(u8 *buf, const u8 * const instr, size_t instrlen, u8 *repl, size_t repl_len)
 {
 	__apply_relocation(buf, instr, instrlen, repl, repl_len);
 	optimize_nops(instr, buf, instrlen);
@@ -496,7 +496,7 @@ void __init_or_module noinline apply_alternatives(struct alt_instr *start,
 		for (; insn_buff_sz < a->instrlen; insn_buff_sz++)
 			insn_buff[insn_buff_sz] = 0x90;
 
-		apply_relocation(insn_buff, instr, a->instrlen, replacement, a->replacementlen);
+		text_poke_apply_relocation(insn_buff, instr, a->instrlen, replacement, a->replacementlen);
 
 		DUMP_BYTES(ALT, instr, a->instrlen, "%px:   old_insn: ", instr);
 		DUMP_BYTES(ALT, replacement, a->replacementlen, "%px:   rpl_insn: ", replacement);
@@ -1981,7 +1981,7 @@ __visible noinline void __init __alt_reloc_selftest(void *arg)
 static noinline void __init alt_reloc_selftest(void)
 {
 	/*
-	 * Tests apply_relocation().
+	 * Tests text_poke_apply_relocation().
 	 *
 	 * This has a relative immediate (CALL) in a place other than the first
 	 * instruction and additionally on x86_64 we get a RIP-relative LEA:
diff --git a/arch/x86/kernel/callthunks.c b/arch/x86/kernel/callthunks.c
index 25ae54250112..e016c5780d42 100644
--- a/arch/x86/kernel/callthunks.c
+++ b/arch/x86/kernel/callthunks.c
@@ -186,7 +186,7 @@ static void *patch_dest(void *dest, bool direct)
 	u8 *pad = dest - tsize;
 
 	memcpy(insn_buff, skl_call_thunk_template, tsize);
-	apply_relocation(insn_buff, pad, tsize, skl_call_thunk_template, tsize);
+	text_poke_apply_relocation(insn_buff, pad, tsize, skl_call_thunk_template, tsize);
 
 	/* Already patched? */
 	if (!bcmp(pad, insn_buff, tsize))
@@ -295,7 +295,7 @@ static bool is_callthunk(void *addr)
 	pad = (void *)(dest - tmpl_size);
 
 	memcpy(insn_buff, skl_call_thunk_template, tmpl_size);
-	apply_relocation(insn_buff, pad, tmpl_size, skl_call_thunk_template, tmpl_size);
+	text_poke_apply_relocation(insn_buff, pad, tmpl_size, skl_call_thunk_template, tmpl_size);
 
 	return !bcmp(pad, insn_buff, tmpl_size);
 }
@@ -313,7 +313,7 @@ int x86_call_depth_emit_accounting(u8 **pprog, void *func, void *ip)
 		return 0;
 
 	memcpy(insn_buff, skl_call_thunk_template, tmpl_size);
-	apply_relocation(insn_buff, ip, tmpl_size, skl_call_thunk_template, tmpl_size);
+	text_poke_apply_relocation(insn_buff, ip, tmpl_size, skl_call_thunk_template, tmpl_size);
 
 	memcpy(*pprog, insn_buff, tmpl_size);
 	*pprog += tmpl_size;
-- 
2.45.2


  parent reply	other threads:[~2025-03-28 13:29 UTC|newest]

Thread overview: 69+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-03-28 13:26 [PATCH -v2 00/49] Simplify, reorganize and clean up the x86 text-patching code (alternative.c) Ingo Molnar
2025-03-28 13:26 ` [PATCH 01/49] x86/alternatives: Rename 'struct bp_patching_desc' to 'struct int3_patching_desc' Ingo Molnar
2025-03-28 13:26 ` [PATCH 02/49] x86/alternatives: Rename 'bp_refs' to 'int3_refs' Ingo Molnar
2025-03-28 13:26 ` [PATCH 03/49] x86/alternatives: Rename 'text_poke_bp_batch()' to 'smp_text_poke_batch_process()' Ingo Molnar
2025-03-28 13:26 ` [PATCH 04/49] x86/alternatives: Rename 'text_poke_bp()' to 'smp_text_poke_single()' Ingo Molnar
2025-03-28 13:26 ` [PATCH 05/49] x86/alternatives: Rename 'poke_int3_handler()' to 'smp_text_poke_int3_trap_handler()' Ingo Molnar
2025-03-28 13:26 ` [PATCH 06/49] x86/alternatives: Rename 'poking_mm' to 'text_poke_mm' Ingo Molnar
2025-03-28 13:26 ` [PATCH 07/49] x86/alternatives: Rename 'poking_addr' to 'text_poke_mm_addr' Ingo Molnar
2025-03-28 13:26 ` [PATCH 08/49] x86/alternatives: Rename 'bp_desc' to 'int3_desc' Ingo Molnar
2025-03-28 13:26 ` [PATCH 09/49] x86/alternatives: Remove duplicate 'text_poke_early()' prototype Ingo Molnar
2025-03-28 13:26 ` [PATCH 10/49] x86/alternatives: Update comments in int3_emulate_push() Ingo Molnar
2025-03-28 13:26 ` [PATCH 11/49] x86/alternatives: Remove the confusing, inaccurate & unnecessary 'temp_mm_state_t' abstraction Ingo Molnar
2025-04-01 14:36   ` Peter Zijlstra
2025-04-01 19:06     ` Ingo Molnar
2025-04-02  4:07       ` Ingo Molnar
2025-04-02  7:54         ` Peter Zijlstra
2025-03-28 13:26 ` [PATCH 12/49] x86/alternatives: Rename 'text_poke_flush()' to 'smp_text_poke_batch_flush()' Ingo Molnar
2025-03-28 13:26 ` [PATCH 13/49] x86/alternatives: Rename 'text_poke_finish()' to 'smp_text_poke_batch_finish()' Ingo Molnar
2025-03-28 13:26 ` [PATCH 14/49] x86/alternatives: Rename 'text_poke_queue()' to 'smp_text_poke_batch_add()' Ingo Molnar
2025-03-28 13:26 ` [PATCH 15/49] x86/alternatives: Rename 'text_poke_loc_init()' to 'text_poke_int3_loc_init()' Ingo Molnar
2025-03-28 13:26 ` [PATCH 16/49] x86/alternatives: Rename 'struct text_poke_loc' to 'struct smp_text_poke_loc' Ingo Molnar
2025-03-28 13:26 ` [PATCH 17/49] x86/alternatives: Rename 'struct int3_patching_desc' to 'struct text_poke_int3_vec' Ingo Molnar
2025-03-28 13:26 ` [PATCH 18/49] x86/alternatives: Rename 'int3_desc' to 'int3_vec' Ingo Molnar
2025-03-28 13:26 ` [PATCH 19/49] x86/alternatives: Add text_mutex) assert to smp_text_poke_batch_flush() Ingo Molnar
2025-03-28 13:26 ` [PATCH 20/49] x86/alternatives: Assert that smp_text_poke_int3_trap_handler() can only ever handle 'tp_vec[]' based requests Ingo Molnar
2025-03-28 13:26 ` [PATCH 21/49] x86/alternatives: Use non-inverted logic instead of 'tp_order_fail()' Ingo Molnar
2025-03-28 13:26 ` [PATCH 22/49] x86/alternatives: Remove the 'addr == NULL means forced-flush' hack from smp_text_poke_batch_finish()/smp_text_poke_batch_flush()/text_poke_addr_ordered() Ingo Molnar
2025-03-28 13:26 ` [PATCH 23/49] x86/alternatives: Simplify smp_text_poke_single() by using tp_vec and existing APIs Ingo Molnar
2025-04-01 14:40   ` Peter Zijlstra
2025-04-01 18:49     ` Ingo Molnar
2025-03-28 13:26 ` [PATCH 24/49] x86/alternatives: Assert input parameters in smp_text_poke_batch_process() Ingo Molnar
2025-03-28 13:26 ` [PATCH 25/49] x86/alternatives: Introduce 'struct smp_text_poke_array' and move tp_vec and tp_vec_nr to it Ingo Molnar
2025-03-28 13:26 ` [PATCH 26/49] x86/alternatives: Remove the tp_vec indirection Ingo Molnar
2025-03-28 13:26 ` [PATCH 27/49] x86/alternatives: Rename 'try_get_desc()' to 'try_get_text_poke_array()' Ingo Molnar
2025-03-28 13:26 ` [PATCH 28/49] x86/alternatives: Rename 'put_desc()' to 'put_text_poke_array()' Ingo Molnar
2025-03-28 13:26 ` [PATCH 29/49] x86/alternatives: Simplify try_get_text_poke_array() Ingo Molnar
2025-03-28 13:26 ` [PATCH 30/49] x86/alternatives: Simplify smp_text_poke_int3_trap_handler() Ingo Molnar
2025-03-28 13:26 ` [PATCH 31/49] x86/alternatives: Simplify smp_text_poke_batch_process() Ingo Molnar
2025-03-28 13:26 ` [PATCH 32/49] x86/alternatives: Rename 'int3_refs' to 'text_poke_array_refs' Ingo Molnar
2025-03-28 13:26 ` [PATCH 33/49] x86/alternatives: Move the text_poke_array manipulation into text_poke_int3_loc_init() and rename it to __smp_text_poke_batch_add() Ingo Molnar
2025-03-28 13:26 ` [PATCH 34/49] x86/alternatives: Remove the mixed-patching restriction on smp_text_poke_single() Ingo Molnar
2025-03-28 13:26 ` [PATCH 35/49] x86/alternatives: Document 'smp_text_poke_single()' Ingo Molnar
2025-03-28 13:26 ` [PATCH 36/49] x86/alternatives: Add documentation for smp_text_poke_batch_add() Ingo Molnar
2025-03-28 13:26 ` [PATCH 37/49] x86/alternatives: Move text_poke_array completion from smp_text_poke_batch_finish() and smp_text_poke_batch_flush() to smp_text_poke_batch_process() Ingo Molnar
2025-04-03 13:08   ` Nikolay Borisov
2025-04-03 13:38     ` Ingo Molnar
2025-04-03 13:41       ` Nikolay Borisov
2025-04-03 14:13         ` Ingo Molnar
2025-04-03 14:39           ` Nikolay Borisov
2025-04-03 15:29             ` Ingo Molnar
2025-04-03 15:34               ` Nikolay Borisov
2025-04-04  7:48                 ` Ingo Molnar
2025-03-28 13:26 ` [PATCH 38/49] x86/alternatives: Rename 'text_poke_sync()' to 'smp_text_poke_sync_each_cpu()' Ingo Molnar
2025-03-28 13:26 ` [PATCH 39/49] x86/alternatives: Simplify text_poke_addr_ordered() Ingo Molnar
2025-03-28 13:26 ` [PATCH 40/49] x86/alternatives: Constify text_poke_addr() Ingo Molnar
2025-03-28 13:26 ` [PATCH 41/49] x86/alternatives: Simplify and clean up patch_cmp() Ingo Molnar
2025-03-28 13:26 ` [PATCH 42/49] x86/alternatives: Standardize on 'tpl' local variable names for 'struct smp_text_poke_loc *' Ingo Molnar
2025-03-28 13:26 ` [PATCH 43/49] x86/alternatives: Rename 'TP_ARRAY_NR_ENTRIES_MAX' to 'TEXT_POKE_ARRAY_MAX' Ingo Molnar
2025-03-28 13:26 ` [PATCH 44/49] x86/alternatives: Rename 'POKE_MAX_OPCODE_SIZE' to 'TEXT_POKE_MAX_OPCODE_SIZE' Ingo Molnar
2025-03-28 13:27 ` [PATCH 45/49] x86/alternatives: Simplify the #include section Ingo Molnar
2025-03-28 13:27 ` [PATCH 46/49] x86/alternatives: Move declarations of vmlinux.lds.S defined section symbols to <asm/alternative.h> Ingo Molnar
2025-03-28 13:27 ` [PATCH 47/49] x86/alternatives: Remove 'smp_text_poke_batch_flush()' Ingo Molnar
2025-03-28 13:27 ` [PATCH 48/49] x86/alternatives: Update the comments in smp_text_poke_batch_process() Ingo Molnar
2025-03-28 13:27 ` Ingo Molnar [this message]
2025-04-01 14:31 ` [PATCH -v2 00/49] Simplify, reorganize and clean up the x86 text-patching code (alternative.c) Peter Zijlstra
2025-04-09 20:51   ` Ingo Molnar
2025-04-10 12:57     ` Peter Zijlstra
2025-04-01 14:31 ` Peter Zijlstra
2025-04-02  3:47   ` Ingo Molnar

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20250328132704.1901674-50-mingo@kernel.org \
    --to=mingo@kernel.org \
    --cc=bp@alien8.de \
    --cc=hpa@zytor.com \
    --cc=jgross@suse.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=peterz@infradead.org \
    --cc=tglx@linutronix.de \
    --cc=torvalds@linux-foundation.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®