mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Huan Tang <tanghuan@vivo.com>
To: bvanassche@acm.org
Cc: James.Bottomley@HansenPartnership.com, alim.akhtar@samsung.com,
	avri.altman@wdc.com, beanhuo@micron.com, ebiggers@google.com,
	keosung.park@samsung.com, linux-kernel@vger.kernel.org,
	linux-scsi@vger.kernel.org, linux@weissschuh.net,
	luhongfei@vivo.com, manivannan.sadhasivam@linaro.org,
	martin.petersen@oracle.com, minwoo.im@samsung.com,
	opensource.kernel@vivo.com, peter.wang@mediatek.com,
	quic_cang@quicinc.com, quic_mnaresh@quicinc.com,
	quic_nguyenb@quicinc.com, tanghuan@vivo.com,
	viro@zeniv.linux.org.uk
Subject: Re: [PATCH v7] ufs: core: Add WB buffer resize support
Date: Wed,  2 Apr 2025 16:07:57 +0800	[thread overview]
Message-ID: <20250402080757.449-1-tanghuan@vivo.com> (raw)
In-Reply-To: <467b9ba0-5dea-49c5-ab43-435d3d3fd6bc@acm.org>

> The description of the attribute contradicts the name of the attribute.
> Wouldn't wb_resize_enable be a better name for this attribute?
> Additionally, that name will be easier to recognize for anyone who is
> familiar with the UFS 4.1 standard.
> 
> To be consistent with other sysfs attributes, the names of the verbs
> should be changed from upper case to lower case and "Others - Reserved"
> should be left out. This comment also applies to the other attributes.
> 
> > +static const char *ufs_wb_resize_hint_to_string(enum wb_resize_hint hint)
> > +{
> > +	switch (hint) {
> > +	case WB_RESIZE_HINT_KEEP:	return "KEEP";
> > +	case WB_RESIZE_HINT_DECREASE:	return "DECREASE";
> > +	case WB_RESIZE_HINT_INCREASE:	return "INCREASE";
> > +	default:	return "UNKNOWN";
> > +	}
> > +}

> The formatting of the above switch/case statement is not compliant with
> the Linux kernel coding style.

Bart sir,

Thank you for your reply .
I have modified it according to your comments, as follows:
https://lore.kernel.org/all/20250402075710.224-1-tanghuan@vivo.com/

Thank you for your patience, please help review again.

Thanks
Huan

      reply	other threads:[~2025-04-02  8:08 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-04-02  1:45 Huan Tang
2025-04-02  4:20 ` Bart Van Assche
2025-04-02  8:07   ` Huan Tang [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20250402080757.449-1-tanghuan@vivo.com \
    --to=tanghuan@vivo.com \
    --cc=James.Bottomley@HansenPartnership.com \
    --cc=alim.akhtar@samsung.com \
    --cc=avri.altman@wdc.com \
    --cc=beanhuo@micron.com \
    --cc=bvanassche@acm.org \
    --cc=ebiggers@google.com \
    --cc=keosung.park@samsung.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-scsi@vger.kernel.org \
    --cc=linux@weissschuh.net \
    --cc=luhongfei@vivo.com \
    --cc=manivannan.sadhasivam@linaro.org \
    --cc=martin.petersen@oracle.com \
    --cc=minwoo.im@samsung.com \
    --cc=opensource.kernel@vivo.com \
    --cc=peter.wang@mediatek.com \
    --cc=quic_cang@quicinc.com \
    --cc=quic_mnaresh@quicinc.com \
    --cc=quic_nguyenb@quicinc.com \
    --cc=viro@zeniv.linux.org.uk \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®