mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Sebastian Andrzej Siewior <bigeasy@linutronix.de>
To: Marco Crivellari <marco.crivellari@suse.com>
Cc: linux-kernel@vger.kernel.org, Tejun Heo <tj@kernel.org>,
	Lai Jiangshan <jiangshanlai@gmail.com>,
	Thomas Gleixner <tglx@linutronix.de>,
	Frederic Weisbecker <frederic@kernel.org>
Subject: Re: [PATCH 4/4] Workqueue: add WQ_PERCPU to every alloc_workqueue user
Date: Mon, 5 May 2025 08:56:58 +0200	[thread overview]
Message-ID: <20250505065658.pHJpgrgL@linutronix.de> (raw)
In-Reply-To: <20250503082834.49413-5-marco.crivellari@suse.com>

On 2025-05-03 10:28:34 [+0200], Marco Crivellari wrote:
> By default, alloc_workqueue() creates bound workqueues
> (i.e., without WQ_UNBOUND).
> 
> With the introduction of the WQ_PERCPU flag (equivalent
> to !WQ_UNBOUND), any alloc_workqueue() caller that
> doesn’t explicitly specify WQ_UNBOUND must now use WQ_PERCPU.
> 
> All existing users have been updated accordingly.
> 
> Suggested-by: Tejun Heo <tj@kernel.org>
> Signed-off-by: Marco Crivellari <marco.crivellari@suse.com>

You could also update Documentation/core-api/workqueue.rst. You
introduce additional flags and you could note the default if this new
flag is missing.

Sebastian

  reply	other threads:[~2025-05-05  6:57 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-05-03  8:28 [PATCH 0/4] Workqueue: rename system workqueue and add WQ_PERCPU Marco Crivellari
2025-05-03  8:28 ` [PATCH 1/4] Workqueue: rename system_wq to system_percpu_wq Marco Crivellari
2025-05-03  8:28 ` [PATCH 2/4] Workqueue: rename system_unbound_wq to system_dfl_wq Marco Crivellari
2025-05-03  8:28 ` [PATCH 3/4] Workqueue: add WQ_PERCPU Marco Crivellari
2025-05-03  8:28 ` [PATCH 4/4] Workqueue: add WQ_PERCPU to every alloc_workqueue user Marco Crivellari
2025-05-05  6:56   ` Sebastian Andrzej Siewior [this message]
2025-05-05  9:22   ` Michal Hocko
2025-05-06 12:36     ` Frederic Weisbecker
2025-05-05  6:51 ` [PATCH 0/4] Workqueue: rename system workqueue and add WQ_PERCPU Sebastian Andrzej Siewior
2025-05-05  7:55   ` Marco Crivellari
2025-05-05  9:25   ` Michal Hocko
2025-05-06  7:53     ` Marco Crivellari
2025-05-05 23:39 ` Tejun Heo
2025-05-06 10:10   ` Marco Crivellari
2025-05-06 12:55     ` Frederic Weisbecker
2025-05-07  0:42       ` Tejun Heo
2025-05-07 12:04         ` Frederic Weisbecker

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20250505065658.pHJpgrgL@linutronix.de \
    --to=bigeasy@linutronix.de \
    --cc=frederic@kernel.org \
    --cc=jiangshanlai@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=marco.crivellari@suse.com \
    --cc=tglx@linutronix.de \
    --cc=tj@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®