From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
To: Zijun Hu <zijun_hu@icloud.com>
Cc: Arnd Bergmann <arnd@arndb.de>,
linux-kernel@vger.kernel.org,
Zijun Hu <zijun.hu@oss.qualcomm.com>
Subject: Re: [PATCH 2/3] char: misc: Rename a local variable in misc_init()
Date: Tue, 24 Jun 2025 16:47:49 +0100 [thread overview]
Message-ID: <2025062401-prenatal-hazily-7fc5@gregkh> (raw)
In-Reply-To: <20250620-fix_mischar-v1-2-6c2716bbf1fa@oss.qualcomm.com>
On Fri, Jun 20, 2025 at 10:35:19PM +0800, Zijun Hu wrote:
> From: Zijun Hu <zijun.hu@oss.qualcomm.com>
>
> Local variable @ret is not used for return value in misc_init().
>
> Give it a different name @pde.
>
> Signed-off-by: Zijun Hu <zijun.hu@oss.qualcomm.com>
> ---
> drivers/char/misc.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/char/misc.c b/drivers/char/misc.c
> index d5accc10a110098f7090dd0f900bc5fae5f75f74..f5ef8c175adb559e67dfe905d43d1404b249cc9e 100644
> --- a/drivers/char/misc.c
> +++ b/drivers/char/misc.c
> @@ -289,9 +289,9 @@ EXPORT_SYMBOL(misc_deregister);
> static int __init misc_init(void)
> {
> int err;
> - struct proc_dir_entry *ret;
> + struct proc_dir_entry *pde;
"pde" is an odd name.
> - ret = proc_create_seq("misc", 0, NULL, &misc_seq_ops);
> + pde = proc_create_seq("misc", 0, NULL, &misc_seq_ops);
Why not "misc_proc_file" as a better name?
> err = class_register(&misc_class);
> if (err)
> goto fail_remove;
> @@ -305,7 +305,7 @@ static int __init misc_init(void)
> pr_err("unable to get major %d for misc devices\n", MISC_MAJOR);
> class_unregister(&misc_class);
> fail_remove:
> - if (ret)
> + if (pde)
Again, "pde" is a rough name, let's pick a better one please.
thanks,
greg k-h
next prev parent reply other threads:[~2025-06-24 15:47 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-06-20 14:35 [PATCH 0/3] char: misc: Trivial cleanup Zijun Hu
2025-06-20 14:35 ` [PATCH 1/3] char: misc: Remove redundant forward declarations Zijun Hu
2025-06-20 14:35 ` [PATCH 2/3] char: misc: Rename a local variable in misc_init() Zijun Hu
2025-06-24 15:47 ` Greg Kroah-Hartman [this message]
2025-06-20 14:35 ` [PATCH 3/3] char: misc: Fix improper and inaccurate error code returned by misc_init() Zijun Hu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2025062401-prenatal-hazily-7fc5@gregkh \
--to=gregkh@linuxfoundation.org \
--cc=arnd@arndb.de \
--cc=linux-kernel@vger.kernel.org \
--cc=zijun.hu@oss.qualcomm.com \
--cc=zijun_hu@icloud.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®