From: Jiri Olsa <jolsa@kernel.org>
To: Oleg Nesterov <oleg@redhat.com>,
Peter Zijlstra <peterz@infradead.org>,
Andrii Nakryiko <andrii@kernel.org>
Cc: bpf@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-trace-kernel@vger.kernel.org, x86@kernel.org,
"Song Liu" <songliubraving@fb.com>, "Yonghong Song" <yhs@fb.com>,
"John Fastabend" <john.fastabend@gmail.com>,
"Hao Luo" <haoluo@google.com>,
"Steven Rostedt" <rostedt@goodmis.org>,
"Masami Hiramatsu" <mhiramat@kernel.org>,
"Alan Maguire" <alan.maguire@oracle.com>,
"David Laight" <David.Laight@ACULAB.COM>,
"Thomas Weißschuh" <thomas@t-8ch.de>,
"Ingo Molnar" <mingo@kernel.org>
Subject: [PATCHv6 perf/core 18/22] selftests/bpf: Add uprobe_regs_equal test
Date: Sun, 20 Jul 2025 13:21:28 +0200 [thread overview]
Message-ID: <20250720112133.244369-19-jolsa@kernel.org> (raw)
In-Reply-To: <20250720112133.244369-1-jolsa@kernel.org>
Changing uretprobe_regs_trigger to allow the test for both
uprobe and uretprobe and renaming it to uprobe_regs_equal.
We check that both uprobe and uretprobe probes (bpf programs)
see expected registers with few exceptions.
Acked-by: Andrii Nakryiko <andrii@kernel.org>
Signed-off-by: Jiri Olsa <jolsa@kernel.org>
---
.../selftests/bpf/prog_tests/uprobe_syscall.c | 56 ++++++++++++++-----
.../selftests/bpf/progs/uprobe_syscall.c | 4 +-
2 files changed, 44 insertions(+), 16 deletions(-)
diff --git a/tools/testing/selftests/bpf/prog_tests/uprobe_syscall.c b/tools/testing/selftests/bpf/prog_tests/uprobe_syscall.c
index 02e98cba5cc6..36ce9e261b5c 100644
--- a/tools/testing/selftests/bpf/prog_tests/uprobe_syscall.c
+++ b/tools/testing/selftests/bpf/prog_tests/uprobe_syscall.c
@@ -22,15 +22,17 @@
#pragma GCC diagnostic ignored "-Wattributes"
-__naked unsigned long uretprobe_regs_trigger(void)
+__attribute__((aligned(16)))
+__nocf_check __weak __naked unsigned long uprobe_regs_trigger(void)
{
asm volatile (
+ ".byte 0x0f, 0x1f, 0x44, 0x00, 0x00\n" /* nop5 */
"movq $0xdeadbeef, %rax\n"
"ret\n"
);
}
-__naked void uretprobe_regs(struct pt_regs *before, struct pt_regs *after)
+__naked void uprobe_regs(struct pt_regs *before, struct pt_regs *after)
{
asm volatile (
"movq %r15, 0(%rdi)\n"
@@ -51,15 +53,17 @@ __naked void uretprobe_regs(struct pt_regs *before, struct pt_regs *after)
"movq $0, 120(%rdi)\n" /* orig_rax */
"movq $0, 128(%rdi)\n" /* rip */
"movq $0, 136(%rdi)\n" /* cs */
+ "pushq %rax\n"
"pushf\n"
"pop %rax\n"
"movq %rax, 144(%rdi)\n" /* eflags */
+ "pop %rax\n"
"movq %rsp, 152(%rdi)\n" /* rsp */
"movq $0, 160(%rdi)\n" /* ss */
/* save 2nd argument */
"pushq %rsi\n"
- "call uretprobe_regs_trigger\n"
+ "call uprobe_regs_trigger\n"
/* save return value and load 2nd argument pointer to rax */
"pushq %rax\n"
@@ -99,25 +103,37 @@ __naked void uretprobe_regs(struct pt_regs *before, struct pt_regs *after)
);
}
-static void test_uretprobe_regs_equal(void)
+static void test_uprobe_regs_equal(bool retprobe)
{
+ LIBBPF_OPTS(bpf_uprobe_opts, opts,
+ .retprobe = retprobe,
+ );
struct uprobe_syscall *skel = NULL;
struct pt_regs before = {}, after = {};
unsigned long *pb = (unsigned long *) &before;
unsigned long *pa = (unsigned long *) &after;
unsigned long *pp;
+ unsigned long offset;
unsigned int i, cnt;
- int err;
+
+ offset = get_uprobe_offset(&uprobe_regs_trigger);
+ if (!ASSERT_GE(offset, 0, "get_uprobe_offset"))
+ return;
skel = uprobe_syscall__open_and_load();
if (!ASSERT_OK_PTR(skel, "uprobe_syscall__open_and_load"))
goto cleanup;
- err = uprobe_syscall__attach(skel);
- if (!ASSERT_OK(err, "uprobe_syscall__attach"))
+ skel->links.probe = bpf_program__attach_uprobe_opts(skel->progs.probe,
+ 0, "/proc/self/exe", offset, &opts);
+ if (!ASSERT_OK_PTR(skel->links.probe, "bpf_program__attach_uprobe_opts"))
goto cleanup;
- uretprobe_regs(&before, &after);
+ /* make sure uprobe gets optimized */
+ if (!retprobe)
+ uprobe_regs_trigger();
+
+ uprobe_regs(&before, &after);
pp = (unsigned long *) &skel->bss->regs;
cnt = sizeof(before)/sizeof(*pb);
@@ -126,7 +142,7 @@ static void test_uretprobe_regs_equal(void)
unsigned int offset = i * sizeof(unsigned long);
/*
- * Check register before and after uretprobe_regs_trigger call
+ * Check register before and after uprobe_regs_trigger call
* that triggers the uretprobe.
*/
switch (offset) {
@@ -140,7 +156,7 @@ static void test_uretprobe_regs_equal(void)
/*
* Check register seen from bpf program and register after
- * uretprobe_regs_trigger call
+ * uprobe_regs_trigger call (with rax exception, check below).
*/
switch (offset) {
/*
@@ -153,6 +169,15 @@ static void test_uretprobe_regs_equal(void)
case offsetof(struct pt_regs, rsp):
case offsetof(struct pt_regs, ss):
break;
+ /*
+ * uprobe does not see return value in rax, it needs to see the
+ * original (before) rax value
+ */
+ case offsetof(struct pt_regs, rax):
+ if (!retprobe) {
+ ASSERT_EQ(pp[i], pb[i], "uprobe rax prog-before value check");
+ break;
+ }
default:
if (!ASSERT_EQ(pp[i], pa[i], "register prog-after value check"))
fprintf(stdout, "failed register offset %u\n", offset);
@@ -190,13 +215,13 @@ static void test_uretprobe_regs_change(void)
unsigned long cnt = sizeof(before)/sizeof(*pb);
unsigned int i, err, offset;
- offset = get_uprobe_offset(uretprobe_regs_trigger);
+ offset = get_uprobe_offset(uprobe_regs_trigger);
err = write_bpf_testmod_uprobe(offset);
if (!ASSERT_OK(err, "register_uprobe"))
return;
- uretprobe_regs(&before, &after);
+ uprobe_regs(&before, &after);
err = write_bpf_testmod_uprobe(0);
if (!ASSERT_OK(err, "unregister_uprobe"))
@@ -616,7 +641,8 @@ static void test_uretprobe_shadow_stack(void)
/* Run all the tests with shadow stack in place. */
shstk_is_enabled = true;
- test_uretprobe_regs_equal();
+ test_uprobe_regs_equal(false);
+ test_uprobe_regs_equal(true);
test_uretprobe_regs_change();
test_uretprobe_syscall_call();
@@ -772,7 +798,7 @@ static void test_uprobe_sigill(void)
static void __test_uprobe_syscall(void)
{
if (test__start_subtest("uretprobe_regs_equal"))
- test_uretprobe_regs_equal();
+ test_uprobe_regs_equal(true);
if (test__start_subtest("uretprobe_regs_change"))
test_uretprobe_regs_change();
if (test__start_subtest("uretprobe_syscall_call"))
@@ -791,6 +817,8 @@ static void __test_uprobe_syscall(void)
test_uprobe_race();
if (test__start_subtest("uprobe_sigill"))
test_uprobe_sigill();
+ if (test__start_subtest("uprobe_regs_equal"))
+ test_uprobe_regs_equal(false);
}
#else
static void __test_uprobe_syscall(void)
diff --git a/tools/testing/selftests/bpf/progs/uprobe_syscall.c b/tools/testing/selftests/bpf/progs/uprobe_syscall.c
index 8a4fa6c7ef59..e08c31669e5a 100644
--- a/tools/testing/selftests/bpf/progs/uprobe_syscall.c
+++ b/tools/testing/selftests/bpf/progs/uprobe_syscall.c
@@ -7,8 +7,8 @@ struct pt_regs regs;
char _license[] SEC("license") = "GPL";
-SEC("uretprobe//proc/self/exe:uretprobe_regs_trigger")
-int uretprobe(struct pt_regs *ctx)
+SEC("uprobe")
+int probe(struct pt_regs *ctx)
{
__builtin_memcpy(®s, ctx, sizeof(regs));
return 0;
--
2.50.1
next prev parent reply other threads:[~2025-07-20 11:25 UTC|newest]
Thread overview: 85+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-07-20 11:21 [PATCHv6 perf/core 00/22] uprobes: Add support to optimize usdt probes on x86_64 Jiri Olsa
2025-07-20 11:21 ` [PATCHv6 perf/core 01/22] uprobes: Remove breakpoint in unapply_uprobe under mmap_write_lock Jiri Olsa
2025-08-25 10:25 ` [tip: perf/core] " tip-bot2 for Jiri Olsa
2025-07-20 11:21 ` [PATCHv6 perf/core 02/22] uprobes: Rename arch_uretprobe_trampoline function Jiri Olsa
2025-08-25 10:25 ` [tip: perf/core] " tip-bot2 for Jiri Olsa
2025-07-20 11:21 ` [PATCHv6 perf/core 03/22] uprobes: Make copy_from_page global Jiri Olsa
2025-08-25 10:25 ` [tip: perf/core] " tip-bot2 for Jiri Olsa
2025-07-20 11:21 ` [PATCHv6 perf/core 04/22] uprobes: Add uprobe_write function Jiri Olsa
2025-08-25 10:25 ` [tip: perf/core] " tip-bot2 for Jiri Olsa
2025-07-20 11:21 ` [PATCHv6 perf/core 05/22] uprobes: Add nbytes argument to uprobe_write Jiri Olsa
2025-08-25 10:25 ` [tip: perf/core] " tip-bot2 for Jiri Olsa
2025-07-20 11:21 ` [PATCHv6 perf/core 06/22] uprobes: Add is_register argument to uprobe_write and uprobe_write_opcode Jiri Olsa
2025-08-25 10:25 ` [tip: perf/core] " tip-bot2 for Jiri Olsa
2025-07-20 11:21 ` [PATCHv6 perf/core 07/22] uprobes: Add do_ref_ctr argument to uprobe_write function Jiri Olsa
2025-08-25 10:25 ` [tip: perf/core] " tip-bot2 for Jiri Olsa
2025-07-20 11:21 ` [PATCHv6 perf/core 08/22] uprobes/x86: Add mapping for optimized uprobe trampolines Jiri Olsa
2025-08-19 14:53 ` Peter Zijlstra
2025-08-20 12:18 ` Jiri Olsa
2025-08-25 10:25 ` [tip: perf/core] " tip-bot2 for Jiri Olsa
2025-07-20 11:21 ` [PATCHv6 perf/core 09/22] uprobes/x86: Add uprobe syscall to speed up uprobe Jiri Olsa
2025-07-20 11:38 ` Oleg Nesterov
2025-07-25 10:11 ` Masami Hiramatsu
2025-08-25 10:24 ` [tip: perf/core] " tip-bot2 for Jiri Olsa
2025-09-03 18:24 ` [PATCHv6 perf/core 09/22] " Andrii Nakryiko
2025-09-03 20:56 ` Jiri Olsa
2025-09-03 21:01 ` Peter Zijlstra
2025-09-03 23:12 ` Andrii Nakryiko
2025-09-04 7:56 ` Jiri Olsa
2025-09-04 9:39 ` Jann Horn
2025-09-04 14:03 ` Jiri Olsa
2025-09-04 18:32 ` Andrii Nakryiko
2025-09-05 10:46 ` Jiri Olsa
2025-09-05 18:44 ` Andrii Nakryiko
2025-09-04 8:13 ` Jiri Olsa
2025-09-04 18:27 ` nop5-optimized USDTs WAS: " Andrii Nakryiko
2025-09-04 20:35 ` Peter Zijlstra
2025-09-04 20:49 ` Andrii Nakryiko
2025-09-04 20:52 ` Peter Zijlstra
2025-09-04 21:44 ` Andrii Nakryiko
2025-09-04 21:56 ` Peter Zijlstra
2025-09-04 21:58 ` Peter Zijlstra
2025-09-05 8:24 ` Peter Zijlstra
2025-09-05 8:38 ` Peter Zijlstra
2025-09-10 14:30 ` Andrii Nakryiko
2025-07-20 11:21 ` [PATCHv6 perf/core 10/22] uprobes/x86: Add support to optimize uprobes Jiri Olsa
2025-07-25 10:13 ` Masami Hiramatsu
2025-07-28 21:34 ` Jiri Olsa
2025-08-08 17:44 ` Jiri Olsa
2025-08-19 19:17 ` Peter Zijlstra
2025-08-20 12:19 ` Jiri Olsa
2025-08-19 19:15 ` Peter Zijlstra
2025-08-20 12:19 ` Jiri Olsa
2025-08-20 13:01 ` Peter Zijlstra
2025-08-20 12:30 ` Peter Zijlstra
2025-08-20 15:58 ` Edgecombe, Rick P
2025-08-20 17:12 ` Peter Zijlstra
2025-08-20 17:26 ` Edgecombe, Rick P
2025-08-20 17:43 ` Peter Zijlstra
2025-08-20 18:04 ` Edgecombe, Rick P
2025-08-20 21:38 ` Jiri Olsa
2025-09-03 6:48 ` Jiri Olsa
2025-08-25 10:24 ` [tip: perf/core] " tip-bot2 for Jiri Olsa
2025-07-20 11:21 ` [PATCHv6 perf/core 11/22] selftests/bpf: Import usdt.h from libbpf/usdt project Jiri Olsa
2025-08-25 10:24 ` [tip: perf/core] " tip-bot2 for Jiri Olsa
2025-07-20 11:21 ` [PATCHv6 perf/core 12/22] selftests/bpf: Reorg the uprobe_syscall test function Jiri Olsa
2025-08-25 10:24 ` [tip: perf/core] " tip-bot2 for Jiri Olsa
2025-07-20 11:21 ` [PATCHv6 perf/core 13/22] selftests/bpf: Rename uprobe_syscall_executed prog to test_uretprobe_multi Jiri Olsa
2025-08-25 10:24 ` [tip: perf/core] " tip-bot2 for Jiri Olsa
2025-07-20 11:21 ` [PATCHv6 perf/core 14/22] selftests/bpf: Add uprobe/usdt syscall tests Jiri Olsa
2025-08-25 10:24 ` [tip: perf/core] " tip-bot2 for Jiri Olsa
2025-07-20 11:21 ` [PATCHv6 perf/core 15/22] selftests/bpf: Add hit/attach/detach race optimized uprobe test Jiri Olsa
2025-08-25 10:24 ` [tip: perf/core] " tip-bot2 for Jiri Olsa
2025-07-20 11:21 ` [PATCHv6 perf/core 16/22] selftests/bpf: Add uprobe syscall sigill signal test Jiri Olsa
2025-08-25 10:24 ` [tip: perf/core] " tip-bot2 for Jiri Olsa
2025-07-20 11:21 ` [PATCHv6 perf/core 17/22] selftests/bpf: Add optimized usdt variant for basic usdt test Jiri Olsa
2025-08-25 10:24 ` [tip: perf/core] " tip-bot2 for Jiri Olsa
2025-07-20 11:21 ` Jiri Olsa [this message]
2025-08-25 10:24 ` [tip: perf/core] selftests/bpf: Add uprobe_regs_equal test tip-bot2 for Jiri Olsa
2025-07-20 11:21 ` [PATCHv6 perf/core 19/22] selftests/bpf: Change test_uretprobe_regs_change for uprobe and uretprobe Jiri Olsa
2025-08-25 10:24 ` [tip: perf/core] " tip-bot2 for Jiri Olsa
2025-07-20 11:21 ` [PATCHv6 perf/core 20/22] seccomp: passthrough uprobe systemcall without filtering Jiri Olsa
2025-08-25 10:24 ` [tip: perf/core] " tip-bot2 for Jiri Olsa
2025-07-20 11:21 ` [PATCHv6 perf/core 21/22] selftests/seccomp: validate uprobe syscall passes through seccomp Jiri Olsa
2025-08-25 10:24 ` [tip: perf/core] " tip-bot2 for Jiri Olsa
2025-07-20 11:21 ` [PATCHv5 22/22] man2: Add uprobe syscall page Jiri Olsa
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250720112133.244369-19-jolsa@kernel.org \
--to=jolsa@kernel.org \
--cc=David.Laight@ACULAB.COM \
--cc=alan.maguire@oracle.com \
--cc=andrii@kernel.org \
--cc=bpf@vger.kernel.org \
--cc=haoluo@google.com \
--cc=john.fastabend@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-trace-kernel@vger.kernel.org \
--cc=mhiramat@kernel.org \
--cc=mingo@kernel.org \
--cc=oleg@redhat.com \
--cc=peterz@infradead.org \
--cc=rostedt@goodmis.org \
--cc=songliubraving@fb.com \
--cc=thomas@t-8ch.de \
--cc=x86@kernel.org \
--cc=yhs@fb.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®