From: Nam Cao <namcao@linutronix.de>
To: Gabriele Monaco <gmonaco@redhat.com>
Cc: linux-kernel@vger.kernel.org,
Steven Rostedt <rostedt@goodmis.org>,
Masami Hiramatsu <mhiramat@kernel.org>,
linux-trace-kernel@vger.kernel.org,
Ingo Molnar <mingo@redhat.com>,
Peter Zijlstra <peterz@infradead.org>,
Tomas Glozar <tglozar@redhat.com>, Juri Lelli <jlelli@redhat.com>,
Clark Williams <williams@redhat.com>,
John Kacur <jkacur@redhat.com>
Subject: Re: [PATCH v4 08/14] verification/rvgen: Organise Kconfig entries for nested monitors
Date: Mon, 21 Jul 2025 16:38:14 +0200 [thread overview]
Message-ID: <20250721143814.waTN9e5C@linutronix.de> (raw)
In-Reply-To: <20250721082325.71554-9-gmonaco@redhat.com>
On Mon, Jul 21, 2025 at 10:23:18AM +0200, Gabriele Monaco wrote:
> The current behaviour of rvgen when running with the -a option is to
> append the necessary lines at the end of the configuration for Kconfig,
> Makefile and tracepoints.
> This is not always the desired behaviour in case of nested monitors:
> while tracepoints are not affected by nesting and the Makefile's only
> requirement is that the parent monitor is built before its children, in
> the Kconfig it is better to have children defined right after their
> parent, otherwise the result has wrong indentation:
>
> [*] foo_parent monitor
> [*] foo_child1 monitor
> [*] foo_child2 monitor
> [*] bar_parent monitor
> [*] bar_child1 monitor
> [*] bar_child2 monitor
> [*] foo_child3 monitor
> [*] foo_child4 monitor
>
> Adapt rvgen to look for a different marker for nested monitors in the
> Kconfig file and append the line right after the last sibling, instead
> of the last monitor.
> Also add the marker when creating a new parent monitor.
>
> Signed-off-by: Gabriele Monaco <gmonaco@redhat.com>
Some nitpicks below. But regardless:
Reviewed-by: Nam Cao <namcao@linutronix.de>
> - def __patch_file(self, file, marker, line):
> + def _patch_file(self, file, marker, line):
> + assert(self.auto_patch)
Nit: follows PEP8 unless there is a reason not to: assert self.auto_patch
> file_to_patch = os.path.join(self.rv_dir, file)
> content = self._read_file(file_to_patch)
> content = content.replace(marker, line + "\n" + marker)
> @@ -146,7 +147,7 @@ class RVGenerator:
> def fill_tracepoint_tooltip(self):
> monitor_class_type = self.fill_monitor_class_type()
> if self.auto_patch:
> - self.__patch_file("rv_trace.h",
> + self._patch_file("rv_trace.h",
> "// Add new monitors based on CONFIG_%s here" % monitor_class_type,
> "#include <monitors/%s/%s_trace.h>" % (self.name, self.name))
> return " - Patching %s/rv_trace.h, double check the result" % self.rv_dir
> @@ -156,10 +157,15 @@ Add this line where other tracepoints are included and %s is defined:
> #include <monitors/%s/%s_trace.h>
> """ % (self.rv_dir, monitor_class_type, self.name, self.name)
>
> + def _container_marker(self, container = None) -> str:
> + return "# Add new %smonitors here" % (container + " "
> + if container else "")
PEP8: container=None
And this function name is misleading, it is not marker for only containers.
Perhaps _kconfig_marker() is more appropriate.
next prev parent reply other threads:[~2025-07-21 14:38 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-07-21 8:23 [PATCH v4 00/14] rv: Add monitors to validate task switch Gabriele Monaco
2025-07-21 8:23 ` [PATCH v4 01/14] tools/rv: Do not skip idle in trace Gabriele Monaco
2025-07-21 8:23 ` [PATCH v4 02/14] tools/rv: Stop gracefully also on SIGTERM Gabriele Monaco
2025-07-21 8:23 ` [PATCH v4 03/14] rv: Add da_handle_start_run_event_ to per-task monitors Gabriele Monaco
2025-07-21 8:23 ` [PATCH v4 04/14] rv: Remove trailing whitespace from tracepoint string Gabriele Monaco
2025-07-21 8:23 ` [PATCH v4 05/14] rv: Return init error when registering monitors Gabriele Monaco
2025-07-21 8:23 ` [PATCH v4 06/14] rv: Use strings in da monitors tracepoints Gabriele Monaco
2025-07-21 8:23 ` [PATCH v4 07/14] rv: Adjust monitor dependencies Gabriele Monaco
2025-07-21 8:23 ` [PATCH v4 08/14] verification/rvgen: Organise Kconfig entries for nested monitors Gabriele Monaco
2025-07-21 14:38 ` Nam Cao [this message]
2025-07-21 15:17 ` Gabriele Monaco
2025-07-21 8:23 ` [PATCH v4 09/14] tools/dot2c: Fix generated files going over 100 column limit Gabriele Monaco
2025-07-21 14:52 ` Nam Cao
2025-07-23 11:18 ` Gabriele Monaco
2025-07-21 8:23 ` [PATCH v4 10/14] rv: Retry when da monitor detects race conditions Gabriele Monaco
2025-07-21 15:01 ` Nam Cao
2025-07-21 15:23 ` Gabriele Monaco
2025-07-21 8:23 ` [PATCH v4 11/14] sched: Adapt sched tracepoints for RV task model Gabriele Monaco
2025-07-21 8:23 ` [PATCH v4 12/14] rv: Replace tss and sncid monitors with more complete sts Gabriele Monaco
2025-07-21 15:15 ` Nam Cao
2025-07-21 16:13 ` Gabriele Monaco
2025-07-21 8:23 ` [PATCH v4 13/14] rv: Add nrp and sssw per-task monitors Gabriele Monaco
2025-07-21 8:23 ` [PATCH v4 14/14] rv: Add opid per-cpu monitor Gabriele Monaco
2025-07-23 0:50 ` [PATCH v4 00/14] rv: Add monitors to validate task switch Steven Rostedt
2025-07-23 9:55 ` Gabriele Monaco
2025-07-23 14:22 ` Steven Rostedt
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250721143814.waTN9e5C@linutronix.de \
--to=namcao@linutronix.de \
--cc=gmonaco@redhat.com \
--cc=jkacur@redhat.com \
--cc=jlelli@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-trace-kernel@vger.kernel.org \
--cc=mhiramat@kernel.org \
--cc=mingo@redhat.com \
--cc=peterz@infradead.org \
--cc=rostedt@goodmis.org \
--cc=tglozar@redhat.com \
--cc=williams@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®