mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Krishna Chaitanya Chundru <krishna.chundru@oss.qualcomm.com>
To: "Viresh Kumar" <vireshk@kernel.org>, "Nishanth Menon" <nm@ti.com>,
	"Stephen Boyd" <sboyd@kernel.org>,
	"Rafael J. Wysocki" <rafael@kernel.org>,
	"Manivannan Sadhasivam" <mani@kernel.org>,
	"Lorenzo Pieralisi" <lpieralisi@kernel.org>,
	"Krzysztof Wilczyński" <kwilczynski@kernel.org>,
	"Rob Herring" <robh@kernel.org>,
	"Bjorn Helgaas" <bhelgaas@google.com>,
	"Bjorn Andersson" <andersson@kernel.org>,
	"Konrad Dybcio" <konradybcio@kernel.org>,
	"Krzysztof Kozlowski" <krzk+dt@kernel.org>,
	"Conor Dooley" <conor+dt@kernel.org>
Cc: linux-pm@vger.kernel.org, linux-kernel@vger.kernel.org,
	linux-pci@vger.kernel.org, linux-arm-msm@vger.kernel.org,
	devicetree@vger.kernel.org,
	Krishna Chaitanya Chundru <krishna.chundru@oss.qualcomm.com>
Subject: [PATCH v4 2/7] OPP: Move refcount and key update for readability in _opp_table_find_key()
Date: Wed, 20 Aug 2025 13:58:48 +0530	[thread overview]
Message-ID: <20250820-opp_pcie-v4-2-273b8944eed0@oss.qualcomm.com> (raw)
In-Reply-To: <20250820-opp_pcie-v4-0-273b8944eed0@oss.qualcomm.com>

Refactor _opp_table_find_key() to improve readability by moving the
reference count increment and key update inside the match condition block.

Also make the 'assert' check mandatory instead of treating it as optional.

Signed-off-by: Krishna Chaitanya Chundru <krishna.chundru@oss.qualcomm.com>
---
 drivers/opp/core.c | 14 ++++++--------
 1 file changed, 6 insertions(+), 8 deletions(-)

diff --git a/drivers/opp/core.c b/drivers/opp/core.c
index a36c3daac39cd0bdd2a1f7e9bad5b92f0c756153..bf49709b8c39271431772924daf0c003b45eec7f 100644
--- a/drivers/opp/core.c
+++ b/drivers/opp/core.c
@@ -544,24 +544,22 @@ static struct dev_pm_opp *_opp_table_find_key(struct opp_table *opp_table,
 	struct dev_pm_opp *temp_opp, *opp = ERR_PTR(-ERANGE);
 
 	/* Assert that the requirement is met */
-	if (assert && !assert(opp_table, index))
+	if (!assert(opp_table, index))
 		return ERR_PTR(-EINVAL);
 
 	guard(mutex)(&opp_table->lock);
 
 	list_for_each_entry(temp_opp, &opp_table->opp_list, node) {
 		if (temp_opp->available == available) {
-			if (compare(&opp, temp_opp, read(temp_opp, index), *key))
+			if (compare(&opp, temp_opp, read(temp_opp, index), *key)) {
+				/* Increment the reference count of OPP */
+				*key = read(opp, index);
+				dev_pm_opp_get(opp);
 				break;
+			}
 		}
 	}
 
-	/* Increment the reference count of OPP */
-	if (!IS_ERR(opp)) {
-		*key = read(opp, index);
-		dev_pm_opp_get(opp);
-	}
-
 	return opp;
 }
 

-- 
2.34.1


  parent reply	other threads:[~2025-08-20  8:29 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-08-20  8:28 [PATCH v4 0/7] OPP: Add support to find OPP for a set of keys Krishna Chaitanya Chundru
2025-08-20  8:28 ` [PATCH v4 1/7] " Krishna Chaitanya Chundru
2025-08-22  6:50   ` Viresh Kumar
2025-08-20  8:28 ` Krishna Chaitanya Chundru [this message]
2025-08-22  6:51   ` [PATCH v4 2/7] OPP: Move refcount and key update for readability in _opp_table_find_key() Viresh Kumar
     [not found]   ` <CGME20250825135939eucas1p206b6e2b5ba115f51618c773a1f37939c@eucas1p2.samsung.com>
2025-08-25 13:59     ` Marek Szyprowski
2025-08-25 15:56       ` Krishna Chaitanya Chundru
2025-08-26  6:10         ` Viresh Kumar
2025-08-26  6:06       ` Viresh Kumar
2025-08-26  7:26         ` Marek Szyprowski
2025-08-26  8:24           ` Viresh Kumar
2025-08-26 11:25       ` Krzysztof Kozlowski
2025-08-20  8:28 ` [PATCH v4 3/7] arm64: dts: qcom: sm8450: Add opp-level to indicate PCIe data rates Krishna Chaitanya Chundru
2025-08-26  5:57   ` Manivannan Sadhasivam
2025-08-26  6:08   ` Manivannan Sadhasivam
2025-08-20  8:28 ` [PATCH v4 4/7] arm64: dts: qcom: sm8550: " Krishna Chaitanya Chundru
2025-08-20  8:28 ` [PATCH v4 5/7] arm64: dts: qcom: sm8650: " Krishna Chaitanya Chundru
2025-08-20  8:28 ` [PATCH v4 6/7] arm64: dts: qcom: x1e80100: " Krishna Chaitanya Chundru
2025-08-20  8:28 ` [PATCH v4 7/7] PCI: qcom: Use frequency and level based OPP lookup Krishna Chaitanya Chundru
2025-08-20  8:55   ` Neil Armstrong
2025-08-26  5:54   ` Manivannan Sadhasivam
2025-08-25 16:44 ` [PATCH v4 0/7] OPP: Add support to find OPP for a set of keys Wasim Nazir
2025-08-26  5:20   ` Viresh Kumar
2025-08-26  5:36     ` Viresh Kumar
2025-08-26  8:27       ` Viresh Kumar

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20250820-opp_pcie-v4-2-273b8944eed0@oss.qualcomm.com \
    --to=krishna.chundru@oss.qualcomm.com \
    --cc=andersson@kernel.org \
    --cc=bhelgaas@google.com \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=konradybcio@kernel.org \
    --cc=krzk+dt@kernel.org \
    --cc=kwilczynski@kernel.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=lpieralisi@kernel.org \
    --cc=mani@kernel.org \
    --cc=nm@ti.com \
    --cc=rafael@kernel.org \
    --cc=robh@kernel.org \
    --cc=sboyd@kernel.org \
    --cc=vireshk@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®