mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Adrian Barnaś" <abarnas@google.com>
To: Hans de Goede <hansg@kernel.org>,
	Mauro Carvalho Chehab <mchehab@kernel.org>,
	 Sakari Ailus <sakari.ailus@linux.intel.com>,
	Andy Shevchenko <andy@kernel.org>,
	 Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Dan Carpenter <dan.carpenter@linaro.org>,
	 linux-media@vger.kernel.org, linux-kernel@vger.kernel.org,
	 linux-staging@lists.linux.dev
Cc: "Adrian Barnaś" <abarnas@google.com>
Subject: [RFC PATCH v2 0/2] staging: media: atomisp: Refactor bit logic helpers in vmem.c
Date: Wed,  3 Sep 2025 09:27:52 +0000	[thread overview]
Message-ID: <20250903092754.2751556-1-abarnas@google.com> (raw)

Refactor proposition for bit operation in vmem.c.
* Previous name for function "inv_subword()" for me is not telling what
function acctualy does - it clears bit specified by subword, so renamed
to clear_subword()
* Added a helper to create a proper bitmask for a subword, without using
GENMASK(end-1, start) which was claimed to be unsafe
* Simplified subword() and clear_subword() to be more readable.

Continuation of https://lore.kernel.org/linux-staging/20250902073841.2338568-1-abarnas@google.com/ 

Adrian Barnaś (2):
  staging: media: atomisp: Change name to better follow its behavior
  staging: media: atomisp: Simplify logic in vmem.c

 .../pci/hive_isp_css_common/host/vmem.c       | 19 ++++++++++++-------
 1 file changed, 12 insertions(+), 7 deletions(-)

-- 
2.51.0.355.g5224444f11-goog


             reply	other threads:[~2025-09-03  9:28 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-09-03  9:27 Adrian Barnaś [this message]
2025-09-03  9:27 ` [RFC PATCH v2 1/2] staging: media: atomisp: Change name to better follow its behavior Adrian Barnaś
2025-09-04  7:48   ` Andy Shevchenko
2025-09-04 11:43     ` Adrian Barnaś
2025-09-03  9:27 ` [RFC PATCH v2 2/2] staging: media: atomisp: Simplify logic in vmem.c Adrian Barnaś
2025-09-03 11:07 ` [RFC PATCH v2 0/2] staging: media: atomisp: Refactor bit logic helpers " Andy Shevchenko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20250903092754.2751556-1-abarnas@google.com \
    --to=abarnas@google.com \
    --cc=andy@kernel.org \
    --cc=dan.carpenter@linaro.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=hansg@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=linux-staging@lists.linux.dev \
    --cc=mchehab@kernel.org \
    --cc=sakari.ailus@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®