From: weishangjuan@eswincomputing.com
To: devicetree@vger.kernel.org, andrew+netdev@lunn.ch,
davem@davemloft.net, edumazet@google.com, kuba@kernel.org,
pabeni@redhat.com, robh@kernel.org, krzk+dt@kernel.org,
conor+dt@kernel.org, linux-arm-kernel@lists.infradead.org,
mcoquelin.stm32@gmail.com, alexandre.torgue@foss.st.com,
yong.liang.choong@linux.intel.com, vladimir.oltean@nxp.com,
rmk+kernel@armlinux.org.uk, faizal.abdul.rahim@linux.intel.com,
prabhakar.mahadev-lad.rj@bp.renesas.com, inochiama@gmail.com,
jan.petrous@oss.nxp.com, jszhang@kernel.org,
p.zabel@pengutronix.de, boon.khai.ng@altera.com,
0x1207@gmail.com, netdev@vger.kernel.org,
linux-kernel@vger.kernel.org,
linux-stm32@st-md-mailman.stormreply.com,
emil.renner.berthing@canonical.com
Cc: ningyu@eswincomputing.com, linmin@eswincomputing.com,
lizhi2@eswincomputing.com, pinkesh.vaghela@einfochips.com,
Shangjuan Wei <weishangjuan@eswincomputing.com>
Subject: [PATCH v5 0/2] Add driver support for Eswin eic7700 SoC ethernet controller
Date: Thu, 4 Sep 2025 16:59:13 +0800 [thread overview]
Message-ID: <20250904085913.2494-1-weishangjuan@eswincomputing.com> (raw)
From: Shangjuan Wei <weishangjuan@eswincomputing.com>
This series depends on the config option patch [1].
[1] https://lore.kernel.org/all/20250825132427.1618089-3-pinkesh.vaghela@einfochips.com/
Updates:
Changes in v5:
- Updated eswin,eic7700-eth.yaml
- Use "items" instead "enum" for clock-names
- Arrange clocks description in correct order
- Delete redundant descriptions for eswin,hsp-sp-csr property
- Updated dwmac-eic7700.c
- Optimize the implementation of eic7700_ appy_delay
- Update comments and remove reg checking
- Use FIELD_PREP in eic7700_apply_delay function
- Use clk_bulk related APIs to manage clks
- Link to v4: https://lore.kernel.org/all/20250827081135.2243-1-weishangjuan@eswincomputing.com/
Changes in v4:
- Updated eswin,eic7700-eth.yaml
- Modify reg:minItems:1 to reg:maxItems: 1
- Delete minItems and maxItems of clock and clock-names
- Delete phy-mode and phy-handle properties
- Add description for clock
- Add types of clock-names
- Delete descriptions for rx-internal-delay-ps and tx-internal-delay-ps
- Add enum value for rx-internal-delay-ps and tx-internal-delay-ps
- Modify description for eswin,hsp-sp-csr property
- Delete eswin,syscrg-csr and eswin,dly-hsp-reg properties
- Modify phy-mode="rgmii" to phy-mode="rgmii-id"
- Updated dwmac-eic7700.c
- Remove fix_mac_speed and configure different delays for different rates
- Merge the offset of the dly register into the eswin, hsp sp csr attributes
for unified management
- Add missing Author and optimize the number of characters per
line to within 80
- Support default delay configuration and add the handling of vendor delay
configuration
- Add clks_config for pm_runtime
- Modify the attribute format, such as eswin,hsp_sp_csr to eswin,hsp-sp-csr
- Link to v3: https://lore.kernel.org/all/20250703091808.1092-1-weishangjuan@eswincomputing.com/
Changes in v3:
- Updated eswin,eic7700-eth.yaml
- Modify snps,dwmac to snps,dwmac-5.20
- Remove the description of reg
- Modify the value of clock minItems and maxItems
- Modify the value of clock-names minItems and maxItems
- Add descriptions of snps,write-questions, snps,read-questions
- Add rx-internal-delay-ps and tx-internal-delay-ps properties
- Modify descriptions for custom properties, such as eswin,hsp-sp-csr
- Delete snps,axi-config property
- Add snps,fixed-burst snps,aal snps,tso properties
- Delete snps,lpi_en property
- Modify format of custom properties
- Updated dwmac-eic7700.c
- Simplify drivers and remove unnecessary API and DTS attribute configurations
- Increase the mapping from tx/rx_delay_ps to private dly
- Link to v2: https://lore.kernel.org/all/aDad+8YHEFdOIs38@mev-dev.igk.intel.com/
Changes in v2:
- Updated eswin,eic7700-eth.yaml
- Add snps,dwmac in binding file
- Modify the description of reg
- Modify the number of clock-names
- Changed the names of reset-names and phy-mode
- Add description for custom properties, such as eswin,hsp_sp_csr
- Delete snps,blen snps,rd_osr_lmt snps,wr_osr_lmt properties
- Updated dwmac-eic7700.c
- Remove the code related to PHY LED configuration from the MAC driver
- Adjust the code format and driver interfaces, such as replacing kzalloc
with devm_kzalloc, etc.
- Use phylib instead of the GPIO API in the driver to implement the PHY
reset function
- Link to v1: https://lore.kernel.org/all/20250516010849.784-1-weishangjuan@eswincomputing.com/
Shangjuan Wei (2):
dt-bindings: ethernet: eswin: Document for EIC7700 SoC
ethernet: eswin: Add eic7700 ethernet driver
.../bindings/net/eswin,eic7700-eth.yaml | 128 +++++++++
drivers/net/ethernet/stmicro/stmmac/Kconfig | 11 +
drivers/net/ethernet/stmicro/stmmac/Makefile | 1 +
.../ethernet/stmicro/stmmac/dwmac-eic7700.c | 250 ++++++++++++++++++
4 files changed, 390 insertions(+)
create mode 100644 Documentation/devicetree/bindings/net/eswin,eic7700-eth.yaml
create mode 100644 drivers/net/ethernet/stmicro/stmmac/dwmac-eic7700.c
--
2.17.1
next reply other threads:[~2025-09-04 8:59 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-09-04 8:59 weishangjuan [this message]
2025-09-04 9:00 ` [PATCH v5 1/2] dt-bindings: ethernet: eswin: Document for EIC7700 SoC weishangjuan
2025-09-05 7:53 ` Krzysztof Kozlowski
2025-09-10 8:36 ` 韦尚娟
2025-09-04 9:01 ` [PATCH v5 2/2] ethernet: eswin: Add eic7700 ethernet driver weishangjuan
2025-09-04 10:26 ` Russell King (Oracle)
2025-09-08 6:55 ` 李志
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250904085913.2494-1-weishangjuan@eswincomputing.com \
--to=weishangjuan@eswincomputing.com \
--cc=0x1207@gmail.com \
--cc=alexandre.torgue@foss.st.com \
--cc=andrew+netdev@lunn.ch \
--cc=boon.khai.ng@altera.com \
--cc=conor+dt@kernel.org \
--cc=davem@davemloft.net \
--cc=devicetree@vger.kernel.org \
--cc=edumazet@google.com \
--cc=emil.renner.berthing@canonical.com \
--cc=faizal.abdul.rahim@linux.intel.com \
--cc=inochiama@gmail.com \
--cc=jan.petrous@oss.nxp.com \
--cc=jszhang@kernel.org \
--cc=krzk+dt@kernel.org \
--cc=kuba@kernel.org \
--cc=linmin@eswincomputing.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-stm32@st-md-mailman.stormreply.com \
--cc=lizhi2@eswincomputing.com \
--cc=mcoquelin.stm32@gmail.com \
--cc=netdev@vger.kernel.org \
--cc=ningyu@eswincomputing.com \
--cc=p.zabel@pengutronix.de \
--cc=pabeni@redhat.com \
--cc=pinkesh.vaghela@einfochips.com \
--cc=prabhakar.mahadev-lad.rj@bp.renesas.com \
--cc=rmk+kernel@armlinux.org.uk \
--cc=robh@kernel.org \
--cc=vladimir.oltean@nxp.com \
--cc=yong.liang.choong@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®