From: Maxime Ripard <mripard@kernel.org>
To: Jocelyn Falempe <jfalempe@redhat.com>
Cc: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
Thomas Zimmermann <tzimmermann@suse.de>,
David Airlie <airlied@gmail.com>,
Simona Vetter <simona@ffwll.ch>,
Javier Martinez Canillas <javierm@redhat.com>,
linux-kernel@vger.kernel.org, dri-devel@lists.freedesktop.org
Subject: Re: [PATCH v2 2/3] drm/panic: Add kunit tests for drm_panic
Date: Wed, 10 Sep 2025 10:33:58 +0200 [thread overview]
Message-ID: <20250910-fascinating-hungry-lemur-1d9f49@houat> (raw)
In-Reply-To: <20250908090341.762049-3-jfalempe@redhat.com>
[-- Attachment #1: Type: text/plain, Size: 5789 bytes --]
Hi,
On Mon, Sep 08, 2025 at 11:00:30AM +0200, Jocelyn Falempe wrote:
> Add kunit tests for drm_panic.
> They check that drawing the panic screen doesn't crash, but they
> don't check the correctness of the resulting image.
>
> Signed-off-by: Jocelyn Falempe <jfalempe@redhat.com>
> ---
>
> v2:
> * Add a few checks, and more comments in the kunit tests. (Maxime Ripard).
>
> MAINTAINERS | 1 +
> drivers/gpu/drm/drm_panic.c | 4 +
> drivers/gpu/drm/tests/drm_panic_test.c | 198 +++++++++++++++++++++++++
> 3 files changed, 203 insertions(+)
> create mode 100644 drivers/gpu/drm/tests/drm_panic_test.c
>
> diff --git a/MAINTAINERS b/MAINTAINERS
> index 402fe14091f1..e9be893d6741 100644
> --- a/MAINTAINERS
> +++ b/MAINTAINERS
> @@ -8480,6 +8480,7 @@ T: git https://gitlab.freedesktop.org/drm/misc/kernel.git
> F: drivers/gpu/drm/drm_draw.c
> F: drivers/gpu/drm/drm_draw_internal.h
> F: drivers/gpu/drm/drm_panic*.c
> +F: drivers/gpu/drm/tests/drm_panic_test.c
> F: include/drm/drm_panic*
>
> DRM PANIC QR CODE
> diff --git a/drivers/gpu/drm/drm_panic.c b/drivers/gpu/drm/drm_panic.c
> index 1e06e3a18d09..d89812ff1935 100644
> --- a/drivers/gpu/drm/drm_panic.c
> +++ b/drivers/gpu/drm/drm_panic.c
> @@ -986,3 +986,7 @@ void drm_panic_exit(void)
> {
> drm_panic_qr_exit();
> }
> +
> +#ifdef CONFIG_DRM_KUNIT_TEST
> +#include "tests/drm_panic_test.c"
> +#endif
> diff --git a/drivers/gpu/drm/tests/drm_panic_test.c b/drivers/gpu/drm/tests/drm_panic_test.c
> new file mode 100644
> index 000000000000..d5d20dd2aa7c
> --- /dev/null
> +++ b/drivers/gpu/drm/tests/drm_panic_test.c
> @@ -0,0 +1,198 @@
> +// SPDX-License-Identifier: GPL-2.0 or MIT
> +/*
> + * Copyright (c) 2025 Red Hat.
> + * Author: Jocelyn Falempe <jfalempe@redhat.com>
> + *
> + * KUNIT tests for drm panic
> + */
> +
> +#include <drm/drm_fourcc.h>
> +#include <drm/drm_panic.h>
> +
> +#include <kunit/test.h>
> +
> +#include <linux/units.h>
> +#include <linux/vmalloc.h>
> +
> +/* Check the framebuffer color only if the panic colors are the default */
> +#if (CONFIG_DRM_PANIC_BACKGROUND_COLOR == 0 && \
> + CONFIG_DRM_PANIC_FOREGROUND_COLOR == 0xffffff)
> +#define DRM_PANIC_CHECK_COLOR
> +#endif
> +
> +struct drm_test_mode {
> + const int width;
> + const int height;
> + const u32 format;
> + void (*draw_screen)(struct drm_scanout_buffer *sb);
> + const char *fname;
> +};
> +
> +/*
> + * Run all tests for the 3 panic screens: user, kmsg and qr_code
> + */
> +#define DRM_TEST_MODE_LIST(func) \
> + DRM_PANIC_TEST_MODE(1024, 768, DRM_FORMAT_XRGB8888, func) \
> + DRM_PANIC_TEST_MODE(300, 200, DRM_FORMAT_XRGB8888, func) \
> + DRM_PANIC_TEST_MODE(1920, 1080, DRM_FORMAT_XRGB8888, func) \
> + DRM_PANIC_TEST_MODE(1024, 768, DRM_FORMAT_RGB565, func) \
> + DRM_PANIC_TEST_MODE(1024, 768, DRM_FORMAT_RGB888, func) \
> +
> +#define DRM_PANIC_TEST_MODE(w, h, f, name) { \
> + .width = w, \
> + .height = h, \
> + .format = f, \
> + .draw_screen = draw_panic_screen_##name, \
> + .fname = #name, \
> + }, \
> +
> +static const struct drm_test_mode drm_test_modes_cases[] = {
> + DRM_TEST_MODE_LIST(user)
> + DRM_TEST_MODE_LIST(kmsg)
> + DRM_TEST_MODE_LIST(qr_code)
> +};
> +#undef DRM_PANIC_TEST_MODE
> +
> +static int drm_test_panic_init(struct kunit *test)
> +{
> + struct drm_scanout_buffer *priv;
> +
> + priv = kunit_kzalloc(test, sizeof(*priv), GFP_KERNEL);
> + KUNIT_ASSERT_NOT_NULL(test, priv);
> +
> + test->priv = priv;
> +
> + drm_panic_set_description("Kunit testing");
> +
> + return 0;
> +}
> +
> +/*
> + * Test drawing the panic screen, using a memory mapped framebuffer
> + * Set the whole buffer to 0xa5, and then check that all pixels have been
> + * written.
> + */
> +static void drm_test_panic_screen_user_map(struct kunit *test)
> +{
> + struct drm_scanout_buffer *sb = test->priv;
> + const struct drm_test_mode *params = test->param_value;
> + char *fb;
> + int fb_size;
> +
> + sb->format = drm_format_info(params->format);
> + fb_size = params->width * params->height * sb->format->cpp[0];
> +
> + fb = vmalloc(fb_size);
> + KUNIT_ASSERT_NOT_NULL(test, fb);
> +
> + memset(fb, 0xa5, fb_size);
> +
> + iosys_map_set_vaddr(&sb->map[0], fb);
> + sb->width = params->width;
> + sb->height = params->height;
> + sb->pitch[0] = params->width * sb->format->cpp[0];
> +
> + params->draw_screen(sb);
> +
> +#ifdef DRM_PANIC_CHECK_COLOR
> + {
> + int i;
> +
> + for (i = 0; i < fb_size; i++)
> + KUNIT_ASSERT_TRUE(test, fb[i] == 0 || fb[i] == 0xff);
> + }
> +#endif
I'm not really fond of the ifdef here. Could you turn this into a
function, and return that it's valid if the colors don't match what you
expect?
> + vfree(fb);
> +}
> +
> +/*
> + * Test drawing the panic screen, using a list of pages framebuffer
> + * No checks are performed
What are you testing then if you aren't checking anything?
> + */
> +static void drm_test_panic_screen_user_page(struct kunit *test)
> +{
> + struct drm_scanout_buffer *sb = test->priv;
> + const struct drm_test_mode *params = test->param_value;
> + int fb_size;
> + struct page **pages;
> + int i;
> + int npages;
> +
> + sb->format = drm_format_info(params->format);
> + fb_size = params->width * params->height * sb->format->cpp[0];
> + npages = DIV_ROUND_UP(fb_size, PAGE_SIZE);
> +
> + pages = kmalloc_array(npages, sizeof(struct page *), GFP_KERNEL);
> + KUNIT_ASSERT_NOT_NULL(test, pages);
> +
> + for (i = 0; i < npages; i++) {
> + pages[i] = alloc_page(GFP_KERNEL);
> + KUNIT_ASSERT_NOT_NULL(test, pages[i]);
KUNIT_ASSERT_* return immediately, so you're leaking the pages array
here.
Maxime
[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 273 bytes --]
next prev parent reply other threads:[~2025-09-10 8:34 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-09-08 9:00 [PATCH v2 0/3] " Jocelyn Falempe
2025-09-08 9:00 ` [PATCH v2 1/3] drm/panic: Rename draw_panic_static_* to draw_panic_screen_* Jocelyn Falempe
2025-09-08 9:00 ` [PATCH v2 2/3] drm/panic: Add kunit tests for drm_panic Jocelyn Falempe
2025-09-10 8:33 ` Maxime Ripard [this message]
2025-09-10 15:16 ` Jocelyn Falempe
2025-09-23 9:57 ` Maxime Ripard
2025-09-25 15:50 ` Jocelyn Falempe
2025-09-08 9:00 ` [PATCH v2 3/3] drm/panic: Add a drm_panic/draw_test in debugfs Jocelyn Falempe
2025-09-10 10:49 ` Maxime Ripard
2025-09-11 12:00 ` Jocelyn Falempe
2025-09-23 10:15 ` Maxime Ripard
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250910-fascinating-hungry-lemur-1d9f49@houat \
--to=mripard@kernel.org \
--cc=airlied@gmail.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=javierm@redhat.com \
--cc=jfalempe@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=maarten.lankhorst@linux.intel.com \
--cc=simona@ffwll.ch \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®