From: Breno Leitao <leitao@debian.org>
To: "Andrew Lunn" <andrew@lunn.ch>,
"David S. Miller" <davem@davemloft.net>,
"Eric Dumazet" <edumazet@google.com>,
"Paolo Abeni" <pabeni@redhat.com>,
kuba@kernel.org, "Simon Horman" <horms@kernel.org>,
"Michael S. Tsirkin" <mst@redhat.com>,
"Jason Wang" <jasowang@redhat.com>,
"Xuan Zhuo" <xuanzhuo@linux.alibaba.com>,
"Eugenio Pérez" <eperezma@redhat.com>,
"Andrew Lunn" <andrew+netdev@lunn.ch>
Cc: netdev@vger.kernel.org, linux-kernel@vger.kernel.org,
virtualization@lists.linux.dev, Breno Leitao <leitao@debian.org>,
Lei Yang <leiyang@redhat.com>,
kernel-team@meta.com
Subject: [PATCH net-next v2 0/7] net: ethtool: add dedicated GRXRINGS driver callbacks
Date: Fri, 12 Sep 2025 08:59:09 -0700 [thread overview]
Message-ID: <20250912-gxrings-v2-0-3c7a60bbeebf@debian.org> (raw)
This patchset introduces a new dedicated ethtool_ops callback,
.get_rx_ring_count, which enables drivers to provide the number of RX
rings directly, improving efficiency and clarity in RX ring queries and
RSS configuration.
Number of drivers implements .get_rxnfc callback just to report the ring
count, so, having a proper callback makes sense and simplify .get_rxnfc
(in some cases remove it completely).
This has been suggested by Jakub, and follow the same idea as RXFH
driver callbacks [1].
This also port virtio_net to this new callback. Once there is consensus
on this approach, I can start moving the drivers to this new callback.
Link: https://lore.kernel.org/all/20250611145949.2674086-1-kuba@kernel.org/ [1]
Suggested-by: Jakub Kicinski <kuba@kernel.org>
Signed-off-by: Breno Leitao <leitao@debian.org>
Tested-by: Lei Yang <leiyang@redhat.com>
---
Changes in v2:
- rename get_num_rxrings() to ethtool_get_rx_ring_count() (Jakub)
- initialize struct ethtool_rxnfc() (Jakub)
- Link to v1: https://lore.kernel.org/r/20250909-gxrings-v1-0-634282f06a54@debian.org
---
Changes v1 from RFC:
- Renaming and changing the return type of .get_rxrings() callback (Jakub)
- Add the docstring format for the new callback (Simon)
- Remove the unecessary WARN_ONCE() (Jakub)
- Link to RFC: https://lore.kernel.org/r/20250905-gxrings-v1-0-984fc471f28f@debian.org
---
Breno Leitao (7):
net: ethtool: pass the num of RX rings directly to ethtool_copy_validate_indir
net: ethtool: add support for ETHTOOL_GRXRINGS ioctl
net: ethtool: remove the duplicated handling from ethtool_get_rxrings
net: ethtool: add get_rx_ring_count callback to optimize RX ring queries
net: ethtool: update set_rxfh to use ethtool_get_rx_ring_count helper
net: ethtool: update set_rxfh_indir to use ethtool_get_rx_ring_count helper
net: virtio_net: add get_rxrings ethtool callback for RX ring queries
drivers/net/virtio_net.c | 15 ++-------
include/linux/ethtool.h | 2 ++
net/ethtool/ioctl.c | 81 +++++++++++++++++++++++++++++++++++++-----------
3 files changed, 68 insertions(+), 30 deletions(-)
---
base-commit: 1f24a240974589ce42f70502ccb3ff3f5189d69a
change-id: 20250905-gxrings-a2ec22ee2aec
Best regards,
--
Breno Leitao <leitao@debian.org>
next reply other threads:[~2025-09-12 15:59 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-09-12 15:59 Breno Leitao [this message]
2025-09-12 15:59 ` [PATCH net-next v2 1/7] net: ethtool: pass the num of RX rings directly to ethtool_copy_validate_indir Breno Leitao
2025-09-12 15:59 ` [PATCH net-next v2 2/7] net: ethtool: add support for ETHTOOL_GRXRINGS ioctl Breno Leitao
2025-09-12 15:59 ` [PATCH net-next v2 3/7] net: ethtool: remove the duplicated handling from ethtool_get_rxrings Breno Leitao
2025-09-12 15:59 ` [PATCH net-next v2 4/7] net: ethtool: add get_rx_ring_count callback to optimize RX ring queries Breno Leitao
2025-09-14 19:59 ` Jakub Kicinski
2025-09-15 9:12 ` Breno Leitao
2025-09-12 15:59 ` [PATCH net-next v2 5/7] net: ethtool: update set_rxfh to use ethtool_get_rx_ring_count helper Breno Leitao
2025-09-12 15:59 ` [PATCH net-next v2 6/7] net: ethtool: update set_rxfh_indir " Breno Leitao
2025-09-12 15:59 ` [PATCH net-next v2 7/7] net: virtio_net: add get_rxrings ethtool callback for RX ring queries Breno Leitao
2025-09-15 10:50 ` [PATCH net-next v2 0/7] net: ethtool: add dedicated GRXRINGS driver callbacks Lei Yang
2025-09-15 10:55 ` Breno Leitao
2025-09-15 10:57 ` Breno Leitao
2025-09-15 14:45 ` Lei Yang
2025-09-15 15:22 ` Jakub Kicinski
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250912-gxrings-v2-0-3c7a60bbeebf@debian.org \
--to=leitao@debian.org \
--cc=andrew+netdev@lunn.ch \
--cc=andrew@lunn.ch \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=eperezma@redhat.com \
--cc=horms@kernel.org \
--cc=jasowang@redhat.com \
--cc=kernel-team@meta.com \
--cc=kuba@kernel.org \
--cc=leiyang@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mst@redhat.com \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
--cc=virtualization@lists.linux.dev \
--cc=xuanzhuo@linux.alibaba.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®