From: Christian Brauner <brauner@kernel.org>
To: Mateusz Guzik <mjguzik@gmail.com>
Cc: Jan Kara <jack@suse.cz>, Joseph Qi <joseph.qi@linux.alibaba.com>,
Mark Tinguely <mark.tinguely@oracle.com>,
ocfs2-devel@lists.linux.dev, viro@zeniv.linux.org.uk,
linux-kernel@vger.kernel.org, linux-fsdevel@vger.kernel.org,
josef@toxicpanda.com, jlbec@evilplan.org, mark@fasheh.com,
willy@infradead.org, david@fromorbit.com
Subject: Re: [External] : [PATCH] ocfs2: retire ocfs2_drop_inode() and I_WILL_FREE usage
Date: Mon, 15 Sep 2025 14:21:56 +0200 [thread overview]
Message-ID: <20250915-anlocken-brummen-b86b3cba8ccf@brauner> (raw)
In-Reply-To: <CAGudoHEBDA1XKu8WTPQ4Nn+GTUWg_FMUavcAddBQ=5doY1aQxw@mail.gmail.com>
On Tue, Sep 09, 2025 at 11:57:11AM +0200, Mateusz Guzik wrote:
> On Tue, Sep 9, 2025 at 11:52 AM Mateusz Guzik <mjguzik@gmail.com> wrote:
> >
> > On Tue, Sep 9, 2025 at 11:51 AM Jan Kara <jack@suse.cz> wrote:
> > >
> > > On Mon 08-09-25 17:39:22, Mateusz Guzik wrote:
> > > > I think generic_delete_inode is a really bad name for what the routine
> > > > is doing and it perhaps contributes to the confusion in the thread.
> > > >
> > > > Perhaps it could be renamed to inode_op_stub_always_drop or similar? I
> > > > don't for specifics, apart from explicitly stating that the return
> > > > value is to drop and bonus points for a prefix showing this is an
> > > > inode thing.
> > >
> > > I think inode_always_drop() would be fine...
> >
> > sgtm. unfortunately there are quite a few consumers, so I don't know
> > if this is worth the churn and consequently I'm not going for it.
> >
> > But should you feel inclined... ;-)
>
> Actually got one better: inode_just_drop(), so that it is clear this
> is not doing anything else.
That's a simple git sed tbh. Just send it to me this week. All big
changes should be done by now.
next prev parent reply other threads:[~2025-09-15 12:22 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <766vdz3ecpm7hv4sp5r3uu4ezggm532ng7fdklb2nrupz6minz@qcws3ufabnjp>
2025-09-04 15:42 ` Mateusz Guzik
2025-09-04 16:15 ` [External] : " Mark Tinguely
2025-09-04 16:22 ` Mateusz Guzik
2025-09-08 1:51 ` Joseph Qi
2025-09-08 10:23 ` Jan Kara
2025-09-08 12:41 ` Joseph Qi
2025-09-08 13:54 ` Jan Kara
2025-09-08 15:39 ` Mateusz Guzik
2025-09-09 9:51 ` Jan Kara
2025-09-09 9:52 ` Mateusz Guzik
2025-09-09 9:57 ` Mateusz Guzik
2025-09-15 12:21 ` Christian Brauner [this message]
2025-09-09 1:23 ` Joseph Qi
2025-09-09 9:49 ` Jan Kara
2025-09-09 9:58 ` Joseph Qi
2025-09-15 12:21 ` Christian Brauner
2025-09-08 1:33 ` Joseph Qi
2025-09-05 13:29 ` Jan Kara
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250915-anlocken-brummen-b86b3cba8ccf@brauner \
--to=brauner@kernel.org \
--cc=david@fromorbit.com \
--cc=jack@suse.cz \
--cc=jlbec@evilplan.org \
--cc=josef@toxicpanda.com \
--cc=joseph.qi@linux.alibaba.com \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mark.tinguely@oracle.com \
--cc=mark@fasheh.com \
--cc=mjguzik@gmail.com \
--cc=ocfs2-devel@lists.linux.dev \
--cc=viro@zeniv.linux.org.uk \
--cc=willy@infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®