From: Breno Leitao <leitao@debian.org>
To: "Andrew Lunn" <andrew@lunn.ch>,
"David S. Miller" <davem@davemloft.net>,
"Eric Dumazet" <edumazet@google.com>,
"Paolo Abeni" <pabeni@redhat.com>,
kuba@kernel.org, "Simon Horman" <horms@kernel.org>,
"Michael S. Tsirkin" <mst@redhat.com>,
"Jason Wang" <jasowang@redhat.com>,
"Xuan Zhuo" <xuanzhuo@linux.alibaba.com>,
"Eugenio Pérez" <eperezma@redhat.com>,
"Andrew Lunn" <andrew+netdev@lunn.ch>
Cc: netdev@vger.kernel.org, linux-kernel@vger.kernel.org,
virtualization@lists.linux.dev, Breno Leitao <leitao@debian.org>,
Lei Yang <leiyang@redhat.com>,
kernel-team@meta.com
Subject: [PATCH net-next v4 0/8] net: ethtool: add dedicated GRXRINGS driver callbacks
Date: Wed, 17 Sep 2025 02:58:07 -0700 [thread overview]
Message-ID: <20250917-gxrings-v4-0-dae520e2e1cb@debian.org> (raw)
This patchset introduces a new dedicated ethtool_ops callback,
.get_rx_ring_count, which enables drivers to provide the number of RX
rings directly, improving efficiency and clarity in RX ring queries and
RSS configuration.
Number of drivers implements .get_rxnfc callback just to report the ring
count, so, having a proper callback makes sense and simplify .get_rxnfc
(in some cases remove it completely).
This has been suggested by Jakub, and follow the same idea as RXFH
driver callbacks [1].
This also port virtio_net to this new callback. Once there is consensus
on this approach, I can start moving the drivers to this new callback.
Link: https://lore.kernel.org/all/20250611145949.2674086-1-kuba@kernel.org/ [1]
Suggested-by: Jakub Kicinski <kuba@kernel.org>
Signed-off-by: Breno Leitao <leitao@debian.org>
Tested-by: Lei Yang <leiyang@redhat.com>
---
Changes in v4:
- Moved ethtool_get_rx_ring_count() to ethtool/common file (Jakub)
- Keep the check for !ops->get_rxnfc only in ethtool_get_rx_ring_count() (Jakub)
- Link to v3: https://lore.kernel.org/r/20250915-gxrings-v3-0-bfd717dbcaad@debian.org
Changes in v3:
- Make ethtool_get_rx_ring_count() non static and use it in rss_set_prep_indir()
- Check return function of ethtool_get_rx_ring_count() in
ethtool_get_rx_ring_count() (Jakub)
- Link to v2: https://lore.kernel.org/r/20250912-gxrings-v2-0-3c7a60bbeebf@debian.org
Changes in v2:
- rename get_num_rxrings() to ethtool_get_rx_ring_count() (Jakub)
- initialize struct ethtool_rxnfc() (Jakub)
- Link to v1: https://lore.kernel.org/r/20250909-gxrings-v1-0-634282f06a54@debian.org
---
Changes v1 from RFC:
- Renaming and changing the return type of .get_rxrings() callback (Jakub)
- Add the docstring format for the new callback (Simon)
- Remove the unecessary WARN_ONCE() (Jakub)
- Link to RFC: https://lore.kernel.org/r/20250905-gxrings-v1-0-984fc471f28f@debian.org
---
Breno Leitao (8):
net: ethtool: pass the num of RX rings directly to ethtool_copy_validate_indir
net: ethtool: add support for ETHTOOL_GRXRINGS ioctl
net: ethtool: remove the duplicated handling from ethtool_get_rxrings
net: ethtool: add get_rx_ring_count callback to optimize RX ring queries
net: ethtool: update set_rxfh to use ethtool_get_rx_ring_count helper
net: ethtool: update set_rxfh_indir to use ethtool_get_rx_ring_count helper
net: ethtool: use the new helper in rss_set_prep_indir()
net: virtio_net: add get_rxrings ethtool callback for RX ring queries
drivers/net/virtio_net.c | 15 +++--------
include/linux/ethtool.h | 2 ++
net/ethtool/common.c | 20 ++++++++++++++
net/ethtool/common.h | 2 ++
net/ethtool/ioctl.c | 69 +++++++++++++++++++++++++++++++++---------------
net/ethtool/rss.c | 15 +++++------
6 files changed, 82 insertions(+), 41 deletions(-)
---
base-commit: 5e87fdc37f8dc619549d49ba5c951b369ce7c136
change-id: 20250905-gxrings-a2ec22ee2aec
Best regards,
--
Breno Leitao <leitao@debian.org>
next reply other threads:[~2025-09-17 9:58 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-09-17 9:58 Breno Leitao [this message]
2025-09-17 9:58 ` [PATCH net-next v4 1/8] net: ethtool: pass the num of RX rings directly to ethtool_copy_validate_indir Breno Leitao
2025-09-17 9:58 ` [PATCH net-next v4 2/8] net: ethtool: add support for ETHTOOL_GRXRINGS ioctl Breno Leitao
2025-09-17 9:58 ` [PATCH net-next v4 3/8] net: ethtool: remove the duplicated handling from ethtool_get_rxrings Breno Leitao
2025-09-17 9:58 ` [PATCH net-next v4 4/8] net: ethtool: add get_rx_ring_count callback to optimize RX ring queries Breno Leitao
2025-09-17 9:58 ` [PATCH net-next v4 5/8] net: ethtool: update set_rxfh to use ethtool_get_rx_ring_count helper Breno Leitao
2025-09-17 9:58 ` [PATCH net-next v4 6/8] net: ethtool: update set_rxfh_indir " Breno Leitao
2025-09-17 9:58 ` [PATCH net-next v4 7/8] net: ethtool: use the new helper in rss_set_prep_indir() Breno Leitao
2025-09-17 9:58 ` [PATCH net-next v4 8/8] net: virtio_net: add get_rxrings ethtool callback for RX ring queries Breno Leitao
2025-09-18 14:30 ` [PATCH net-next v4 0/8] net: ethtool: add dedicated GRXRINGS driver callbacks patchwork-bot+netdevbpf
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250917-gxrings-v4-0-dae520e2e1cb@debian.org \
--to=leitao@debian.org \
--cc=andrew+netdev@lunn.ch \
--cc=andrew@lunn.ch \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=eperezma@redhat.com \
--cc=horms@kernel.org \
--cc=jasowang@redhat.com \
--cc=kernel-team@meta.com \
--cc=kuba@kernel.org \
--cc=leiyang@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mst@redhat.com \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
--cc=virtualization@lists.linux.dev \
--cc=xuanzhuo@linux.alibaba.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®