mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Peter Zijlstra <peterz@infradead.org>
To: Alexandre Chartre <alexandre.chartre@oracle.com>
Cc: linux-kernel@vger.kernel.org, mingo@kernel.org, jpoimboe@kernel.org
Subject: Re: [RFC PATCH v2 00/17] objtool: Function validation tracing
Date: Wed, 24 Sep 2025 11:57:55 +0200	[thread overview]
Message-ID: <20250924095755.GY3245006@noisy.programming.kicks-ass.net> (raw)
In-Reply-To: <4c4afe3e-ac24-4891-9acd-1d493ea88eca@oracle.com>

On Wed, Sep 24, 2025 at 11:50:25AM +0200, Alexandre Chartre wrote:
> 
> On 9/24/25 11:17, Peter Zijlstra wrote:
> > On Wed, Sep 24, 2025 at 09:36:49AM +0200, Peter Zijlstra wrote:
> > 
> > > >                        | <alternative.65c4e> alt 1/4 end
> > > >   65c4e: os_xsave+0x2e | <alternative.65c4e> alt 2/4 begin
> > > >   1c3d: .altinstr_replacement+0x1c3d | | xsaves64 0x40(%rbp)
> > > >   65c53: os_xsave+0x33 | | xor %ebx,%ebx
> > > >   65c55: os_xsave+0x35 | | test %ebx,%ebx - already visited
> > > >                        | <alternative.65c4e> alt 2/4 end
> > > >   65c4e: os_xsave+0x2e | <alternative.65c4e> alt 3/4 begin
> > > >   1c38: .altinstr_replacement+0x1c38 | | xsavec64 0x40(%rbp)
> > > >   65c53: os_xsave+0x33 | | xor %ebx,%ebx - already visited
> > > >                        | <alternative.65c4e> alt 3/4 end
> > > >   65c4e: os_xsave+0x2e | <alternative.65c4e> alt 4/4 begin
> > > >   1c33: .altinstr_replacement+0x1c33 | | xsaveopt64 0x40(%rbp)
> > > >   65c53: os_xsave+0x33 | | xor %ebx,%ebx - already visited
> > > >                        | <alternative.65c4e> alt 4/4 end
> > > >   65c4e: os_xsave+0x2e | <alternative.65c4e> alt default
> > > >   65c4e: os_xsave+0x2e | xsave64 0x40(%rbp)
> > > >   65c53: os_xsave+0x33 | xor %ebx,%ebx - already visited
> > > 
> > > I find it *very* hard to read these alternatives. If at all possible, I
> > > think something like:
> > > 
> > >     65c4e: os_xsave+0x2e | xsave64	| xsaveopt64	| xsavec64	| xsaves64
> > >     65c53: os_xsave+0x33 | xor %ebx,%ebx
> > > 
> > > Would be *much* easier to follow
> > 
> > Another option is to write it source-like:
> > 
> >    65c4e: os_xsave+0x2e | ALTERNATIVE("xsave64",
> >                                       "xsaveopt64", X86_FEATURE_XSAVEOPT,
> > 				     "xsavec64", X86_FEATURE_XSAVEC,
> > 				     "xsaves64", X86_FEATURE_XSAVES);
> >    65c53: os_xsave+0x33 | xor %ebx,%ebx
> > 
> > 
> > We have the 'feature' bit, we'd just have to 'borrow' the feature
> > strings from the kernel I suppose.
> 
> Yes, that would be very useful. But I will probably look at it for a next
> set of patches.

Yes, like I said, I don't think we need to hold up the current set for
this. But given how I struggle to read that alternative stuff, I figured
we should explore alternatives :-)

  reply	other threads:[~2025-09-24 10:03 UTC|newest]

Thread overview: 35+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-06-19 14:56 Alexandre Chartre
2025-06-19 14:56 ` [RFC PATCH v2 01/17] objtool: Move disassembly functions to a separated file Alexandre Chartre
2025-06-19 14:56 ` [RFC PATCH v2 02/17] objtool: Create disassembly context Alexandre Chartre
2025-09-23 22:23   ` Josh Poimboeuf
2025-06-19 14:56 ` [RFC PATCH v2 03/17] objtool: Disassemble code with libopcodes instead of running objdump Alexandre Chartre
2025-06-19 14:56 ` [RFC PATCH v2 04/17] tool build: Remove annoying newline in build output Alexandre Chartre
2025-06-19 14:56 ` [RFC PATCH v2 05/17] objtool: Print symbol during disassembly Alexandre Chartre
2025-06-19 14:56 ` [RFC PATCH v2 06/17] objtool: Improve offstr() output Alexandre Chartre
2025-09-23 22:23   ` Josh Poimboeuf
2025-06-19 14:56 ` [RFC PATCH v2 07/17] objtool: Store instruction disassembly result Alexandre Chartre
2025-06-19 14:56 ` [RFC PATCH v2 08/17] objtool: Disassemble instruction on warning or backtrace Alexandre Chartre
2025-06-19 14:56 ` [RFC PATCH v2 09/17] objtool: Extract code to validate instruction from the validate branch loop Alexandre Chartre
2025-06-19 14:56 ` [RFC PATCH v2 10/17] objtool: Record symbol name max length Alexandre Chartre
2025-06-19 14:56 ` [RFC PATCH v2 11/17] objtool: Add option to trace function validation Alexandre Chartre
2025-09-23 22:25   ` Josh Poimboeuf
2025-06-19 14:56 ` [RFC PATCH v2 12/17] objtool: Trace instruction state changes during " Alexandre Chartre
2025-06-19 14:56 ` [RFC PATCH v2 13/17] objtool: Improve register reporting " Alexandre Chartre
2025-06-19 14:56 ` [RFC PATCH v2 14/17] objtool: Improve tracing of alternative instructions Alexandre Chartre
2025-06-19 14:56 ` [RFC PATCH v2 15/17] objtool: Do not validate IBT for .return_sites and .call_sites Alexandre Chartre
2025-06-19 14:56 ` [RFC PATCH v2 16/17] objtool: Add the --disas=<function-pattern> action Alexandre Chartre
2025-06-19 14:56 ` [RFC PATCH v2 17/17] objtool: Disassemble all alternatives when using --disas Alexandre Chartre
2025-09-23 22:33 ` [RFC PATCH v2 00/17] objtool: Function validation tracing Josh Poimboeuf
2025-09-24  9:25   ` Alexandre Chartre
2025-09-24  7:36 ` Peter Zijlstra
2025-09-24  7:42   ` Peter Zijlstra
2025-09-24 10:08     ` Peter Zijlstra
2025-09-24 10:10       ` Peter Zijlstra
2025-09-24 10:52         ` Alexandre Chartre
2025-09-24 10:58           ` Peter Zijlstra
2025-09-24 11:45             ` Peter Zijlstra
2025-09-24 11:57               ` Alexandre Chartre
2025-09-24  9:17   ` Peter Zijlstra
2025-09-24  9:50     ` Alexandre Chartre
2025-09-24  9:57       ` Peter Zijlstra [this message]
2025-09-24  9:37   ` Alexandre Chartre

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20250924095755.GY3245006@noisy.programming.kicks-ass.net \
    --to=peterz@infradead.org \
    --cc=alexandre.chartre@oracle.com \
    --cc=jpoimboe@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®