From: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
To: Sakari Ailus <sakari.ailus@linux.intel.com>
Cc: linux-acpi@vger.kernel.org, linux-kernel@vger.kernel.org,
"Rafael J. Wysocki" <rafael@kernel.org>,
Len Brown <lenb@kernel.org>,
Dmitry Torokhov <dmitry.torokhov@gmail.com>,
Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
Jonathan Cameron <Jonathan.Cameron@huawei.com>
Subject: Re: [PATCH 3/3] ACPI: property: Rework acpi_graph_get_next_endpoint()
Date: Wed, 1 Oct 2025 15:20:51 +0300 [thread overview]
Message-ID: <20251001122051.GC14600@pendragon.ideasonboard.com> (raw)
In-Reply-To: <20251001104320.1272752-4-sakari.ailus@linux.intel.com>
On Wed, Oct 01, 2025 at 01:43:20PM +0300, Sakari Ailus wrote:
> Rework the code obtaining the next endpoint in
> acpi_graph_get_next_endpoint(). The resulting code removes unnecessary
> contitionals and should be easier to follow.
>
> Suggested-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
> Signed-off-by: Sakari Ailus <sakari.ailus@linux.intel.com>
Reviewed-by: Laurent Pinchart <laurent.pinchart+renesas@ideasonboard.com>
> ---
> drivers/acpi/property.c | 17 ++++++++++-------
> 1 file changed, 10 insertions(+), 7 deletions(-)
>
> diff --git a/drivers/acpi/property.c b/drivers/acpi/property.c
> index 200e5d717f16..c07f45929a25 100644
> --- a/drivers/acpi/property.c
> +++ b/drivers/acpi/property.c
> @@ -1421,14 +1421,17 @@ static struct fwnode_handle *acpi_graph_get_next_endpoint(
> if (!port)
> return NULL;
>
> - endpoint = acpi_get_next_subnode(port, prev);
> - while (!endpoint) {
> - port = acpi_get_next_subnode(fwnode, port);
> - if (!port)
> + do {
> + endpoint = acpi_get_next_subnode(port, prev);
> + if (endpoint)
> break;
> - if (is_acpi_graph_node(port, "port"))
> - endpoint = acpi_get_next_subnode(port, NULL);
> - }
> +
> + prev = NULL;
> +
> + do {
> + port = acpi_get_next_subnode(fwnode, port);
> + } while (port && !is_acpi_graph_node(port, "port"));
> + } while (port);
>
> /*
> * The names of the endpoint nodes begin with "endpoint@" followed by
--
Regards,
Laurent Pinchart
prev parent reply other threads:[~2025-10-01 12:21 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-10-01 10:43 [PATCH 0/3] ACPI property cleanups Sakari Ailus
2025-10-01 10:43 ` [PATCH 1/3] ACPI: property: Make acpi_get_next_subnode() static Sakari Ailus
2025-10-01 10:43 ` [PATCH 2/3] ACPI: property: Use ACPI functions in acpi_graph_get_next_endpoint() only Sakari Ailus
2025-10-01 10:43 ` [PATCH 3/3] ACPI: property: Rework acpi_graph_get_next_endpoint() Sakari Ailus
2025-10-01 12:20 ` Laurent Pinchart [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20251001122051.GC14600@pendragon.ideasonboard.com \
--to=laurent.pinchart@ideasonboard.com \
--cc=Jonathan.Cameron@huawei.com \
--cc=andriy.shevchenko@linux.intel.com \
--cc=dmitry.torokhov@gmail.com \
--cc=lenb@kernel.org \
--cc=linux-acpi@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=rafael@kernel.org \
--cc=sakari.ailus@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®