mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jason Wang <jasowang@redhat.com>
To: mst@redhat.com, jasowang@redhat.com, xuanzhuo@linux.alibaba.com,
	eperezma@redhat.com, virtualization@lists.linux.dev,
	linux-kernel@vger.kernel.org
Subject: [PATCH V8 00/19] virtio_ring in order support
Date: Mon, 20 Oct 2025 15:09:44 +0800	[thread overview]
Message-ID: <20251020071003.28834-1-jasowang@redhat.com> (raw)

Hello all:

This sereis tries to implement the VIRTIO_F_IN_ORDER to
virtio_ring. This is done by introducing virtqueue ops so we can
implement separate helpers for different virtqueue layout/features
then the in-order were implemented on top.

Tests shows 2%-19% imporvment with packed virtqueue PPS with KVM guest
vhost-net/testpmd on the host.

Changes since v7:

- Rebase on vhost.git linux-next branch
- Tweak the comment to explain the usage of free_head

Changes since V6:

- Rebase on vhost.git linux-next branch
- Fix poking packed virtqueue in more_used_split_in_order()
- Fix calling detach_buf_packed_in_order() unconditonally in
  virtqueue_detach_unused_buf_packed()
- Typo and indentation fixes
- Fix wrong changelog of patch 7

Changes since V5:

- rebase on vhost.git linux-next branch
- reorder the total_len to reduce memory comsuming

Changes since V4:

- Fix build error when DEBUG is enabled
- Fix function duplications
- Remove unnecessary new lines

Changes since V3:

- Re-benchmark with the recent vhost-net in order support
- Rename the batched used id and length
- Other minor tweaks

Changes since V2:

- Fix build warning when DEBUG is enabled

Changes since V1:

- use const global array of function pointers to avoid indirect
  branches to eliminate retpoline when mitigation is enabled
- fix used length calculation when processing used ids in a batch
- fix sparse warnings

Jason Wang (19):
  virtio_ring: rename virtqueue_reinit_xxx to virtqueue_reset_xxx()
  virtio_ring: switch to use vring_virtqueue in virtqueue_poll variants
  virtio_ring: unify logic of virtqueue_poll() and more_used()
  virtio_ring: switch to use vring_virtqueue for virtqueue resize
    variants
  virtio_ring: switch to use vring_virtqueue for virtqueue_kick_prepare
    variants
  virtio_ring: switch to use vring_virtqueue for virtqueue_add variants
  virtio: switch to use vring_virtqueue for virtqueue_get variants
  virtio_ring: switch to use vring_virtqueue for enable_cb_prepare
    variants
  virtio_ring: use vring_virtqueue for enable_cb_delayed variants
  virtio_ring: switch to use vring_virtqueue for disable_cb variants
  virtio_ring: switch to use vring_virtqueue for detach_unused_buf
    variants
  virtio_ring: switch to use unsigned int for virtqueue_poll_packed()
  virtio_ring: introduce virtqueue ops
  virtio_ring: determine descriptor flags at one time
  virtio_ring: factor out core logic of buffer detaching
  virtio_ring: factor out core logic for updating last_used_idx
  virtio_ring: factor out split indirect detaching logic
  virtio_ring: factor out split detaching logic
  virtio_ring: add in order support

 drivers/virtio/virtio_ring.c | 905 ++++++++++++++++++++++++++---------
 1 file changed, 692 insertions(+), 213 deletions(-)

-- 
2.31.1


             reply	other threads:[~2025-10-20  7:10 UTC|newest]

Thread overview: 43+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-10-20  7:09 Jason Wang [this message]
2025-10-20  7:09 ` [PATCH V8 01/19] virtio_ring: rename virtqueue_reinit_xxx to virtqueue_reset_xxx() Jason Wang
2025-10-20  7:09 ` [PATCH V8 02/19] virtio_ring: switch to use vring_virtqueue in virtqueue_poll variants Jason Wang
2025-10-20  7:09 ` [PATCH V8 03/19] virtio_ring: unify logic of virtqueue_poll() and more_used() Jason Wang
2025-10-20  7:09 ` [PATCH V8 04/19] virtio_ring: switch to use vring_virtqueue for virtqueue resize variants Jason Wang
2025-10-20  7:09 ` [PATCH V8 05/19] virtio_ring: switch to use vring_virtqueue for virtqueue_kick_prepare variants Jason Wang
2025-10-20  7:09 ` [PATCH V8 06/19] virtio_ring: switch to use vring_virtqueue for virtqueue_add variants Jason Wang
2025-10-20  7:09 ` [PATCH V8 07/19] virtio: switch to use vring_virtqueue for virtqueue_get variants Jason Wang
2025-10-20  7:09 ` [PATCH V8 08/19] virtio_ring: switch to use vring_virtqueue for enable_cb_prepare variants Jason Wang
2025-10-20  7:09 ` [PATCH V8 09/19] virtio_ring: use vring_virtqueue for enable_cb_delayed variants Jason Wang
2025-10-20  7:09 ` [PATCH V8 10/19] virtio_ring: switch to use vring_virtqueue for disable_cb variants Jason Wang
2025-10-20  7:09 ` [PATCH V8 11/19] virtio_ring: switch to use vring_virtqueue for detach_unused_buf variants Jason Wang
2025-10-20  7:09 ` [PATCH V8 12/19] virtio_ring: switch to use unsigned int for virtqueue_poll_packed() Jason Wang
2025-10-20 16:15   ` Michael S. Tsirkin
2025-10-21  3:53     ` Jason Wang
2025-10-20  7:09 ` [PATCH V8 13/19] virtio_ring: introduce virtqueue ops Jason Wang
2025-10-20 10:41   ` Michael S. Tsirkin
2025-10-21  3:28     ` Jason Wang
2025-10-20 15:20   ` Michael S. Tsirkin
2025-10-21  3:52     ` Jason Wang
2025-10-20  7:09 ` [PATCH V8 14/19] virtio_ring: determine descriptor flags at one time Jason Wang
2025-10-20 15:18   ` Michael S. Tsirkin
2025-10-21  3:50     ` Jason Wang
2025-10-20  7:09 ` [PATCH V8 15/19] virtio_ring: factor out core logic of buffer detaching Jason Wang
2025-10-20  7:10 ` [PATCH V8 16/19] virtio_ring: factor out core logic for updating last_used_idx Jason Wang
2025-10-20  7:10 ` [PATCH V8 17/19] virtio_ring: factor out split indirect detaching logic Jason Wang
2025-10-20 16:17   ` Michael S. Tsirkin
2025-10-21  3:55     ` Jason Wang
2025-10-20 18:05   ` Michael S. Tsirkin
2025-10-20  7:10 ` [PATCH V8 18/19] virtio_ring: factor out split " Jason Wang
2025-10-20 15:18   ` Michael S. Tsirkin
2025-10-21  3:36     ` Jason Wang
2025-10-21  8:27       ` Michael S. Tsirkin
2025-10-22  4:00         ` Jason Wang
2025-10-22  5:44           ` Michael S. Tsirkin
2025-10-20  7:10 ` [PATCH V8 19/19] virtio_ring: add in order support Jason Wang
2025-10-20  9:08   ` Michael S. Tsirkin
2025-10-21  3:21     ` Jason Wang
2025-10-20  9:13   ` Michael S. Tsirkin
2025-10-21  3:25     ` Jason Wang
2025-10-20 10:11   ` Michael S. Tsirkin
2025-10-21  3:26     ` Jason Wang
2025-10-20 15:19 ` [PATCH V8 00/19] virtio_ring " Michael S. Tsirkin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20251020071003.28834-1-jasowang@redhat.com \
    --to=jasowang@redhat.com \
    --cc=eperezma@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mst@redhat.com \
    --cc=virtualization@lists.linux.dev \
    --cc=xuanzhuo@linux.alibaba.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®