From: Rahul Kumar <rk0006818@gmail.com>
To: liviu.dudau@arm.com, maarten.lankhorst@linux.intel.com,
mripard@kernel.org, tzimmermann@suse.de, airlied@gmail.com,
simona@ffwll.ch
Cc: dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org,
rk0006818@gmail.com
Subject: [PATCH v2 0/3] drm/komeda: Convert logging to drm_* helpers
Date: Tue, 18 Nov 2025 16:29:31 +0530 [thread overview]
Message-ID: <20251118105934.748955-1-rk0006818@gmail.com> (raw)
This series converts Komeda logging from the legacy DRM_ERROR/WARN/INFO()
and DRM_DEBUG() macros to the modern drm_*() helpers. The drm_*() helpers
take a struct drm_device * and allow the DRM core to include device
information in the log output. This improves readability and brings the
driver in line with current DRM logging guidelines.
To support this conversion, a small Komeda internal header
(komeda_drv.h) is introduced to provide access to struct komeda_drv
where needed. No functional changes are intended.
Changes in v2:
- Corrected the use of dev_get_drvdata(); it returns struct komeda_drv *,
not struct komeda_kms_dev *.
- Added komeda_drv.h to make struct komeda_drv available for logging
conversion.
- Split the series into 3 small patches as requested.
Rahul Kumar (3):
drm/komeda: Add komeda_drv.h to make struct komeda_drv available
drm/komeda: Convert logging in komeda_pipeline.c to drm_* with
drm_device parameter
drm/komeda: Convert logging in d71_dev.c to drm_* with drm_device
parameter
.../gpu/drm/arm/display/komeda/d71/d71_dev.c | 24 +++++---
.../gpu/drm/arm/display/komeda/komeda_drv.c | 6 +-
.../gpu/drm/arm/display/komeda/komeda_drv.h | 24 ++++++++
.../drm/arm/display/komeda/komeda_pipeline.c | 61 +++++++++++++------
4 files changed, 84 insertions(+), 31 deletions(-)
create mode 100644 drivers/gpu/drm/arm/display/komeda/komeda_drv.h
--
2.43.0
next reply other threads:[~2025-11-18 10:59 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-11-18 10:59 Rahul Kumar [this message]
2025-11-18 10:59 ` [PATCH v2 1/3] drm/komeda: Add komeda_drv.h to make struct komeda_drv available Rahul Kumar
2025-11-18 10:59 ` [PATCH v2 2/3] drm/komeda: Convert logging in komeda_pipeline.c to drm_* with drm_device parameter Rahul Kumar
2025-11-18 10:59 ` [PATCH v2 3/3] drm/komeda: Convert logging in d71_dev.c " Rahul Kumar
2025-11-25 6:45 ` Rahul Kumar
2025-12-02 13:33 ` Liviu Dudau
2025-12-02 13:43 ` Rahul Kumar
2025-12-10 16:47 ` [PATCH v2 0/3] drm/komeda: Convert logging to drm_* helpers Liviu Dudau
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20251118105934.748955-1-rk0006818@gmail.com \
--to=rk0006818@gmail.com \
--cc=airlied@gmail.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=linux-kernel@vger.kernel.org \
--cc=liviu.dudau@arm.com \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mripard@kernel.org \
--cc=simona@ffwll.ch \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®