mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Xu Yilun <yilun.xu@linux.intel.com>
To: x86@kernel.org, dave.hansen@linux.intel.com, kas@kernel.org,
	linux-kernel@vger.kernel.org
Cc: chao.gao@intel.com, rick.p.edgecombe@intel.com,
	dan.j.williams@intel.com, baolu.lu@linux.intel.com,
	yilun.xu@linux.intel.com, yilun.xu@intel.com,
	zhenzhong.duan@intel.com, kvm@vger.kernel.org,
	adrian.hunter@intel.com
Subject: [PATCH 0/6] TDX: Stop metadata auto-generation, improve readability
Date: Tue,  2 Dec 2025 13:08:38 +0800	[thread overview]
Message-ID: <20251202050844.2520762-1-yilun.xu@linux.intel.com> (raw)

Hi:

This addresses the common need [1][2] to stop auto-generating metadata
reading code, improve readability, allowing us to manually edit and
review metadata code in a comfortable way. TDX Connect needs to add more
metadata fields based on this series, and I believe also for DPAMT and
TDX Module runtime update.

The main changes derive from previous code & discussions before
auto-generation is introduced, including the usage of
struct field_mapping table, the build-time field size check, the concern
about awkward "ret = ret ?: " code pattern. [3]

Another concern from DPAMT [4] leads to the last patch and I realize all
optional features may face with the same problem - Optional metadata
reading should be skipped when a TDX Module doesn't support, don't fail
the whole TDX Module initialization. I use "TDX Module Extensions" as
the example and test case just because I have the TDX Connect ENV on
hand.

This series is based on Dan's tsm#devsec-phase1 [5] (convenient for my
testing), but is clean to apply to v6.18-rc7.

[1] https://lore.kernel.org/kvm/1e7bcbad-eb26-44b7-97ca-88ab53467212@intel.com/
[2] https://lore.kernel.org/all/89a4e42d-b0fd-49b0-8d51-df7bac0d5e5b@intel.com/
[3] https://lore.kernel.org/kvm/9a06e2cf469cbca2777ac2c4ef70579e6bb934d5.camel@intel.com/
[4] https://lore.kernel.org/kvm/850f7ce0571cb54bc984c79861bdfd104e097eb9.camel@intel.com/
[5] https://git.kernel.org/pub/scm/linux/kernel/git/devsec/tsm.git/log/?h=devsec-phase1


Xu Yilun (6):
  x86/virt/tdx: Move bit definitions of TDX_FEATURES0 to public header
  x86/virt/tdx: Move read_sys_metadata_field() to where it is called
  x86/virt/tdx: Refactor metadata reading with a clearer for loop
  x86/virt/tdx: Sanity check the size of each metadata field
  x86/virt/tdx: Add generic support for reading array-typed metadata
  x86/virt/tdx: Skip unsupported metadata by querying tdx_feature0

 arch/x86/include/asm/tdx.h                  |   5 +
 arch/x86/include/asm/tdx_global_metadata.h  |  12 +-
 arch/x86/virt/vmx/tdx/tdx.h                 |   3 -
 arch/x86/virt/vmx/tdx/tdx.c                 |  20 --
 arch/x86/virt/vmx/tdx/tdx_global_metadata.c | 194 ++++++++++++--------
 5 files changed, 134 insertions(+), 100 deletions(-)

-- 
2.25.1


             reply	other threads:[~2025-12-02  5:24 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-12-02  5:08 Xu Yilun [this message]
2025-12-02  5:08 ` [PATCH 1/6] x86/virt/tdx: Move bit definitions of TDX_FEATURES0 to public header Xu Yilun
2025-12-02  5:08 ` [PATCH 2/6] x86/virt/tdx: Move read_sys_metadata_field() to where it is called Xu Yilun
2025-12-02  5:08 ` [PATCH 3/6] x86/virt/tdx: Refactor metadata reading with a clearer for loop Xu Yilun
2025-12-02  5:08 ` [PATCH 4/6] x86/virt/tdx: Sanity check the size of each metadata field Xu Yilun
2025-12-02  5:08 ` [PATCH 5/6] x86/virt/tdx: Add generic support for reading array-typed metadata Xu Yilun
2025-12-02  5:08 ` [PATCH 6/6] x86/virt/tdx: Skip unsupported metadata by querying tdx_feature0 Xu Yilun
2025-12-07  7:44 ` [PATCH 0/6] TDX: Stop metadata auto-generation, improve readability dan.j.williams
2025-12-08 10:17   ` Xu Yilun

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20251202050844.2520762-1-yilun.xu@linux.intel.com \
    --to=yilun.xu@linux.intel.com \
    --cc=adrian.hunter@intel.com \
    --cc=baolu.lu@linux.intel.com \
    --cc=chao.gao@intel.com \
    --cc=dan.j.williams@intel.com \
    --cc=dave.hansen@linux.intel.com \
    --cc=kas@kernel.org \
    --cc=kvm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rick.p.edgecombe@intel.com \
    --cc=x86@kernel.org \
    --cc=yilun.xu@intel.com \
    --cc=zhenzhong.duan@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®