From: Peter Zijlstra <peterz@infradead.org>
To: Josh Poimboeuf <jpoimboe@kernel.org>
Cc: x86@kernel.org, linux-kernel@vger.kernel.org,
Linus Torvalds <torvalds@linux-foundation.org>,
Ingo Molnar <mingo@kernel.org>, Borislav Petkov <bp@alien8.de>,
Thomas Gleixner <tglx@linutronix.de>
Subject: Re: [PATCH 8/8] x86/alternative: Convert alternatives to assembler macros
Date: Wed, 10 Dec 2025 10:16:45 +0100 [thread overview]
Message-ID: <20251210091645.GJ3707837@noisy.programming.kicks-ass.net> (raw)
In-Reply-To: <dccoaur5kkn4x6rbhtsqjwnswlokxyxtowkatbiwwb5b6etu3b@2pjtaijjjpmj>
On Tue, Dec 09, 2025 at 05:15:06PM -0800, Josh Poimboeuf wrote:
> Ok, so while the syntax itself is nested, the underlying behavior is
> just stacking alternatives together, like ALTERNATIVE_2 and _3 already
> do, correct?
Yup.
> While it's clever that the current implementation allows that kind of
> nested syntax, it seems dangerous. I don't see anything preventing the
> inner ALTERNATIVE from being placed in the middle of the outer
> ALTERNATIVE's original instructions, or anywhere in the outer's
> replacement code.
>
> It would be really easy to introduce CALL_NOSPEC in the middle of a
> group of instructions in an ALTERNATIVE without realizing that you're
> likely introducing some subtle or not-so-subtle bug on x86-32, which
> just happens to hide an ALTERNATIVE_2 inside the CALL_NOSPEC...
I think I made objtool complain in that case, but I'm not sure.
> The gas macro doesn't give you the leeway to make that mistake, so you'd
> have to restructure the code slightly to make it fit into a proper
> ALTERNATIVE_3. Which is less magical and more clear, so that seems like
> a good thing.
Perhaps, I'm not really a fan of the ALTERNATIVE_n() macros much. I
think writing the nested ALTERNATIVE() form is actually more readable.
But perhaps I'm the crazy one -- wouldn't be the first time :-)
Anyway, seeing how its not actually used, and I've since solved the case
that gave rise to all this completely differently, perhaps I should just
shut up and let you do the conversion.
I mean, we will have to do ALTERNATIVE_4() at some point, and it will be
glorious... *sigh*
next prev parent reply other threads:[~2025-12-10 9:16 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-12-06 21:41 [PATCH 0/8] objtool, x86/alternative: Convert objtool annotations and x86 " Josh Poimboeuf
2025-12-06 21:41 ` [PATCH 1/8] objtool: Rename ANNOTYPE_IGNORE_ALTS -> ANNOTYPE_IGNORE_ALTERNATIVE Josh Poimboeuf
2025-12-06 21:41 ` [PATCH 2/8] objtool: Make ANNOTYPE_DATA_SPECIAL unique across all annotations Josh Poimboeuf
2025-12-06 21:41 ` [PATCH 3/8] objtool: Rename C ANNOTATE_REACHABLE to ANNOTATE_REACHABLE_LABEL Josh Poimboeuf
2025-12-06 21:41 ` [PATCH 4/8] objtool: Rename asm ANNOTATE_NOCFI_SYM to ANNOTATE_NOCFI Josh Poimboeuf
2025-12-06 21:41 ` [PATCH 5/8] objtool: Convert annotations to assembler macros Josh Poimboeuf
2025-12-07 14:51 ` Josh Poimboeuf
2025-12-08 9:37 ` Peter Zijlstra
2025-12-06 21:41 ` [PATCH 6/8] x86/asm: Use unique code labels in __FILL_RETURN_BUFFER Josh Poimboeuf
2025-12-06 21:41 ` [PATCH 7/8] x86/asm: Remove newlines in alternatives Josh Poimboeuf
2025-12-07 14:52 ` Josh Poimboeuf
2025-12-06 21:41 ` [PATCH 8/8] x86/alternative: Convert alternatives to assembler macros Josh Poimboeuf
2025-12-08 9:51 ` Peter Zijlstra
2025-12-08 22:46 ` Josh Poimboeuf
2025-12-09 9:24 ` Peter Zijlstra
2025-12-10 1:15 ` Josh Poimboeuf
2025-12-10 9:16 ` Peter Zijlstra [this message]
2025-12-11 5:20 ` Josh Poimboeuf
2025-12-11 1:06 ` [PATCH 0/8] objtool, x86/alternative: Convert objtool annotations and x86 " Borislav Petkov
2025-12-11 5:27 ` Josh Poimboeuf
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20251210091645.GJ3707837@noisy.programming.kicks-ass.net \
--to=peterz@infradead.org \
--cc=bp@alien8.de \
--cc=jpoimboe@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@kernel.org \
--cc=tglx@linutronix.de \
--cc=torvalds@linux-foundation.org \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®