From: Detlev Casanova <detlev.casanova@collabora.com>
To: linux-kernel@vger.kernel.org
Cc: Mauro Carvalho Chehab <mchehab@kernel.org>,
Detlev Casanova <detlev.casanova@collabora.com>,
Ezequiel Garcia <ezequiel@vanguardiasur.com.ar>,
Heiko Stuebner <heiko@sntech.de>,
Daniel Almeida <daniel.almeida@collabora.com>,
Jonathan Corbet <corbet@lwn.net>,
Ricardo Ribalda <ribalda@chromium.org>,
Hans Verkuil <hverkuil@kernel.org>, Yunke Cao <yunkec@google.com>,
Hans de Goede <hansg@kernel.org>,
Laurent Pinchart <laurent.pinchart@ideasonboard.com>,
Nicolas Dufresne <nicolas.dufresne@collabora.com>,
Sakari Ailus <sakari.ailus@linux.intel.com>,
Pavan Bobba <opensource206@gmail.com>,
James Cowgill <james.cowgill@blaize.com>,
linux-media@vger.kernel.org, linux-rockchip@lists.infradead.org,
linux-arm-kernel@lists.infradead.org, kernel@collabora.com
Subject: [PATCH v6 00/17] media: rkvdec: Add support for VDPU381 and VDPU383
Date: Wed, 17 Dec 2025 12:40:37 -0500 [thread overview]
Message-ID: <20251217174059.1341784-1-detlev.casanova@collabora.com> (raw)
These variants are found respectively in the RK3588 and RK3576 SoCs.
This patch only adds support for H264 and H265 in both variants.
As there is a considerable part of the code that can be shared with the
already supported rkvdec decoder driver, the support for these variants
is added here rather than writing a new driver.
This patch set uses the newly introduced hevc_ext_sps_[ls]t_rps v4l2
controls for HEVC.
Therefore, a patched version of userpace tools is needed for HEVC
support (added for GStreamer[1] and in an early stage for FFmpeg[2]).
The DTS changes can be found in another patch set: [3]
[1]: https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/9355
[2]: https://gitlab.collabora.com/detlev/ffmpeg
[3]: https://lore.kernel.org/all/20251020212009.8852-1-detlev.casanova@collabora.com/
Changes since v5:
- Extract multicore management in separate commit
- Move variant specific functions to an ops struct
- Fix a typo and "h264" -> "hevc" copy/paste mistakes
- Move RKVDEC_*_PIXELS to rkvdec.h
- Drop VDPU383_*_PIXELS, use the the RKVDEC ones instead
- Change RKVDEC_1080P_PIXELS value to 1920 * 1088
- Long and short term ref sets extend controls:
- Add them in visl traces
- Reword documentation to specify SPS extension and use
- Mention Vulkan Video API similarity
- Specify behavior for empty array values
- Reorder struct fields to ensure fixed compiled size
- Remove the mention of V4L2_CTRL_FLAG_DYNAMIC_ARRAY flag
Changes since v4:
- Add basic ext_sps_[ls]t_rps validation (flags only)
- Add missing copyright in new common files
- Rename num_coded_fmts, rcb_num, clk_count
- Avoid allocating RCB config when not needed
- Merge rkvdec_config into rkvdec_variant
- Keep rkvdec_hevc_get_image_fmt per variant
Changes since v3:
- Rebased on latest next (ea299a216426) + HEVC support for rk3399
Changes since v2:
- Rebased on Kwiboo's HEVC support for rk3399
- Include hevc_ext_sps_[ls]t_rps v4l2 controls commits
- Remove empty lines at end of files
- Rename RKVDEC2_ALLOC_* to RKVDEC_ALLOC_*
- Set min_with and min_height to 64
- Remove vdpu38x_fill_pixfmt_mp() function
- Handle userspace not supporting hevc_ext_sps_[ls]t_rps
- Make all config structs static const
Changes since v1:
- Add parsing of the short and long term ref frame sets from the new v4l2
controls
- Add RPS cache to avoid parsing the same data again
- Fix HEVC pixel formats selection
- Fix multiple indentation errors
Detlev Casanova (17):
media: uapi: HEVC: Add v4l2_ctrl_hevc_ext_sps_[ls]t_rps controls
media: v4l2-ctrls: Add hevc_ext_sps_[ls]t_rps controls
media: visl: Add HEVC short and long term RPS sets
media: rkvdec: Switch to using structs instead of writel
media: rkvdec: Move cabac tables to their own source file
media: rkvdec: Use structs to represent the HW RPS
media: rkvdec: Move h264 functions to common file
media: rkvdec: Move hevc functions to common file
media: rkvdec: Add variant specific coded formats list
media: rkvdec: Add RCB and SRAM support
media: rkvdec: Support per-variant interrupt handler
media: rkvdec: Enable all clocks without naming them
media: rkvdec: Disable multicore support
media: rkvdec: Add H264 support for the VDPU381 variant
media: rkvdec: Add H264 support for the VDPU383 variant
media: rkvdec: Add HEVC support for the VDPU381 variant
media: rkvdec: Add HEVC support for the VDPU383 variant
.../media/v4l/ext-ctrls-codec-stateless.rst | 120 +++
.../media/v4l/videodev2.h.rst.exceptions | 2 +
.../media/v4l/vidioc-queryctrl.rst | 12 +
.../media/platform/rockchip/rkvdec/Kconfig | 1 +
.../media/platform/rockchip/rkvdec/Makefile | 14 +-
.../{rkvdec-hevc-data.c => rkvdec-cabac.c} | 506 +++++++++-
.../rockchip/rkvdec/rkvdec-h264-common.c | 258 +++++
.../rockchip/rkvdec/rkvdec-h264-common.h | 89 ++
.../platform/rockchip/rkvdec/rkvdec-h264.c | 891 ++----------------
.../rockchip/rkvdec/rkvdec-hevc-common.c | 488 ++++++++++
.../rockchip/rkvdec/rkvdec-hevc-common.h | 108 +++
.../platform/rockchip/rkvdec/rkvdec-hevc.c | 257 +----
.../platform/rockchip/rkvdec/rkvdec-rcb.c | 178 ++++
.../platform/rockchip/rkvdec/rkvdec-rcb.h | 29 +
.../platform/rockchip/rkvdec/rkvdec-regs.h | 571 +++++++----
.../rockchip/rkvdec/rkvdec-vdpu381-h264.c | 469 +++++++++
.../rockchip/rkvdec/rkvdec-vdpu381-hevc.c | 641 +++++++++++++
.../rockchip/rkvdec/rkvdec-vdpu381-regs.h | 424 +++++++++
.../rockchip/rkvdec/rkvdec-vdpu383-h264.c | 582 ++++++++++++
.../rockchip/rkvdec/rkvdec-vdpu383-hevc.c | 736 +++++++++++++++
.../rockchip/rkvdec/rkvdec-vdpu383-regs.h | 281 ++++++
.../platform/rockchip/rkvdec/rkvdec-vp9.c | 231 ++---
.../media/platform/rockchip/rkvdec/rkvdec.c | 542 ++++++++++-
.../media/platform/rockchip/rkvdec/rkvdec.h | 43 +
drivers/media/test-drivers/visl/visl-dec.c | 7 +
drivers/media/test-drivers/visl/visl-dec.h | 3 +
.../media/test-drivers/visl/visl-trace-hevc.h | 59 ++
drivers/media/v4l2-core/v4l2-ctrls-core.c | 28 +
drivers/media/v4l2-core/v4l2-ctrls-defs.c | 10 +
include/uapi/linux/v4l2-controls.h | 61 ++
include/uapi/linux/videodev2.h | 2 +
31 files changed, 6230 insertions(+), 1413 deletions(-)
rename drivers/media/platform/rockchip/rkvdec/{rkvdec-hevc-data.c => rkvdec-cabac.c} (86%)
create mode 100644 drivers/media/platform/rockchip/rkvdec/rkvdec-h264-common.c
create mode 100644 drivers/media/platform/rockchip/rkvdec/rkvdec-h264-common.h
create mode 100644 drivers/media/platform/rockchip/rkvdec/rkvdec-hevc-common.c
create mode 100644 drivers/media/platform/rockchip/rkvdec/rkvdec-hevc-common.h
create mode 100644 drivers/media/platform/rockchip/rkvdec/rkvdec-rcb.c
create mode 100644 drivers/media/platform/rockchip/rkvdec/rkvdec-rcb.h
create mode 100644 drivers/media/platform/rockchip/rkvdec/rkvdec-vdpu381-h264.c
create mode 100644 drivers/media/platform/rockchip/rkvdec/rkvdec-vdpu381-hevc.c
create mode 100644 drivers/media/platform/rockchip/rkvdec/rkvdec-vdpu381-regs.h
create mode 100644 drivers/media/platform/rockchip/rkvdec/rkvdec-vdpu383-h264.c
create mode 100644 drivers/media/platform/rockchip/rkvdec/rkvdec-vdpu383-hevc.c
create mode 100644 drivers/media/platform/rockchip/rkvdec/rkvdec-vdpu383-regs.h
--
2.52.0
next reply other threads:[~2025-12-17 17:41 UTC|newest]
Thread overview: 24+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-12-17 17:40 Detlev Casanova [this message]
2025-12-17 17:40 ` [PATCH v6 01/17] media: uapi: HEVC: Add v4l2_ctrl_hevc_ext_sps_[ls]t_rps controls Detlev Casanova
2025-12-17 17:40 ` [PATCH v6 02/17] media: v4l2-ctrls: Add hevc_ext_sps_[ls]t_rps controls Detlev Casanova
2025-12-17 17:40 ` [PATCH v6 03/17] media: visl: Add HEVC short and long term RPS sets Detlev Casanova
2025-12-17 17:40 ` [PATCH v6 04/17] media: rkvdec: Switch to using structs instead of writel Detlev Casanova
2025-12-17 23:15 ` Jonas Karlman
2025-12-17 17:40 ` [PATCH v6 05/17] media: rkvdec: Move cabac tables to their own source file Detlev Casanova
2025-12-17 17:40 ` [PATCH v6 06/17] media: rkvdec: Use structs to represent the HW RPS Detlev Casanova
2025-12-17 17:40 ` [PATCH v6 07/17] media: rkvdec: Move h264 functions to common file Detlev Casanova
2025-12-17 17:40 ` [PATCH v6 08/17] media: rkvdec: Move hevc " Detlev Casanova
2025-12-17 17:40 ` [PATCH v6 09/17] media: rkvdec: Add variant specific coded formats list Detlev Casanova
2025-12-17 23:37 ` Jonas Karlman
2025-12-17 17:40 ` [PATCH v6 10/17] media: rkvdec: Add RCB and SRAM support Detlev Casanova
2025-12-17 23:27 ` Jonas Karlman
2025-12-17 17:40 ` [PATCH v6 11/17] media: rkvdec: Support per-variant interrupt handler Detlev Casanova
2025-12-17 17:40 ` [PATCH v6 12/17] media: rkvdec: Enable all clocks without naming them Detlev Casanova
2025-12-17 17:40 ` [PATCH v6 13/17] media: rkvdec: Disable multicore support Detlev Casanova
2025-12-17 17:40 ` [PATCH v6 14/17] media: rkvdec: Add H264 support for the VDPU381 variant Detlev Casanova
2025-12-17 23:56 ` Jonas Karlman
2025-12-17 17:40 ` [PATCH v6 15/17] media: rkvdec: Add H264 support for the VDPU383 variant Detlev Casanova
2025-12-18 0:18 ` Jonas Karlman
2025-12-17 17:40 ` [PATCH v6 16/17] media: rkvdec: Add HEVC support for the VDPU381 variant Detlev Casanova
2025-12-18 0:47 ` Jonas Karlman
2025-12-17 17:40 ` [PATCH v6 17/17] media: rkvdec: Add HEVC support for the VDPU383 variant Detlev Casanova
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20251217174059.1341784-1-detlev.casanova@collabora.com \
--to=detlev.casanova@collabora.com \
--cc=corbet@lwn.net \
--cc=daniel.almeida@collabora.com \
--cc=ezequiel@vanguardiasur.com.ar \
--cc=hansg@kernel.org \
--cc=heiko@sntech.de \
--cc=hverkuil@kernel.org \
--cc=james.cowgill@blaize.com \
--cc=kernel@collabora.com \
--cc=laurent.pinchart@ideasonboard.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=linux-rockchip@lists.infradead.org \
--cc=mchehab@kernel.org \
--cc=nicolas.dufresne@collabora.com \
--cc=opensource206@gmail.com \
--cc=ribalda@chromium.org \
--cc=sakari.ailus@linux.intel.com \
--cc=yunkec@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®