mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: david.laight.linux@gmail.com
To: Thomas Gleixner <tglx@linutronix.de>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	Peter Zijlstra <peterz@infradead.org>,
	Mathieu Desnoyers <mathieu.desnoyers@efficios.com>,
	Kees Cook <kees@kernel.org>,
	linux-kernel@vger.kernel.org, akpm@linux-foundation.org,
	Al Viro <viro@zeniv.linux.org.uk>
Cc: David Laight <david.laight.linux@gmail.com>
Subject: [PATCH 0/5] uaccess: Updates to scoped_user_access()
Date: Sat, 20 Dec 2025 21:56:03 +0000	[thread overview]
Message-ID: <20251220215608.434614-1-david.laight.linux@gmail.com> (raw)

From: David Laight <david.laight.linux@gmail.com>

Converting kernel/signal.c to use scoped_user_access() had compilation
warnings because some of the pointers are 'pointer to const'.
This is fixed in patch 1.

Patches 2 and 3 factor out the 'autoterminating nested for loops'.
I'm sure there'll be a 'bikeshed' discussion about the names.

I think the two 'typeof(uptr)' could be 'auto', compiles for me
but IIRC there are issues with old compilers.

Patch 4 stops warnings from -Wshadow (enabled by W=2).
I did think about making the _diag_xxx conditional on a W=2 build,
but since the pre-processor just emits #pragma lines and they are
smaller that the for() loop it doesn't seem worth while.

Patch 5 is the change to signal.c that prompted patch 1.
The generated code looks fine, but I've not tested it.
Most of the changes are to 'compat' code - so are probably not
usually performance critical.
IIRC the non-compat code uses copy_to/from_user() for the structures
so is probably slower than the compat code's member by member copy.

David Laight (5):
  uaccess: Fix scoped_user_read_access() for 'pointer to const'
  compiler.h: Add generic support for 'autoterminating nested for()
    loops'
  uaccess.h: Use with() and and_with() in __scoped_user_access()
  uaccess: Disable -Wshadow in __scoped_user_access()
  signal: Use scoped_user_access() instead of __put/get_user()

 include/linux/compiler.h | 26 +++++++++++++++
 include/linux/uaccess.h  | 32 +++++++++---------
 kernel/signal.c          | 72 +++++++++++++++++++++++-----------------
 3 files changed, 84 insertions(+), 46 deletions(-)

-- 
2.39.5


             reply	other threads:[~2025-12-20 21:56 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-12-20 21:56 david.laight.linux [this message]
2025-12-20 21:56 ` [PATCH 1/5] uaccess: Fix scoped_user_read_access() for 'pointer to const' david.laight.linux
2025-12-20 21:56 ` [PATCH 2/5] compiler.h: Add generic support for 'autoterminating nested for() loops' david.laight.linux
2025-12-20 21:56 ` [PATCH 3/5] uaccess.h: Use with() and and_with() in __scoped_user_access() david.laight.linux
2025-12-20 21:56 ` [PATCH 4/5] uaccess: Disable -Wshadow " david.laight.linux
2025-12-20 21:56 ` [PATCH 5/5] signal: Use scoped_user_access() instead of __put/get_user() david.laight.linux

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20251220215608.434614-1-david.laight.linux@gmail.com \
    --to=david.laight.linux@gmail.com \
    --cc=akpm@linux-foundation.org \
    --cc=kees@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mathieu.desnoyers@efficios.com \
    --cc=peterz@infradead.org \
    --cc=tglx@linutronix.de \
    --cc=torvalds@linux-foundation.org \
    --cc=viro@zeniv.linux.org.uk \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®