mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jason Wang <jasowang@redhat.com>
To: mst@redhat.com, jasowang@redhat.com
Cc: xuanzhuo@linux.alibaba.com, eperezma@redhat.com,
	virtualization@lists.linux.dev, linux-kernel@vger.kernel.org
Subject: [PATCH V11 12/19] virtio_ring: switch to use unsigned int for virtqueue_poll_packed()
Date: Tue, 30 Dec 2025 14:46:42 +0800	[thread overview]
Message-ID: <20251230064649.55597-13-jasowang@redhat.com> (raw)
In-Reply-To: <20251230064649.55597-1-jasowang@redhat.com>

Switch to use unsigned int for virtqueue_poll_packed() to match
virtqueue_poll() and virtqueue_poll_split() and to ease the
abstraction of the virtqueue ops.

Signed-off-by: Jason Wang <jasowang@redhat.com>
---
 drivers/virtio/virtio_ring.c | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/drivers/virtio/virtio_ring.c b/drivers/virtio/virtio_ring.c
index db5cdb5fcb20..f804c5c6975a 100644
--- a/drivers/virtio/virtio_ring.c
+++ b/drivers/virtio/virtio_ring.c
@@ -1699,7 +1699,8 @@ static inline bool is_used_desc_packed(const struct vring_virtqueue *vq,
 	return avail == used && used == used_wrap_counter;
 }
 
-static bool virtqueue_poll_packed(const struct vring_virtqueue *vq, u16 off_wrap)
+static bool virtqueue_poll_packed(const struct vring_virtqueue *vq,
+				  unsigned int off_wrap)
 {
 	bool wrap_counter;
 	u16 used_idx;
-- 
2.31.1


  parent reply	other threads:[~2025-12-30  6:47 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-12-30  6:46 [PATCH V11 00/19] virtio_ring in order support Jason Wang
2025-12-30  6:46 ` [PATCH V11 01/19] virtio_ring: rename virtqueue_reinit_xxx to virtqueue_reset_xxx() Jason Wang
2025-12-30  6:46 ` [PATCH V11 02/19] virtio_ring: switch to use vring_virtqueue in virtqueue_poll variants Jason Wang
2025-12-30  6:46 ` [PATCH V11 03/19] virtio_ring: unify logic of virtqueue_poll() and more_used() Jason Wang
2025-12-30  6:46 ` [PATCH V11 04/19] virtio_ring: switch to use vring_virtqueue for virtqueue resize variants Jason Wang
2025-12-30  6:46 ` [PATCH V11 05/19] virtio_ring: switch to use vring_virtqueue for virtqueue_kick_prepare variants Jason Wang
2025-12-30  6:46 ` [PATCH V11 06/19] virtio_ring: switch to use vring_virtqueue for virtqueue_add variants Jason Wang
2025-12-30  6:46 ` [PATCH V11 07/19] virtio: switch to use vring_virtqueue for virtqueue_get variants Jason Wang
2025-12-30  6:46 ` [PATCH V11 08/19] virtio_ring: switch to use vring_virtqueue for enable_cb_prepare variants Jason Wang
2025-12-30  6:46 ` [PATCH V11 09/19] virtio_ring: use vring_virtqueue for enable_cb_delayed variants Jason Wang
2025-12-30  6:46 ` [PATCH V11 10/19] virtio_ring: switch to use vring_virtqueue for disable_cb variants Jason Wang
2025-12-30  6:46 ` [PATCH V11 11/19] virtio_ring: switch to use vring_virtqueue for detach_unused_buf variants Jason Wang
2025-12-30  6:46 ` Jason Wang [this message]
2025-12-30  6:46 ` [PATCH V11 13/19] virtio_ring: introduce virtqueue ops Jason Wang
2025-12-30  6:46 ` [PATCH V11 14/19] virtio_ring: determine descriptor flags at one time Jason Wang
2025-12-30  6:46 ` [PATCH V11 15/19] virtio_ring: factor out core logic of buffer detaching Jason Wang
2025-12-30  6:46 ` [PATCH V11 16/19] virtio_ring: factor out core logic for updating last_used_idx Jason Wang
2025-12-30  6:46 ` [PATCH V11 17/19] virtio_ring: factor out split indirect detaching logic Jason Wang
2025-12-30  6:46 ` [PATCH V11 18/19] virtio_ring: factor out split " Jason Wang
2025-12-30  6:46 ` [PATCH V11 19/19] virtio_ring: add in order support Jason Wang
  -- strict thread matches above, loose matches on Subject: below --
2025-12-25  4:25 [PATCH V11 00/19] virtio_ring " Jason Wang
2025-12-25  4:26 ` [PATCH V11 12/19] virtio_ring: switch to use unsigned int for virtqueue_poll_packed() Jason Wang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20251230064649.55597-13-jasowang@redhat.com \
    --to=jasowang@redhat.com \
    --cc=eperezma@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mst@redhat.com \
    --cc=virtualization@lists.linux.dev \
    --cc=xuanzhuo@linux.alibaba.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®