From: Thinh Nguyen <Thinh.Nguyen@synopsys.com>
To: Prashanth K <prashanth.k@oss.qualcomm.com>
Cc: Thinh Nguyen <Thinh.Nguyen@synopsys.com>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
"linux-usb@vger.kernel.org" <linux-usb@vger.kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"stable@vger.kernel.org" <stable@vger.kernel.org>
Subject: Re: [PATCH] usb: dwc3: gadget: Move vbus draw to workqueue context
Date: Tue, 3 Feb 2026 00:04:22 +0000 [thread overview]
Message-ID: <20260203000419.3fxiarn3wh7zq4vp@synopsys.com> (raw)
In-Reply-To: <20260129111403.3081730-1-prashanth.k@oss.qualcomm.com>
On Thu, Jan 29, 2026, Prashanth K wrote:
> Currently dwc3_gadget_vbus_draw() can be called from atomic
> context, which in turn invokes power-supply-core APIs. And
> some these PMIC APIs have operations that may sleep, leading
> to kernel panic.
>
> Fix this by moving the vbus_draw into a workqueue context.
>
> Fixes: 66e0ea341a2a ("usb: dwc3: core: Defer the probe until USB power supply ready")
> Cc: stable@vger.kernel.org
> Signed-off-by: Prashanth K <prashanth.k@oss.qualcomm.com>
> ---
> drivers/usb/dwc3/core.c | 19 ++++++++++++++++++-
> drivers/usb/dwc3/core.h | 4 ++++
> drivers/usb/dwc3/gadget.c | 8 +++-----
> 3 files changed, 25 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/usb/dwc3/core.c b/drivers/usb/dwc3/core.c
> index f32b67bf73a4..c9af126b9695 100644
> --- a/drivers/usb/dwc3/core.c
> +++ b/drivers/usb/dwc3/core.c
> @@ -2155,6 +2155,20 @@ static int dwc3_get_num_ports(struct dwc3 *dwc)
> return 0;
> }
>
> +static void dwc3_vbus_draw_work(struct work_struct *work)
> +{
> + struct dwc3 *dwc = container_of(work, struct dwc3, vbus_draw_work);
> + union power_supply_propval val = {0};
> + int ret;
> +
> + val.intval = 1000 * (dwc->vbus_draw_current);
> + ret = power_supply_set_property(dwc->usb_psy, POWER_SUPPLY_PROP_INPUT_CURRENT_LIMIT, &val);
> +
> + if (ret < 0)
> + dev_dbg(dwc->dev, "Error (%d) setting vbus draw (%d mA)\n",
> + ret, dwc->vbus_draw_current);
> +}
> +
> static struct power_supply *dwc3_get_usb_power_supply(struct dwc3 *dwc)
> {
> struct power_supply *usb_psy;
> @@ -2169,6 +2183,7 @@ static struct power_supply *dwc3_get_usb_power_supply(struct dwc3 *dwc)
> if (!usb_psy)
> return ERR_PTR(-EPROBE_DEFER);
>
> + INIT_WORK(&dwc->vbus_draw_work, dwc3_vbus_draw_work);
> return usb_psy;
> }
>
> @@ -2395,8 +2410,10 @@ void dwc3_core_remove(struct dwc3 *dwc)
>
> dwc3_free_event_buffers(dwc);
>
> - if (dwc->usb_psy)
> + if (dwc->usb_psy) {
> + cancel_work_sync(&dwc->vbus_draw_work);
> power_supply_put(dwc->usb_psy);
> + }
> }
> EXPORT_SYMBOL_GPL(dwc3_core_remove);
>
> diff --git a/drivers/usb/dwc3/core.h b/drivers/usb/dwc3/core.h
> index 08cc6f2b5c23..052fb18c6b5c 100644
> --- a/drivers/usb/dwc3/core.h
> +++ b/drivers/usb/dwc3/core.h
> @@ -1178,6 +1178,8 @@ struct dwc3_glue_ops {
> * @wakeup_pending_funcs: Indicates whether any interface has requested for
> * function wakeup in bitmap format where bit position
> * represents interface_id.
> + * @vbus_draw_work: Workqueue used for scheduling vbus draw work
This is "work" and not workqueue, and it's used to set the vbus drawing
limit. Move this below usb_psy.
> + * @vbus_draw_current: How much current to draw from vbus, in milliAmperes.
Can we rename this to current_limit to match the setting name? And move
this along with the above.
The rest looks fine to me.
Thanks,
Thinh
> */
> struct dwc3 {
> struct work_struct drd_work;
> @@ -1413,6 +1415,8 @@ struct dwc3 {
> struct dentry *debug_root;
> u32 gsbuscfg0_reqinfo;
> u32 wakeup_pending_funcs;
> + struct work_struct vbus_draw_work;
> + unsigned int vbus_draw_current;
> };
>
> #define INCRX_BURST_MODE 0
> diff --git a/drivers/usb/dwc3/gadget.c b/drivers/usb/dwc3/gadget.c
> index 9355c952c140..03d8a3a151e0 100644
> --- a/drivers/usb/dwc3/gadget.c
> +++ b/drivers/usb/dwc3/gadget.c
> @@ -3124,8 +3124,6 @@ static void dwc3_gadget_set_ssp_rate(struct usb_gadget *g,
> static int dwc3_gadget_vbus_draw(struct usb_gadget *g, unsigned int mA)
> {
> struct dwc3 *dwc = gadget_to_dwc(g);
> - union power_supply_propval val = {0};
> - int ret;
>
> if (dwc->usb2_phy)
> return usb_phy_set_power(dwc->usb2_phy, mA);
> @@ -3133,10 +3131,10 @@ static int dwc3_gadget_vbus_draw(struct usb_gadget *g, unsigned int mA)
> if (!dwc->usb_psy)
> return -EOPNOTSUPP;
>
> - val.intval = 1000 * mA;
> - ret = power_supply_set_property(dwc->usb_psy, POWER_SUPPLY_PROP_INPUT_CURRENT_LIMIT, &val);
> + dwc->vbus_draw_current = mA;
> + schedule_work(&dwc->vbus_draw_work);
>
> - return ret;
> + return 0;
> }
>
> /**
> --
> 2.34.1
>
next prev parent reply other threads:[~2026-02-03 0:31 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-01-29 11:14 Prashanth K
2026-01-31 20:14 ` Samuel Wu
2026-02-03 0:04 ` Thinh Nguyen [this message]
2026-02-04 3:59 ` Kyle Tso
2026-02-04 4:17 ` Prashanth K
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260203000419.3fxiarn3wh7zq4vp@synopsys.com \
--to=thinh.nguyen@synopsys.com \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=prashanth.k@oss.qualcomm.com \
--cc=stable@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®