mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@lst.de>
To: Namjae Jeon <linkinjeon@kernel.org>
Cc: viro@zeniv.linux.org.uk, brauner@kernel.org, hch@lst.de,
	tytso@mit.edu, willy@infradead.org, jack@suse.cz,
	djwong@kernel.org, josef@toxicpanda.com, sandeen@sandeen.net,
	rgoldwyn@suse.com, xiang@kernel.org, dsterba@suse.com,
	pali@kernel.org, ebiggers@kernel.org, neil@brown.name,
	amir73il@gmail.com, linux-fsdevel@vger.kernel.org,
	linux-kernel@vger.kernel.org, iamjoonsoo.kim@lge.com,
	cheol.lee@lge.com, jay.sim@lge.com, gunho.lee@lge.com
Subject: Re: [PATCH v6 12/16] ntfs: add reparse and ea operations
Date: Tue, 3 Feb 2026 07:37:58 +0100	[thread overview]
Message-ID: <20260203063758.GB18053@lst.de> (raw)
In-Reply-To: <20260202220202.10907-13-linkinjeon@kernel.org>

Suggested commit message:

Implement support for Extended Attributes and Reparse Points, enabling
Posix ACL support and, and compatibility with Windows Subsystem for
Linux (WSL) metadata.

> +struct WSL_LINK_REPARSE_DATA {
> +	__le32	type;
> +	char	link[];
> +};
> +
> +struct REPARSE_INDEX {			/* index entry in $Extend/$Reparse */

Why are these using all upper case names unlike the rest of the
code?

> +	ok = ni && reparse_attr && (size >= sizeof(struct reparse_point)) &&
> +		(reparse_attr->reparse_tag != IO_REPARSE_TAG_RESERVED_ZERO) &&
> +		(((size_t)le16_to_cpu(reparse_attr->reparse_data_length) +
> +		  sizeof(struct reparse_point) +
> +		  ((reparse_attr->reparse_tag & IO_REPARSE_TAG_IS_MICROSOFT) ?
> +		   0 : sizeof(struct guid))) == size);

A bunch of superflous braces.  But in general decomposing such complex
operations into an inline helper using multiple if statements and
adding comments improves the readability a lot.

> +	if (ok) {

... and just return here for !ok and reduce the indentation for
the rest of the function?

> +		switch (reparse_attr->reparse_tag) {
> +		case IO_REPARSE_TAG_LX_SYMLINK:
> +			wsl_reparse_data = (const struct WSL_LINK_REPARSE_DATA *)
> +						reparse_attr->reparse_data;
> +			if ((le16_to_cpu(reparse_attr->reparse_data_length) <=
> +			     sizeof(wsl_reparse_data->type)) ||
> +			    (wsl_reparse_data->type != cpu_to_le32(2)))
> +				ok = false;
> +			break;
> +		case IO_REPARSE_TAG_AF_UNIX:
> +		case IO_REPARSE_TAG_LX_FIFO:
> +		case IO_REPARSE_TAG_LX_CHR:
> +		case IO_REPARSE_TAG_LX_BLK:
> +			if (reparse_attr->reparse_data_length ||
> +			    !(ni->flags & FILE_ATTRIBUTE_RECALL_ON_OPEN))
> +				ok = false;
> +			break;

... and then directly return from inside the switch as well?


  reply	other threads:[~2026-02-03  6:38 UTC|newest]

Thread overview: 37+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-02-02 22:01 [PATCH v6 00/16] ntfs filesystem remake Namjae Jeon
2026-02-02 22:01 ` [PATCH v6 01/16] Revert "fs: Remove NTFS classic" Namjae Jeon
2026-02-02 22:01 ` [PATCH v6 02/16] Documentation: filesystems: update NTFS driver documentation Namjae Jeon
2026-02-03  5:44   ` Christoph Hellwig
2026-02-03 13:01     ` Namjae Jeon
2026-02-02 22:01 ` [PATCH v6 03/16] fs: add generic FS_IOC_SHUTDOWN definitions Namjae Jeon
2026-02-02 22:36   ` Darrick J. Wong
2026-02-03  5:38     ` Christoph Hellwig
2026-02-03  8:54   ` Jan Kara
2026-02-02 22:01 ` [PATCH v6 04/16] ntfs: update in-memory, on-disk structures and headers Namjae Jeon
2026-02-03  5:47   ` Christoph Hellwig
2026-02-03 13:03     ` Namjae Jeon
2026-02-02 22:01 ` [PATCH v6 05/16] ntfs: update super block operations Namjae Jeon
2026-02-03  5:52   ` Christoph Hellwig
2026-02-03 13:04     ` Namjae Jeon
2026-02-02 22:01 ` [PATCH v6 07/16] ntfs: update directory operations Namjae Jeon
2026-02-03  5:55   ` Christoph Hellwig
2026-02-03 13:04     ` Namjae Jeon
2026-02-02 22:01 ` [PATCH v6 08/16] ntfs: update file operations Namjae Jeon
2026-02-03  6:07   ` Christoph Hellwig
2026-02-03 13:08     ` Namjae Jeon
2026-02-02 22:01 ` [PATCH v6 09/16] ntfs: update iomap and address space operations Namjae Jeon
2026-02-03  6:20   ` Christoph Hellwig
2026-02-03 14:05     ` Namjae Jeon
2026-02-02 22:01 ` [PATCH v6 10/16] ntfs: update attrib operations Namjae Jeon
2026-02-03  6:22   ` Christoph Hellwig
2026-02-03 14:06     ` Namjae Jeon
2026-02-02 22:01 ` [PATCH v6 11/16] ntfs: update runlist handling and cluster allocator Namjae Jeon
2026-02-03  6:34   ` Christoph Hellwig
2026-02-03 14:22     ` Namjae Jeon
2026-02-02 22:01 ` [PATCH v6 12/16] ntfs: add reparse and ea operations Namjae Jeon
2026-02-03  6:37   ` Christoph Hellwig [this message]
2026-02-03 14:17     ` Namjae Jeon
2026-02-02 22:02 ` [PATCH v6 14/16] ntfs3: remove legacy ntfs driver support Namjae Jeon
2026-02-02 22:02 ` [PATCH v6 15/16] ntfs: add Kconfig and Makefile Namjae Jeon
2026-02-03  6:38   ` Christoph Hellwig
2026-02-02 22:02 ` [PATCH v6 16/16] MAINTAINERS: update ntfs filesystem entry Namjae Jeon

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260203063758.GB18053@lst.de \
    --to=hch@lst.de \
    --cc=amir73il@gmail.com \
    --cc=brauner@kernel.org \
    --cc=cheol.lee@lge.com \
    --cc=djwong@kernel.org \
    --cc=dsterba@suse.com \
    --cc=ebiggers@kernel.org \
    --cc=gunho.lee@lge.com \
    --cc=iamjoonsoo.kim@lge.com \
    --cc=jack@suse.cz \
    --cc=jay.sim@lge.com \
    --cc=josef@toxicpanda.com \
    --cc=linkinjeon@kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=neil@brown.name \
    --cc=pali@kernel.org \
    --cc=rgoldwyn@suse.com \
    --cc=sandeen@sandeen.net \
    --cc=tytso@mit.edu \
    --cc=viro@zeniv.linux.org.uk \
    --cc=willy@infradead.org \
    --cc=xiang@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®