From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from smtp.kernel.org (aws-us-west-2-korg-mail-1.web.codeaurora.org [10.30.226.201]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id F2EDE1A2389 for ; Wed, 4 Feb 2026 22:31:17 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=10.30.226.201 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1770244278; cv=none; b=aq1tBisK5L0fYWWsWcHZWh9umqIeZTEjWIIPUm833mMDNkDMCGKXFabSrB+5sLlorWJj6fev3p8g509ScKjp9ITnlqA4RsZMDyPK6t4UeTdosh6kuV26MuIIT3FmfjUXtnrhTHnTXDP5P9D/PpsRDQdCB0W3hL1WX/hJ+r29jXg= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1770244278; c=relaxed/simple; bh=il7aJ3eIWZeVJd7eT+iGQ2haRY0GHhIg8kpdTR7XNp8=; h=Date:From:To:Cc:Subject:Message-Id:In-Reply-To:References: Mime-Version:Content-Type; b=fyNd+5iEtULhy1syX5cTiTC4w4m3f1kqKcRaF66QSZ/KIZpciH2Dl1OVmmW+Y7R1XftFnkNEqyz9ekJOMKEvn4xejyJ9XQ5Xdn4BYhpLJKTKw/Zf4yZsKsw3lpTlkpLEfLogurObKtVBefhsCgmDjUH20Kxa/C7s4DrpUGnqI1k= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dkim=pass (1024-bit key) header.d=linux-foundation.org header.i=@linux-foundation.org header.b=bkZWq0tF; arc=none smtp.client-ip=10.30.226.201 Authentication-Results: smtp.subspace.kernel.org; dkim=pass (1024-bit key) header.d=linux-foundation.org header.i=@linux-foundation.org header.b="bkZWq0tF" Received: by smtp.kernel.org (Postfix) with ESMTPSA id E3D8EC4CEF7; Wed, 4 Feb 2026 22:31:16 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=linux-foundation.org; s=korg; t=1770244277; bh=il7aJ3eIWZeVJd7eT+iGQ2haRY0GHhIg8kpdTR7XNp8=; h=Date:From:To:Cc:Subject:In-Reply-To:References:From; b=bkZWq0tFfzkTtKtN9z61RnYCdolEQZCrTfV/oYrh/sDwDq0gdnXdY1AgNDzqUlrg0 AR3I/AtvQpwKFs3KFEzCcHdDYlLZc5FLAhWHu0DCrlhNqY5jPKTOcNb+shpL6YHDUR Ql8O4/bWbC6TEorw5hpeY7Gd5/JAKNbLuI8mGsbg= Date: Wed, 4 Feb 2026 14:31:16 -0800 From: Andrew Morton To: "David Hildenbrand (arm)" Cc: Ankur Arora , linux-kernel@vger.kernel.org, linux-mm@kvack.org, x86@kernel.org, bp@alien8.de, dave.hansen@linux.intel.com, hpa@zytor.com, mingo@redhat.com, mjguzik@gmail.com, luto@kernel.org, peterz@infradead.org, tglx@linutronix.de, willy@infradead.org, raghavendra.kt@amd.com, chleroy@kernel.org, ioworker0@gmail.com, lizhe.67@bytedance.com, boris.ostrovsky@oracle.com, konrad.wilk@oracle.com, kernel test robot Subject: Re: [PATCH v2] mm: folio_zero_user: open code range computation in folio_zero_user() Message-Id: <20260204143116.968730e769500aea281809bb@linux-foundation.org> In-Reply-To: <9206a7c4-bf88-4138-b8af-961625a82439@kernel.org> References: <20260107072009.1615991-9-ankur.a.arora@oracle.com> <20260128185943.2397128-1-ankur.a.arora@oracle.com> <9206a7c4-bf88-4138-b8af-961625a82439@kernel.org> X-Mailer: Sylpheed 3.8.0beta1 (GTK+ 2.24.33; x86_64-pc-linux-gnu) Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: Mime-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Content-Transfer-Encoding: 7bit On Wed, 4 Feb 2026 22:01:42 +0100 "David Hildenbrand (arm)" wrote: > > As David pointed out, the previous open coded version makes a few > > unnecessary changes. Could you queue this one instead? > > > > I'm late, maybe this is already upstream. It's in mm-unstable. The second round of MM upstreaming is two weeks hence. > > > > /* Region to the left of the fault */ > > - r[1] = DEFINE_RANGE(pg.start, > > - clamp_t(s64, r[2].start - 1, pg.start - 1, r[2].start)); > > + r[1] = DEFINE_RANGE(pg.start, r[2].start - 1); > > > > /* Region to the right of the fault: always valid for the common fault_idx=0 case. */ > > - r[0] = DEFINE_RANGE(clamp_t(s64, r[2].end + 1, r[2].end, pg.end + 1), > > - pg.end); > > + r[0] = DEFINE_RANGE(r[2].end + 1, pg.end); > > TBH, without the clamp that looks much more readable here. me too. > > > > for (i = 0; i < ARRAY_SIZE(r); i++) { > > const unsigned long addr = base_addr + r[i].start * PAGE_SIZE; > > - const unsigned int nr_pages = range_len(&r[i]); > > + const long nr_pages = (long)range_len(&r[i]); > > struct page *page = folio_page(folio, r[i].start); > > > > if (nr_pages > 0) > > - clear_contig_highpages(page, addr, nr_pages); > > + clear_contig_highpages(page, addr, (unsigned int)nr_pages); > > Is that cast really required? Seems not. The types for nr_pages are a bit chaotic - u64->long->uint.