From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from mail-wm1-f42.google.com (mail-wm1-f42.google.com [209.85.128.42]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id CB3591FC7FB for ; Tue, 24 Feb 2026 18:30:05 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=209.85.128.42 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1771957807; cv=none; b=YXKstOr412OoORy43irFtuZQKjBKPn4iPYX/CyxbUjY2DXDmnAPfs1o2ZWinsGyF4NSAXgmDo0qBeaoyf6+MIVreXr7a3MM+At/grwgXYM7CyiuxfInzzxqD7UGQ1ELtI7HELji7a1s8/i40xXIkvkFph82GIaHcQncVqfazKrs= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1771957807; c=relaxed/simple; bh=PbWZcT3aIYFxW5Ppb1wt0AuvqcdTG4aMUdC3K7Y8Al4=; h=Date:From:To:Cc:Subject:Message-ID:References:MIME-Version: Content-Type:Content-Disposition:In-Reply-To; b=DjivVPJUf4tWCYNO5TCaDle5NP+iV+aZ2PEw+3A6EFjAgaLvszRB4W2+gIVwaXiMxSaD+4u07CyEXQVVyPUVvEJeiLaba8VWuGGP8sVO8A9ZXtDGb6Ab6zvk+EEThLaDefhD3eZ+nUztkEimQqiKLLlf1d92uXyC02Ia+vGdyyg= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=gmail.com; spf=pass smtp.mailfrom=gmail.com; dkim=pass (2048-bit key) header.d=gmail.com header.i=@gmail.com header.b=MOwu1Tzl; arc=none smtp.client-ip=209.85.128.42 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=gmail.com Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=gmail.com Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=gmail.com header.i=@gmail.com header.b="MOwu1Tzl" Received: by mail-wm1-f42.google.com with SMTP id 5b1f17b1804b1-483bcff7a3dso584705e9.1 for ; Tue, 24 Feb 2026 10:30:05 -0800 (PST) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20230601; t=1771957804; x=1772562604; darn=vger.kernel.org; h=in-reply-to:content-disposition:mime-version:references:message-id :subject:cc:to:from:date:from:to:cc:subject:date:message-id:reply-to; bh=vy6D+hE2xhOiRI343jCC4Oy3zlTR5Sfyp5vbNl4FLck=; b=MOwu1TzlNkaHTjAY/kjFzhMfrw3YMh+DCp7RFsczNj7z/TMwK5rMuRjklmk1THbBT2 WS4DE4QboA4CHkn0cEE/q/vGSyx9i9H/FBFwGxPUh6sdPcAlAFq+ndF6fi+C0EfDLTDz KZ5Y647ipXr7g6CEqVwuLLQSnpRCSFq2WdqANGNkEFs0VFsQlIXy6IQW+qpf2WWS8alx hBREeuPmVx/nbYloc79yYJztcFa4HkglBzdvAyUKZW4G7JDQEVqHTKgh4A5M9ivp2rRl oySGw8V2akJbTN5PubfL8LcH8AVRgKC6/DK8MeEj3zEKFxl496tZHLJOy2N2xXmvCN4A 30iQ== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1771957804; x=1772562604; h=in-reply-to:content-disposition:mime-version:references:message-id :subject:cc:to:from:date:x-gm-gg:x-gm-message-state:from:to:cc :subject:date:message-id:reply-to; bh=vy6D+hE2xhOiRI343jCC4Oy3zlTR5Sfyp5vbNl4FLck=; b=QwpZj5tXQR2gjdOQLCxXXS2xv+rNzMpltclpZFDvKBNIdVUoiv9bVNgzYDdTR5w8jd 8WL1s8XqnokszUyKZz/56RFPHdAIgUHkysFgswMn+9y0xoKAfbe0bMLtqpiCaau1f2z/ 8/9T8wGiv55ZIPlMapozHonBKlKVZtUjgQ/ePCRkiJqUGO9n6OPb+CKOt2T38HN/oyjI 5KZ1AHvyzVQkPjqvrKgUzEzHK1zSK7UPl+ANDFMcM1zQk1dUykenLwDegz+iafpsh9hy XnvPt3D9gvTEZvC1EJE4dcDZkehMGjXuHkBelxuXMWnf81ON0KgXbKaF99BKMmFxbOtI F/Lg== X-Forwarded-Encrypted: i=1; AJvYcCUdQmc85lNVVmW9jKwJOiAwGBkwmGOdtsSpiU+B973+rv356qwH8qjdXrWK3xa0sBtGCuIzU2hnjA8pNU0=@vger.kernel.org X-Gm-Message-State: AOJu0YzgyfIlHFk2lUH0LzI463BJN6h4IOZD5oidFLMeXuIRd5hg495d jwOsuaqQ8nIQdY4piDD23kKF7Frfkzff4dH3n7eX80pFqA1eqFxQbRWG X-Gm-Gg: AZuq6aKsf9WkjBE7741O9o3Joj1zg3j3ThvHVBWJOThbQE+cT/WSWuwrkV0mliY3gfn uBdhEl8mEeKwondq+qnHAnT1qUWuViZnlqy5hDE4u+4kHuCIVyi//IeftC2vRUJv5j0KFNbEZlf 0H5YYG/x3I1QQDGyWcvtldZRt2c3VjFohjDIa8xCV2rsX6PS5/Wr7knO8KDzPTbs5SZsYYyJHa1 WJCSoZOq8sARnYpe4iO4RBN/lCQ72cD2Zu0Bre/iiOANWWxMzRcWU5WDsjQF9GouSJwNnE83nTc mOzaWoJGd5HmBdDXeuUm61O72/HQrMSFEeFYq+ItLNBF05/YS+xb8welRIVu61h9A34ah7G3buC EorEHe5+8mPzXJNND2dCNr/VaZUyX91OeHcVa2+0ijaarQldbXCGorMwgyuYdNRLkX1YGMtgo9T Br+yfi6Au4Ci6nbl4= X-Received: by 2002:a05:600c:470f:b0:483:7d93:9fb7 with SMTP id 5b1f17b1804b1-483a95ec6bamr135887715e9.2.1771957803799; Tue, 24 Feb 2026 10:30:03 -0800 (PST) Received: from skbuf ([2a02:2f04:d809:4b00:7cd9:3431:5b61:7303]) by smtp.gmail.com with ESMTPSA id 5b1f17b1804b1-483b89095a7sm22695185e9.24.2026.02.24.10.30.02 (version=TLS1_3 cipher=TLS_AES_256_GCM_SHA384 bits=256/256); Tue, 24 Feb 2026 10:30:03 -0800 (PST) Date: Tue, 24 Feb 2026 20:30:00 +0200 From: Vladimir Oltean To: Andy Shevchenko Cc: linux-can@vger.kernel.org, linux-phy@lists.infradead.org, linux-kernel@vger.kernel.org, Marc Kleine-Budde , Vincent Mailhol , Vinod Koul , Neil Armstrong , Josua Mayer Subject: Re: [PATCH v1 1/4] phy: phy-can-transceiver: Convert to use device property API Message-ID: <20260224183000.txlazzyw7z34nhsj@skbuf> References: <20260219202910.2304440-1-andriy.shevchenko@linux.intel.com> <20260219202910.2304440-1-andriy.shevchenko@linux.intel.com> <20260219202910.2304440-2-andriy.shevchenko@linux.intel.com> <20260219202910.2304440-2-andriy.shevchenko@linux.intel.com> <20260224162606.spnzzedvmvp2h7xd@skbuf> Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: On Tue, Feb 24, 2026 at 06:54:48PM +0200, Andy Shevchenko wrote: > On Tue, Feb 24, 2026 at 06:26:06PM +0200, Vladimir Oltean wrote: > > On Thu, Feb 19, 2026 at 09:26:19PM +0100, Andy Shevchenko wrote: > > ... > > > > - if (!of_property_present(dev->of_node, "mux-states")) > > > + if (!device_property_present(dev, "mux-states")) > > > > There's an entire saga with this function - devm_mux_state_get_optional(). > > Josua Mayer is preparing to move it to the MUX core, which will be a cross-tree series. > > Would you mind not touching this, to avoid complicating what is already > > a complicated operation? It is going away anyway, and from what I can > > see in Josua's last series, its implementation from drivers/mux/core.c > > is already using device property APIs: > > https://lore.kernel.org/linux-phy/20260208-rz-sdio-mux-v9-2-9a3be13c1280@solid-run.com/ > > Basically you ask me to postpone the series until that will be in. Since this > file is a mess in terms of OF/fwnode API use in exchange I would like whoever > is doing the other part to speed up a bit if possible. > > I prefer to see cleaner solution to be applied sooner and last in a long distance, > that's why I see either mine first but soon, or that first but also soon should > be in. Can we try to achieve that? The idea is that Ulf already expressed the availability to take the phy-can-transceiver patch through the mmc tree and provide back a tag to be pulled into linux-phy: https://lore.kernel.org/linux-phy/CAPDyKFrtTaJ5fqqbGrE_K6SAdTZYUfp-BycGjtWs4SabwBysKA@mail.gmail.com/ If linux-phy takes your patch first, there will be a conflict when pulling the stable branch, and it won't be so fun, plus we can't even build-test Josua's submission on linux-phy, so that's obviously not great. So yeah, I'm not requesting you to postpone the entire series, just not touch devm_mux_state_get_optional() and don't let it appear in your patch context. Somebody will have to remove "#include " at the end of the whole process, but that's minor. > ... > > > > - phy = devm_phy_create(dev, dev->of_node, &can_transceiver_phy_ops); > > > + phy = devm_phy_create(dev, NULL, &can_transceiver_phy_ops); > > > > It is not obvious why you replaced dev->of_node with NULL here. > > It doesn't appear correct. You seem to be breaking OF-based PHY lookups. > > It's the default. Yeah, I probably have to explain this in the commit message. Ah, ok. Found the "phy->dev.of_node = node ?: dev->of_node;" assignment. Sorry and noted, but please add it to the commit message too. > Basically all devm_phy_create(dev, dev->of_node, ...) for clarity should be > converted to that approach. Or even better, a new (agnostic) API should take > default fwnode from the same device. > > phy = devm_phy_create_simple(dev, &..._phy_ops); > > // name was quickly chosen and may be not the best we can come up with I agree in principle. PHY drivers shouldn't be given a function where they routinely have to set one of the arguments to NULL, but a simpler function without that argument. But the phy-core.c doesn't support fwnode at all yet, it uses OF throughout. I think it would be preferable to leave this change to somebody who has business in that area. (are you interested in PHYs with a fwnode for any particular reason, or just because the API is more "generic" just in case?)