mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jonathan Cameron <jic23@kernel.org>
To: Maxwell Doose <m32285159@gmail.com>
Cc: "David Lechner" <dlechner@baylibre.com>,
	"Nuno Sá" <nuno.sa@analog.com>,
	"Andy Shevchenko" <andy@kernel.org>,
	linux-iio@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] iio: humidity: ens210: remove compiler warning workaround
Date: Fri, 22 May 2026 13:37:17 +0100	[thread overview]
Message-ID: <20260522133717.32772423@jic23-huawei> (raw)
In-Reply-To: <CAKqfh0Gwon4X2aCoDSNNBg7wXnKfbh69kj1R2HopKv=jHwfL-g@mail.gmail.com>

On Fri, 22 May 2026 00:25:08 -0500
Maxwell Doose <m32285159@gmail.com> wrote:

> Hi David,
> 
> On Thu, May 21, 2026 at 8:26 PM David Lechner <dlechner@baylibre.com> wrote:
> >
> > Rewrite IIO_CHAN_INFO_RAW case to avoid needing to add unreachable code
> > to work around a compiler warning.
> >
> > When scoped_guard() was first introduced, compilers could not see when
> > it returned unconditionally from inside the hidden for loop. This has
> > since been fixed in the macro definition. So removing the `return
> > -EINVAL` should be enough. Still, we can improve readability, decrease
> > indentation and avoid the hidden for loop by rewriting the case without
> > scoped_guard().
> >
> > Signed-off-by: David Lechner <dlechner@baylibre.com>
> > ---
> >  drivers/iio/humidity/ens210.c | 19 ++++++++++---------
> >  1 file changed, 10 insertions(+), 9 deletions(-)
> >
> > diff --git a/drivers/iio/humidity/ens210.c b/drivers/iio/humidity/ens210.c
> > index 22ad208e6aa6..49543fc389bf 100644
> > --- a/drivers/iio/humidity/ens210.c
> > +++ b/drivers/iio/humidity/ens210.c
> > @@ -149,15 +149,16 @@ static int ens210_read_raw(struct iio_dev *indio_dev,
> >         int ret;
> >
> >         switch (mask) {
> > -       case IIO_CHAN_INFO_RAW:
> > -               scoped_guard(mutex, &data->lock) {
> > -                       ret = ens210_get_measurement(
> > -                               indio_dev, channel->type == IIO_TEMP, val);
> > -                       if (ret)
> > -                               return ret;
> > -                       return IIO_VAL_INT;
> > -               }
> > -               return -EINVAL; /* compiler warning workaround */
> > +       case IIO_CHAN_INFO_RAW: {
> > +               guard(mutex)(&data->lock);
> > +
> > +               ret = ens210_get_measurement(indio_dev, channel->type == IIO_TEMP,
> > +                                            val);
> > +               if (ret)
> > +                       return ret;
> > +
> > +               return IIO_VAL_INT;
> > +       }
> >         case IIO_CHAN_INFO_SCALE:
> >                 if (channel->type == IIO_TEMP) {
> >                         *val = 15;
> >  
> 
> I'm questioning how that initial commit got merged at all, they
> could've just used guard()() with {} (the kind of thing to make me
> want to take a look at this file even further!). Visually looks good
> to me but will follow-up later with rb if it all checks out.

The guard stuff was fairly new at the time so we were still working out what
patterns make sense. Took a little while for consensus to emerge!

Anyhow patch is obviously correct and a cleanup so applied to the testing
branch of iio.git.  Happy to add tags etc for next few days
(or drop it if I'm missing something!)

Jonathan

> 
> best regards,
> max
> 
> 
> > ---
> > base-commit: e1a29334a9c043defe7a9363fa76d399d3fdfbec
> > change-id: 20260521-iio-humidity-ens210-remove-hack-7c5a6496547c
> >
> > Best regards,
> > --
> > David Lechner <dlechner@baylibre.com>
> >
> >  
> 


  reply	other threads:[~2026-05-22 12:37 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-05-22  1:25 David Lechner
2026-05-22  5:25 ` Maxwell Doose
2026-05-22 12:37   ` Jonathan Cameron [this message]
2026-05-22 12:43     ` Maxwell Doose
2026-06-02 18:06     ` Andy Shevchenko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260522133717.32772423@jic23-huawei \
    --to=jic23@kernel.org \
    --cc=andy@kernel.org \
    --cc=dlechner@baylibre.com \
    --cc=linux-iio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=m32285159@gmail.com \
    --cc=nuno.sa@analog.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®