From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from mail-pl1-f180.google.com (mail-pl1-f180.google.com [209.85.214.180]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 37DAF38F65C for ; Fri, 12 Jun 2026 17:29:09 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=209.85.214.180 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1781285350; cv=none; b=K/5ApRm9nsqmBy8E0Cu9RvPNskDjPqOlvNIxJ6dOQ6W54qDTB9HjLce2DRXFxYhhfo7M/NQ+j1x42Ft2b/jEXYBc+hHr367p5L31GUdDDR2NmDUnOrl7yCPdRyyE84M2iYRQtXctL4UbAUnHZaaSy1sYvRiZSRytJYn2xTlI72o= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1781285350; c=relaxed/simple; bh=gH3FIVCDrAGV0izBe38P2bPsc0eUstU+ANKMIFL2JCY=; h=Date:From:To:Cc:Subject:Message-ID:References:MIME-Version: Content-Type:Content-Disposition:In-Reply-To; b=O/yywJLDE31rAqpsyFXWQ3gsAOEkIGoUJbZTgReBzNLG5l+bnCIqkgtf77qPgXq0DbZxMw/Db0XcMIgDg9mib5LpKcJzb6ued0zaZJrKOZxQG4HdIEmDMqbWGlDyjFLxAplmWzEr1vszg10e3L2atwLgUZLHTET5f4g1HkZftYw= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=reject dis=none) header.from=google.com; spf=pass smtp.mailfrom=google.com; dkim=pass (2048-bit key) header.d=google.com header.i=@google.com header.b=MPQTIjok; arc=none smtp.client-ip=209.85.214.180 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=reject dis=none) header.from=google.com Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=google.com Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=google.com header.i=@google.com header.b="MPQTIjok" Received: by mail-pl1-f180.google.com with SMTP id d9443c01a7336-2bf2d865383so3125ad.1 for ; Fri, 12 Jun 2026 10:29:09 -0700 (PDT) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=google.com; s=20251104; t=1781285348; x=1781890148; darn=vger.kernel.org; h=in-reply-to:content-disposition:mime-version:references:message-id :subject:cc:to:from:date:from:to:cc:subject:date:message-id:reply-to; bh=loLLkK8YFj2RX3MISH+YVtNr5164MIZqNzHdzscYBKE=; b=MPQTIjokndlnC51FLbrWXZC1nO3KRMcJFaWy3wieWU2SIkLKtVIefhiprGAwLWtmLu BGLEYJmhkbEp6IMfq2oVHzvrZdBGQQUMZr5q9UPqQDVtxTLgT4wEqfss38k78IIUww0s NIt+l+sU65BKEB4SoMyb9sdsNNBgccS1/KFG5HrivodnOkjH2Rkw5nLZfC5BZwGeJIbi enfjYKpWeB+Fw3HCc2jvi3mqDP+qoG7m36vGy3pla8nHtqk7M5E0WthrRwqW3hKjY5J5 COW5lJ2zNpnTkAVfnXsUOqGY9AeEN+0BGQ/9yUr09WYMxPO5WJNUmnQK5BDI+kxtLWfx A10Q== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20251104; t=1781285348; x=1781890148; h=in-reply-to:content-disposition:mime-version:references:message-id :subject:cc:to:from:date:x-gm-gg:x-gm-message-state:from:to:cc :subject:date:message-id:reply-to; bh=loLLkK8YFj2RX3MISH+YVtNr5164MIZqNzHdzscYBKE=; b=g/UxtHn0MHcR6N1uoJaGmoiXWzWHS1kVIFLWyZ9OyQFihMs8M1GjZapv9zQCewDC5v 8JKDHcy6Qaee6e/mtKczoa2c65VZXbrWEHWqVLGEeyEQr+Hvvhz5SLmsN5x6W21500hm d9QWKOBW8VVvo9jkmhO/9LgiPvlLfloiaMWsvcWQWsD4JEcmcOfATL99dQUerVezOvkx GWtVzMrv775VsHMF8pgcL/icrGkdR39UDFN7ZMYHmobVcqYhimBaW/RbyhW1gP7CV3AH QLo/pABPCMk+72PJsXYr1pk4iamgcdYMcKXRGJKU5S0tzwGJ0ETFRrmToNCztEPg9f9R YlhQ== X-Forwarded-Encrypted: i=1; AFNElJ9ProSMxwuwUunLnUv9kvNv9pvxRNKjwG7Hb4l1axUwo+K6XtnMsQdKT8yMTdl3CZvp67q3hN4ub8/w45Y=@vger.kernel.org X-Gm-Message-State: AOJu0Yyj19Oa1QdG/JfvZfR45dJQLqQuvxucm2V5d3pBtLU+JMMb1Qnx MvbglTS9mpgpLEOOGzJbxdmEeiODvFSv4A/S4/yytYVnpzlsu4EUbhLtRx07QlNQ/A== X-Gm-Gg: Acq92OG21L+02Yv8zLOXawkDbdcwg4SdVd9Q7hp24M7QcgPIE5Zl/s+iOf9IVpiIWMN asgoHSI4sFGNiYmsR5s2f3mbbw6HbYj11JWIslKP3BcviArRkePgIbsC8hErhdppjDPOsfUZniB fMaesnOGa1V53T/eyH0Ba+N8Ld6l1SChbkBOukWOvysRRTqzVHVL9kCi4HpSR4EBWm+BqHKDgHb DwiCTcmsUb2JCqzTpjxjhluvE1zaKbCn2H40Lx5Oa2yfJJ7QiSxlLhUEwL5qmnaSiiBevI9JRUS ec0QU/zIK/OTfxAwCD3TStnuWGaYmTgwGkjCHBOzFNcZx9OVKjQ8wsUqX37/9NGMt9zJ3QfvZrv 9GEzok6ReHjcbkbZ2PBqvW2YTzXsplKMNSqx+cDA3XlcIsjN77WyRsejzFUKv3oc1GbpuNoYE1d dMv/vODVc3BRrfsrPDPIFW0bQ4mqsaUVQPS7rLPfHuEhGk8LgMGuOhaU5baA== X-Received: by 2002:a17:903:4b4f:b0:2c1:ee6e:be1c with SMTP id d9443c01a7336-2c665136d6fmr88905ad.26.1781285348004; Fri, 12 Jun 2026 10:29:08 -0700 (PDT) Received: from google.com (60.89.247.35.bc.googleusercontent.com. [35.247.89.60]) by smtp.gmail.com with ESMTPSA id d2e1a72fcca58-8434afc8a90sm2766871b3a.28.2026.06.12.10.29.07 (version=TLS1_3 cipher=TLS_AES_256_GCM_SHA384 bits=256/256); Fri, 12 Jun 2026 10:29:07 -0700 (PDT) Date: Fri, 12 Jun 2026 10:29:02 -0700 From: Vipin Sharma To: Pasha Tatashin Cc: rppt@kernel.org, pratyush@kernel.org, tarunsahu@google.com, skhawaja@google.com, shuah@kernel.org, dmatlack@google.com, linux-kernel@vger.kernel.org, kexec@lists.infradead.org, linux-kselftest@vger.kernel.org Subject: Re: [PATCH v2 1/2] selftests/liveupdate: Move luo_test_utils.* into a reusable library Message-ID: <20260612172349.GA40404.vipinsh@google.com> References: <20260610230909.876546-1-vipinsh@google.com> <20260610230909.876546-2-vipinsh@google.com> <178123377286.908199.18067987861441109485.b4-review@b4> Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <178123377286.908199.18067987861441109485.b4-review@b4> On Fri, Jun 12, 2026 at 03:09:32AM +0000, Pasha Tatashin wrote: > On Wed, 10 Jun 2026 16:09:07 -0700, Vipin Sharma wrote: > > diff --git a/tools/testing/selftests/liveupdate/lib/libliveupdate.mk b/tools/testing/selftests/liveupdate/lib/libliveupdate.mk > > new file mode 100644 > > index 000000000000..0fb738c02330 > > --- /dev/null > > +++ b/tools/testing/selftests/liveupdate/lib/libliveupdate.mk > > @@ -0,0 +1,20 @@ > > [ ... skip 14 lines ... ] > > + $(Q)mkdir -p $@ > > + > > +$(LIBLIVEUPDATE_O): $(LIBLIVEUPDATE_OUTPUT)/%.o : $(LIBLIVEUPDATE_SRCDIR)/%.c | $(LIBLIVEUPDATE_OUTPUT) > > + $(CC) $(CFLAGS) $(CPPFLAGS) $(TARGET_ARCH) -c $< -o $@ > > + > > +EXTRA_CLEAN += $(LIBLIVEUPDATE_OUTPUT) > > since this file contains utility functions (luo_open_device, luo_test, > etc.), naming it liveupdate.c makes it sound like the main > implementation rather than a test helper library. Using something > distinct like lu_utils.c would make more sense. Okay, I will rename the new file to lu_utils.[ch] > > > > > diff --git a/tools/testing/selftests/liveupdate/luo_test_utils.c b/tools/testing/selftests/liveupdate/lib/liveupdate.c > > similarity index 99% > > rename from tools/testing/selftests/liveupdate/luo_test_utils.c > > rename to tools/testing/selftests/liveupdate/lib/liveupdate.c > > index 333a3530051b..897c200f3845 100644 > > --- a/tools/testing/selftests/liveupdate/luo_test_utils.c > > +++ b/tools/testing/selftests/liveupdate/lib/liveupdate.c > > @@ -22,7 +22,7 @@ > > #include > > #include > > > > -#include "luo_test_utils.h" > > +#include > > Linux kernel coding style generally prefers block headers to be sorted > alphabetically. > Okay, I will reoder them here and in the other files. Thanks!