From: Andrew Morton <akpm@linux-foundation.org>
To: Ye Liu <ye.liu@linux.dev>
Cc: Zi Yan <ziy@nvidia.com>, Vlastimil Babka <vbabka@kernel.org>,
Suren Baghdasaryan <surenb@google.com>,
Michal Hocko <mhocko@suse.com>,
Brendan Jackman <jackmanb@google.com>,
Johannes Weiner <hannes@cmpxchg.org>,
linux-mm@kvack.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 0/7] mm/page_owner: misc cleanups
Date: Mon, 29 Jun 2026 19:33:56 -0700 [thread overview]
Message-ID: <20260629193356.e3a7527636192308f1557ae2@linux-foundation.org> (raw)
In-Reply-To: <20260630015331.147174-1-ye.liu@linux.dev>
On Tue, 30 Jun 2026 09:53:17 +0800 Ye Liu <ye.liu@linux.dev> wrote:
> This series collects a few cleanups for mm/page_owner.c that have been
> accumulated while reading through the file. There is no functional
> change -- the goal is to make the code easier to read and maintain.
Updated, thanks.
AI review had some questions and suggestions:
https://sashiko.dev/#/patchset/20260630015331.147174-1-ye.liu@linux.dev
prev parent reply other threads:[~2026-06-30 2:33 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-06-30 1:53 Ye Liu
2026-06-30 1:53 ` [PATCH v3 1/7] mm/page_owner: extract skip_buddy_pages() helper to unify buddy page skipping Ye Liu
2026-06-30 1:53 ` [PATCH v3 2/7] mm/page_owner: add MR_NEVER to enum migrate_reason and use it for last_migrate_reason Ye Liu
2026-06-30 1:58 ` Zi Yan
2026-06-30 7:28 ` Vlastimil Babka (SUSE)
2026-06-30 1:53 ` [PATCH v3 3/7] mm: use enum migrate_reason instead of int for migration reason parameters Ye Liu
2026-06-30 2:01 ` Zi Yan
2026-06-30 7:30 ` Vlastimil Babka (SUSE)
2026-06-30 1:53 ` [PATCH v3 4/7] mm/page_owner: hoist CONFIG_MEMCG to function level for print_page_owner_memcg() Ye Liu
2026-06-30 1:53 ` [PATCH v3 5/7] mm/page_owner: add missing newline to count_threshold format string Ye Liu
2026-06-30 1:53 ` [PATCH v3 6/7] mm/page_owner: move free_ts_nsec output to free section in __dump_page_owner() Ye Liu
2026-06-30 1:53 ` [PATCH v3 7/7] mm/page_owner: drop redundant page_owner prefix from static symbols Ye Liu
2026-06-30 2:33 ` Andrew Morton [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260629193356.e3a7527636192308f1557ae2@linux-foundation.org \
--to=akpm@linux-foundation.org \
--cc=hannes@cmpxchg.org \
--cc=jackmanb@google.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=mhocko@suse.com \
--cc=surenb@google.com \
--cc=vbabka@kernel.org \
--cc=ye.liu@linux.dev \
--cc=ziy@nvidia.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®