From: "Thomas Weißschuh (Schneider Electric)" <thomas.weissschuh@linutronix.de>
To: Anna-Maria Behnsen <anna-maria@linutronix.de>,
Frederic Weisbecker <frederic@kernel.org>,
Thomas Gleixner <tglx@kernel.org>
Cc: linux-kernel@vger.kernel.org,
"Thomas Weißschuh (Schneider Electric)"
<thomas.weissschuh@linutronix.de>
Subject: [PATCH 1/8] hrtimer: Rename hrtimer_defs.h to hrtimer_bases.h
Date: Thu, 02 Jul 2026 11:41:58 +0200 [thread overview]
Message-ID: <20260702-hrtimer-header-dependencies-v1-1-c50b19bda473@linutronix.de> (raw)
In-Reply-To: <20260702-hrtimer-header-dependencies-v1-0-c50b19bda473@linutronix.de>
This header was originally added for #defines and was later extended
with the hrtimer base structures. All the #defines have been removed
in the meantime, so the naming is off now.
Rename the header to fit its contents more.
This will also make the upcoming addition of some functions nicer.
Signed-off-by: Thomas Weißschuh (Schneider Electric) <thomas.weissschuh@linutronix.de>
---
include/linux/hrtimer.h | 2 +-
include/linux/{hrtimer_defs.h => hrtimer_bases.h} | 4 ++--
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/include/linux/hrtimer.h b/include/linux/hrtimer.h
index 6862dea0acc5..8aa58520a816 100644
--- a/include/linux/hrtimer.h
+++ b/include/linux/hrtimer.h
@@ -12,7 +12,7 @@
#ifndef _LINUX_HRTIMER_H
#define _LINUX_HRTIMER_H
-#include <linux/hrtimer_defs.h>
+#include <linux/hrtimer_bases.h>
#include <linux/hrtimer_rearm.h>
#include <linux/hrtimer_types.h>
#include <linux/init.h>
diff --git a/include/linux/hrtimer_defs.h b/include/linux/hrtimer_bases.h
similarity index 98%
rename from include/linux/hrtimer_defs.h
rename to include/linux/hrtimer_bases.h
index 52ed9e46ff13..8c10f45dc469 100644
--- a/include/linux/hrtimer_defs.h
+++ b/include/linux/hrtimer_bases.h
@@ -1,6 +1,6 @@
/* SPDX-License-Identifier: GPL-2.0 */
-#ifndef _LINUX_HRTIMER_DEFS_H
-#define _LINUX_HRTIMER_DEFS_H
+#ifndef _LINUX_HRTIMER_BASES_H
+#define _LINUX_HRTIMER_BASES_H
#include <linux/ktime.h>
#include <linux/timerqueue.h>
--
2.55.0
next prev parent reply other threads:[~2026-07-02 9:42 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-02 9:41 [PATCH 0/8] hrtimer: Untangle base definitions from hrtimer.h Thomas Weißschuh (Schneider Electric)
2026-07-02 9:41 ` Thomas Weißschuh (Schneider Electric) [this message]
2026-07-07 21:49 ` [tip: timers/core] hrtimer: Rename hrtimer_defs.h to hrtimer_bases.h tip-bot2 for Thomas Weißschuh (Schneider Electric)
2026-07-02 9:41 ` [PATCH 2/8] hrtimer: Move hrtimer_callback_running() " Thomas Weißschuh (Schneider Electric)
2026-07-07 21:49 ` [tip: timers/core] " tip-bot2 for Thomas Weißschuh (Schneider Electric)
2026-07-02 9:42 ` [PATCH 3/8] hrtimer: Move hrtimer_update_function() to hrtimer.c Thomas Weißschuh (Schneider Electric)
2026-07-07 21:49 ` [tip: timers/core] " tip-bot2 for Thomas Weißschuh (Schneider Electric)
2026-07-02 9:42 ` [PATCH 4/8] tick: Explicitly include linux/hrtimer_bases.h Thomas Weißschuh (Schneider Electric)
2026-07-07 21:49 ` [tip: timers/core] " tip-bot2 for Thomas Weißschuh (Schneider Electric)
2026-07-02 9:42 ` [PATCH 5/8] hrtimer: " Thomas Weißschuh (Schneider Electric)
2026-07-07 21:49 ` [tip: timers/core] " tip-bot2 for Thomas Weißschuh (Schneider Electric)
2026-07-02 9:42 ` [PATCH 6/8] hrtimer: Explicitly include some necessary headers in hrtimer_rearm.h Thomas Weißschuh (Schneider Electric)
2026-07-07 21:49 ` [tip: timers/core] " tip-bot2 for Thomas Weißschuh (Schneider Electric)
2026-07-02 9:42 ` [PATCH 7/8] x86/speculation: Explicitly include linux/types.h Thomas Weißschuh (Schneider Electric)
2026-07-07 21:49 ` [tip: timers/core] " tip-bot2 for Thomas Weißschuh (Schneider Electric)
2026-07-02 9:42 ` [PATCH 8/8] hrtimer: Remove inclusion of hrtimer_bases.h remove from hrtimer.h Thomas Weißschuh (Schneider Electric)
2026-07-07 21:49 ` [tip: timers/core] " tip-bot2 for Thomas Weißschuh (Schneider Electric)
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260702-hrtimer-header-dependencies-v1-1-c50b19bda473@linutronix.de \
--to=thomas.weissschuh@linutronix.de \
--cc=anna-maria@linutronix.de \
--cc=frederic@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=tglx@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®