From: Bjorn Helgaas <helgaas@kernel.org>
To: manivannan.sadhasivam@oss.qualcomm.com
Cc: "Bjorn Helgaas" <bhelgaas@google.com>,
"Lorenzo Pieralisi" <lpieralisi@kernel.org>,
"Krzysztof Wilczyński" <kwilczynski@kernel.org>,
"Manivannan Sadhasivam" <mani@kernel.org>,
"Rob Herring" <robh@kernel.org>,
"Krzysztof Kozlowski" <krzk+dt@kernel.org>,
"Conor Dooley" <conor+dt@kernel.org>,
"Krishna Chaitanya Chundru" <krishna.chundru@oss.qualcomm.com>,
"Bartosz Golaszewski" <brgl@kernel.org>,
"Bjorn Andersson" <andersson@kernel.org>,
linux-pci@vger.kernel.org, devicetree@vger.kernel.org,
linux-kernel@vger.kernel.org, "Alex Elder" <elder@riscstar.com>
Subject: Re: [PATCH 0/6] PCI/pwrctrl: tc9563: Several fixes and improvements
Date: Mon, 27 Jul 2026 11:29:51 -0500 [thread overview]
Message-ID: <20260727162951.GA1230192@bhelgaas> (raw)
In-Reply-To: <20260725-tc9563-fix-v1-0-ec4286e31331@oss.qualcomm.com>
On Sat, Jul 25, 2026 at 10:59:12AM +0200, Manivannan Sadhasivam via B4 Relay wrote:
> Hi,
>
> This series contains several fixes and improvements for the TC9563 Pwrctrl
> driver and the switch binding. Most of the fixes are related to ensuring
> correctness in parsing the DT properties for the switch ports and the
> integrated Endpoint.
>
> More details are in the individual patches.
>
> Testing
> =======
>
> This series was validated on the RB3Gen2 board.
>
> Signed-off-by: Manivannan Sadhasivam <manivannan.sadhasivam@oss.qualcomm.com>
> ---
> Manivannan Sadhasivam (6):
> dt-bindings: PCI: toshiba,tc9563: Restrict Tx Amplitude, DFE and N_FTS to USP, DSP1 and DSP2
> PCI/pwrctrl: tc9563: Fix parsing the integrated Ethernet MAC Endpoint node
> PCI/pwrctrl: tc9563: Power off only the external ports in tc9563_pwrctrl_disable_port()
> PCI/pwrctrl: tc9563: Skip Tx amplitude and DFE tuning for DSP3
> PCI/pwrctrl: tc9563: Rename DSP3 to VDSP
> PCI/pwrctrl: tc9563: Move Integrated MAC Endpoint out of 'tc9563_pwrctrl_ports' enum
>
> .../devicetree/bindings/pci/toshiba,tc9563.yaml | 21 +++-
> drivers/pci/pwrctrl/pci-pwrctrl-tc9563.c | 129 ++++++++++++++-------
> 2 files changed, 104 insertions(+), 46 deletions(-)
Added to pci/pwrctrl for v7.3, thanks!
Happy to revise if you respond to any of Alex's comments.
prev parent reply other threads:[~2026-07-27 16:29 UTC|newest]
Thread overview: 28+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-25 8:59 Manivannan Sadhasivam via B4 Relay
2026-07-25 8:59 ` [PATCH 1/6] dt-bindings: PCI: toshiba,tc9563: Restrict Tx Amplitude, DFE and N_FTS to USP, DSP1 and DSP2 Manivannan Sadhasivam via B4 Relay
2026-07-27 15:59 ` Alex Elder
2026-07-28 13:09 ` Manivannan Sadhasivam
2026-07-25 8:59 ` [PATCH 2/6] PCI/pwrctrl: tc9563: Fix parsing the integrated Ethernet MAC Endpoint node Manivannan Sadhasivam via B4 Relay
2026-07-27 14:17 ` Bartosz Golaszewski
2026-07-27 15:59 ` Alex Elder
2026-07-28 13:12 ` Manivannan Sadhasivam
2026-07-28 13:38 ` Manivannan Sadhasivam
2026-07-28 13:41 ` Alex Elder
2026-07-28 15:35 ` Manivannan Sadhasivam
2026-07-25 8:59 ` [PATCH 3/6] PCI/pwrctrl: tc9563: Power off only the external ports in tc9563_pwrctrl_disable_port() Manivannan Sadhasivam via B4 Relay
2026-07-27 14:22 ` Bartosz Golaszewski
2026-07-27 15:59 ` Alex Elder
2026-07-25 8:59 ` [PATCH 4/6] PCI/pwrctrl: tc9563: Skip Tx amplitude and DFE tuning for DSP3 Manivannan Sadhasivam via B4 Relay
2026-07-27 14:23 ` Bartosz Golaszewski
2026-07-27 15:59 ` Alex Elder
2026-07-28 13:25 ` Manivannan Sadhasivam
2026-07-28 13:34 ` Alex Elder
2026-07-28 16:04 ` Bjorn Helgaas
2026-07-29 15:21 ` Manivannan Sadhasivam
2026-07-25 8:59 ` [PATCH 5/6] PCI/pwrctrl: tc9563: Rename DSP3 to VDSP Manivannan Sadhasivam via B4 Relay
2026-07-27 14:23 ` Bartosz Golaszewski
2026-07-27 15:59 ` Alex Elder
2026-07-25 8:59 ` [PATCH 6/6] PCI/pwrctrl: tc9563: Move Integrated MAC Endpoint out of 'tc9563_pwrctrl_ports' enum Manivannan Sadhasivam via B4 Relay
2026-07-27 14:23 ` Bartosz Golaszewski
2026-07-27 15:59 ` Alex Elder
2026-07-27 16:29 ` Bjorn Helgaas [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260727162951.GA1230192@bhelgaas \
--to=helgaas@kernel.org \
--cc=andersson@kernel.org \
--cc=bhelgaas@google.com \
--cc=brgl@kernel.org \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=elder@riscstar.com \
--cc=krishna.chundru@oss.qualcomm.com \
--cc=krzk+dt@kernel.org \
--cc=kwilczynski@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=lpieralisi@kernel.org \
--cc=mani@kernel.org \
--cc=manivannan.sadhasivam@oss.qualcomm.com \
--cc=robh@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®