mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Pawel Zalewski via B4 Relay <devnull+pzalewski.thegoodpenguin.co.uk@kernel.org>
To: Yushan Wang <wangyushan12@huawei.com>,
	Conor Dooley <conor@kernel.org>,
	 Jonathan Cameron <jic23@kernel.org>
Cc: linux-kernel@vger.kernel.org,
	 "Pawel Zalewski (The Capable Hub)"
	<pzalewski@thegoodpenguin.co.uk>
Subject: [PATCH] cache: hisi_soc_hha: use named initializers for acpi_device_id
Date: Tue, 04 Aug 2026 12:17:45 +0100	[thread overview]
Message-ID: <20260804-cache-v1-1-a1491610bb01@thegoodpenguin.co.uk> (raw)

From: "Pawel Zalewski (The Capable Hub)" <pzalewski@thegoodpenguin.co.uk>

Use a named initializer for the acpi_device_id fields which
makes the code more readable and consistent with how lists
are initialized in the rest of the kernel code base.

Signed-off-by: Pawel Zalewski (The Capable Hub) <pzalewski@thegoodpenguin.co.uk>
---
 drivers/cache/hisi_soc_hha.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/cache/hisi_soc_hha.c b/drivers/cache/hisi_soc_hha.c
index 756c43398515..f0f6c0354108 100644
--- a/drivers/cache/hisi_soc_hha.c
+++ b/drivers/cache/hisi_soc_hha.c
@@ -170,7 +170,7 @@ static void hisi_soc_hha_remove(struct platform_device *pdev)
 }
 
 static const struct acpi_device_id hisi_soc_hha_ids[] = {
-	{ "HISI0511", },
+	{ .id = "HISI0511" },
 	{ }
 };
 MODULE_DEVICE_TABLE(acpi, hisi_soc_hha_ids);

---
base-commit: 075b74841bd0065a3bda3440873c747938e69b68
change-id: 20260803-cache-55f8e58f7d94

Best regards,
--  
Pawel Zalewski (The Capable Hub) <pzalewski@thegoodpenguin.co.uk>



             reply	other threads:[~2026-08-04 11:17 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-04 11:17 Pawel Zalewski via B4 Relay [this message]
2026-08-04 22:34 ` Jonathan Cameron
2026-08-05  1:07 ` Yushan Wang
2026-08-10 14:56 ` Conor Dooley

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260804-cache-v1-1-a1491610bb01@thegoodpenguin.co.uk \
    --to=devnull+pzalewski.thegoodpenguin.co.uk@kernel.org \
    --cc=conor@kernel.org \
    --cc=jic23@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pzalewski@thegoodpenguin.co.uk \
    --cc=wangyushan12@huawei.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®