From: Sang-Heon Jeon <ekffu200098@gmail.com>
To: Andrew Morton <akpm@linux-foundation.org>,
Mike Rapoport <rppt@kernel.org>
Cc: linux-kernel@vger.kernel.org, linux-mm@kvack.org
Subject: [PATCH v3 0/2] mm/mm_init: simplify zone_spanned_pages_in_node()
Date: Fri, 14 Aug 2026 22:37:37 +0900 [thread overview]
Message-ID: <20260814133744.2746782-1-ekffu200098@gmail.com> (raw)
Hello,
This series simplifies zone_spanned_pages_in_node(), which adjusts
*zone_start_pfn and *zone_end_pfn before and after calling
adjust_zone_range_for_zone_movable(). The helper adjusts the same two
values, which makes the code harder to follow.
Patch 1 folds adjust_zone_range_for_zone_movable() into the caller,
extracts zone_movable_pfn[nid] into a local variable, and reduces the
indentation level.
Patch 2 removes the clamping to node_end_pfn and moves the check and
the clamping to node_start_pfn into the ZONE_MOVABLE branch, which is
the only place they have an effect. It also merges the two branches
that adjust for zone_movable_pfn[nid].
No functional change.
---
Changes from v2 [2]
- Squash patches 2 to 4 into one and fold patch 5 into patch 1, as Mike suggested
Changes from v1 [1]
- Change base to memblock/for-next
- Add patch 4 to merge the two branches
- Update comment
[1] https://lore.kernel.org/all/20260804144803.3290255-1-ekffu200098@gmail.com/
[2] https://lore.kernel.org/all/20260806162100.313965-1-ekffu200098@gmail.com/
---
Sang-Heon Jeon (2):
mm/mm_init: fold adjust_zone_range_for_zone_movable() into its only
caller
mm/mm_init: simplify ZONE_MOVABLE branch in
zone_spanned_pages_in_node()
mm/mm_init.c | 79 ++++++++++++++++++++++++----------------------------
1 file changed, 36 insertions(+), 43 deletions(-)
--
2.43.0
next reply other threads:[~2026-08-14 13:37 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-14 13:37 Sang-Heon Jeon [this message]
2026-08-14 13:37 ` [PATCH v3 1/2] mm/mm_init: fold adjust_zone_range_for_zone_movable() into its only caller Sang-Heon Jeon
2026-08-14 13:37 ` [PATCH v3 2/2] mm/mm_init: simplify ZONE_MOVABLE branch in zone_spanned_pages_in_node() Sang-Heon Jeon
2026-08-23 14:21 ` [PATCH v3 0/2] mm/mm_init: simplify zone_spanned_pages_in_node() Mike Rapoport
2026-08-23 15:27 ` Sang-Heon Jeon
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260814133744.2746782-1-ekffu200098@gmail.com \
--to=ekffu200098@gmail.com \
--cc=akpm@linux-foundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=rppt@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®