mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jason Gunthorpe <jgg@nvidia.com>
To: "Aneesh Kumar K.V" <aneesh.kumar@kernel.org>
Cc: linux-coco@lists.linux.dev, linux-arm-kernel@lists.infradead.org,
	linux-kernel@vger.kernel.org,
	Catalin Marinas <catalin.marinas@arm.com>,
	Greg KH <gregkh@linuxfoundation.org>,
	Jeremy Linton <jeremy.linton@arm.com>,
	Jonathan Cameron <jic23@kernel.org>,
	Lorenzo Pieralisi <lpieralisi@kernel.org>,
	Mark Rutland <mark.rutland@arm.com>,
	Sudeep Holla <sudeep.holla@arm.com>,
	Will Deacon <will@kernel.org>,
	Steven Price <steven.price@arm.com>,
	Suzuki K Poulose <Suzuki.Poulose@arm.com>,
	Andre Przywara <andre.przywara@arm.com>
Subject: Re: [PATCH v9 5/7] virt: coco: arm-cca-guest: Rename TSM report source file
Date: Sat, 29 Aug 2026 16:07:20 -0300	[thread overview]
Message-ID: <20260829190720.GB4157646@nvidia.com> (raw)
In-Reply-To: <yq5ao6eltqfk.fsf@kernel.org>

On Sat, Aug 29, 2026 at 11:32:23AM +0530, Aneesh Kumar K.V wrote:
> Jason Gunthorpe <jgg@nvidia.com> writes:
> 
> >> The Arm CCA guest driver currently only implements TSM report support, but
> >> follow-up changes will add more TSM-related functionality to the same
> >> module.
> >> 
> >> Rename arm-cca-guest.c to arm-cca.c and build it as an object of the
> >> arm-cca-guest module. This leaves room for the module to grow additional
> >> source files.
> >
> > That's pretty confusing, the module is called arm-cc-guest.ko but it
> > has host items too?
> >
> > I would have more expected the module to be named arm-cca and this
> > file to be guest and a future file to be host or something like that?
> >
> > It is annoying to change module names but we do it, and I think it
> > should be no problem in this case since there are no users..
> >
> > But maybe this patch should be in another series..
> >
> 
> We have two modules, arm-cca-guest.ko and arm-cca-host.ko, located in
> their respective directories:
> 
> drivers/virt/coco/arm-cca-guest/
> drivers/virt/coco/arm-cca-host/
> 
> They also have separate Kconfig symbols, ARM_CCA_GUEST and ARM_CCA_HOST.

So this is about renaming the .c file so you can have a multi .c file
module then? The usual kbuild problem. I'd call it guest-main or
similar. Linus has disliked suttering the directory name into the file
name in the past

Jason

  reply	other threads:[~2026-08-29 19:07 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-05  6:32 [PATCH v9 0/7] Switch Arm SMCCC firmware services to an SMCCC bus Aneesh Kumar K.V (Arm)
2026-08-05  6:32 ` [PATCH v9 1/7] firmware: smccc: Add an Arm " Aneesh Kumar K.V (Arm)
2026-08-28 19:34   ` Jason Gunthorpe
2026-08-05  6:32 ` [PATCH v9 2/7] firmware: hwrng: arm_smccc_trng: Register as an SMCCC device Aneesh Kumar K.V (Arm)
2026-08-05 11:08   ` Catalin Marinas
2026-08-28 19:34   ` Jason Gunthorpe
2026-08-29  5:54     ` Aneesh Kumar K.V
2026-08-29 19:11       ` Jason Gunthorpe
2026-08-05  6:32 ` [PATCH v9 3/7] firmware: arm_rmm: Move RSI support out of arch/arm64 Aneesh Kumar K.V (Arm)
2026-08-05 11:21   ` Catalin Marinas
2026-08-05 13:05     ` Aneesh Kumar K.V
2026-08-10 10:03   ` Suzuki K Poulose
2026-08-28 19:34   ` Jason Gunthorpe
2026-08-29  5:58     ` Aneesh Kumar K.V
2026-08-05  6:32 ` [PATCH v9 4/7] arm64: realm: Move Realm memory encryption ops to RSI code Aneesh Kumar K.V (Arm)
2026-08-10 10:12   ` Suzuki K Poulose
2026-08-10 12:15     ` Aneesh Kumar K.V
2026-08-05  6:32 ` [PATCH v9 5/7] virt: coco: arm-cca-guest: Rename TSM report source file Aneesh Kumar K.V (Arm)
2026-08-28 19:34   ` Jason Gunthorpe
2026-08-29  6:02     ` Aneesh Kumar K.V
2026-08-29 19:07       ` Jason Gunthorpe [this message]
2026-08-05  6:32 ` [PATCH v9 6/7] firmware: smccc: arm-cca-guest: Bind the TSM provider to an SMCCC device Aneesh Kumar K.V (Arm)
2026-08-28 19:34   ` Jason Gunthorpe
2026-08-29  6:12     ` Aneesh Kumar K.V
2026-08-29 19:13       ` Jason Gunthorpe
2026-08-05  6:32 ` [PATCH v9 7/7] coco: guest: arm64: Replace dummy CCA device with sysfs ABI Aneesh Kumar K.V (Arm)
2026-08-28 19:34   ` Jason Gunthorpe
2026-08-05  9:51 ` [PATCH v9 0/7] Switch Arm SMCCC firmware services to an SMCCC bus Catalin Marinas
2026-08-05 12:22   ` Aneesh Kumar K.V
2026-08-10  9:35     ` Aneesh Kumar K.V
2026-08-10 10:24       ` Will Deacon

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260829190720.GB4157646@nvidia.com \
    --to=jgg@nvidia.com \
    --cc=Suzuki.Poulose@arm.com \
    --cc=andre.przywara@arm.com \
    --cc=aneesh.kumar@kernel.org \
    --cc=catalin.marinas@arm.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=jeremy.linton@arm.com \
    --cc=jic23@kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-coco@lists.linux.dev \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lpieralisi@kernel.org \
    --cc=mark.rutland@arm.com \
    --cc=steven.price@arm.com \
    --cc=sudeep.holla@arm.com \
    --cc=will@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®