From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from bali.collaboradmins.com (bali.collaboradmins.com [148.251.105.195]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 5FEAF4CCDEE for ; Tue, 1 Sep 2026 12:31:05 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=148.251.105.195 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1788265866; cv=none; b=Zr4Etjsyl9ahdR/Fg8U9e0iLtbUdGdCI9SWVR21mA5kM+mQUuRXy6zJMcqivSCE+KGNT1mtutjQwPGAQWcJ5Sa1MVvyGwunBEISRwY97EIZ32dksOeSIom7SoBHRArUn2QuKjkXF0lQh1/4+o5zVCiZ49v3q9ac/xH+Hxo3cpTE= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1788265866; c=relaxed/simple; bh=0cjXppRhGX/DMTcgLpKy2KbGeSyz7F8K0A7pf9RNNXo=; h=Date:From:To:Cc:Subject:Message-ID:In-Reply-To:References: MIME-Version:Content-Type; b=pKpTBM3i5he1/ZiV1BKBN7F/Cdm+b/T3P+kAUaKsujQGAsr4KIi9XrpdSSvMxqc+q8KycMJxPMnXItUbhql/96tQ22+DR/ZwIr6MYGL6NfXgYuwaer8aYwdqJPHWIUfHsgXkDexV/Kh3mICZ+6m71yUyk3VF51lULQltNDruLOs= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=collabora.com; spf=pass smtp.mailfrom=collabora.com; dkim=pass (2048-bit key) header.d=collabora.com header.i=@collabora.com header.b=V0g1+T8V; arc=none smtp.client-ip=148.251.105.195 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=collabora.com Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=collabora.com Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=collabora.com header.i=@collabora.com header.b="V0g1+T8V" DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=collabora.com; s=mail; t=1788265863; bh=0cjXppRhGX/DMTcgLpKy2KbGeSyz7F8K0A7pf9RNNXo=; h=Date:From:To:Cc:Subject:In-Reply-To:References:From; b=V0g1+T8Vt3HbVt4yi9ANc9vKwMuo0BUmfh2mtEchb7jVibPVqYwQB9qB+4D2ty0Zi Iv1r4xHV4cgL/RdTqu39EULdXqu26oF/huV9mvBo91+K8EoaEY7dkElEjYY1CAnxW+ cspGHoewcQnA0RZ2gURuB6vMuy3q7dXg8pKUahEcw4scRnv0XnAO0+oexiVPFf48DM RWb4vqEWI3zf5jZKXfn6KRrI3IMcQy251GJL2vCcwezY78KXIyA75am9DlgwZbqrx0 q3DF/lfLAi+1VaAanSq5YaDC/My2phFby/lO18kG2l2sU1j1ELokZivmy6gd0SJxn/ aFhiF70ZfIcQw== Received: from fedora-21.home (unknown [100.64.0.11]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange secp256r1 server-signature RSA-PSS (4096 bits) server-digest SHA256) (No client certificate requested) (Authenticated sender: bbrezillon) by bali.collaboradmins.com (Postfix) with ESMTPSA id 95ABA17E006A; Tue, 01 Sep 2026 14:31:02 +0200 (CEST) Date: Tue, 1 Sep 2026 14:30:57 +0200 From: Boris Brezillon To: =?UTF-8?B?QWRyacOhbg==?= Larumbe Cc: Rob Herring , Steven Price , Maarten Lankhorst , Maxime Ripard , Thomas Zimmermann , David Airlie , Simona Vetter , Faith Ekstrand , "Marty E. Plummer" , Tomeu Vizoso , Eric Anholt , Alyssa Rosenzweig , Robin Murphy , Philipp Zabel , dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org, Collabora Kernel Team , Neil Armstrong Subject: Re: [PATCH v7 04/17] drm/panfrost: Move debugfs initialisation to relevant subsystems Message-ID: <20260901143057.47497b30@fedora-21.home> In-Reply-To: <20260828-claude-fixes-v7-4-72a13b2c125d@collabora.com> References: <20260828-claude-fixes-v7-0-72a13b2c125d@collabora.com> <20260828-claude-fixes-v7-4-72a13b2c125d@collabora.com> Organization: Collabora X-Mailer: Claws Mail 4.4.0 (GTK 3.24.52; x86_64-redhat-linux-gnu) Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: quoted-printable On Fri, 28 Aug 2026 21:56:44 +0100 Adri=C3=A1n Larumbe wrote: > @@ -757,4 +758,28 @@ void panfrost_gem_debugfs_print_bos(struct panfrost_= device *pfdev, > seq_printf(m, "Total size: %zd, Total resident: %zd, Total reclaimable:= %zd\n", > totals.size, totals.resident, totals.reclaimable); > } > + > +static int panfrost_gems_show(struct seq_file *m, void *data) > +{ > + struct drm_info_node *node =3D m->private; > + struct panfrost_device *pfdev =3D to_panfrost_device(node->minor->dev); > + > + panfrost_gem_debugfs_print_bos(pfdev, m); > + > + return 0; > +} > + > +static struct drm_info_list panfrost_debugfs_list[] =3D { > + {"gems", > + panfrost_gems_show, 0, NULL}, > +}; > + > +int panfrost_gems_debugfs_init(struct drm_minor *minor) nit: I would rename that one panfrost_gem_debugfs_init(). The rest looks good Reviewed-by: Boris Brezillon > +{ > + drm_debugfs_create_files(panfrost_debugfs_list, > + ARRAY_SIZE(panfrost_debugfs_list), > + minor->debugfs_root, minor); > + > + return 0; > +}