From: Vladimir Oltean <olteanv@gmail.com>
To: Inochi Amaoto <inochiama@gmail.com>
Cc: Vinod Koul <vkoul@kernel.org>,
Neil Armstrong <neil.armstrong@linaro.org>,
Manivannan Sadhasivam <mani@kernel.org>,
Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
linux-phy@lists.infradead.org, linux-kernel@vger.kernel.org,
Yixun Lan <dlan@gentoo.org>, Longbin Li <looong.bin@gmail.com>
Subject: Re: [PATCH v2 0/4] phy: core: Add phy bulk helpers support
Date: Mon, 7 Sep 2026 13:28:49 +0300 [thread overview]
Message-ID: <20260907102849.w7yn43x6m3f2rnuj@skbuf> (raw)
In-Reply-To: <20260904083709.425893-1-inochiama@gmail.com>
Hi Inochi,
On Fri, Sep 04, 2026 at 04:37:04PM +0800, Inochi Amaoto wrote:
> As discussed in [1], some drivers may do not care the difference between
> phys. Instead, they only need to treat them as a group and operate them
> together. This means a bulk operation is needed.
>
> Add some bulk helper functions for phy core by referencing the design of
> clock/reset subsystem. This can relieve the driver owners' life who needs
> to handle many phys, as well as each phy error reporting.
>
> [1] https://lore.kernel.org/linux-pci/ak9KzNFF26B0Kttz@ashevche-desk.local/
>
> Changed from v1:
> - https://lore.kernel.org/linux-phy/20260831025319.94886-1-inochiama@gmail.com/
> patch 1:
> 1. Update document.
> patch 2:
> 1. Fix document format.
> 2. Fix several document description.
> patch 3:
> 1. Split into two patches: one for non devm helpers, one for devm helpers.
> 2. All the bulk helper now use unsigned int for counts.
> 3. Fix multiple the while loop statement.
> 4. Rename of_phy_get_parent_count() to of_phy_get_count().
> 5. Fix some 80 line function problems.
> 6. Use PTR_ERR_OR_ZERO() to simplify the error handle.
> 7. Fix zero value in the document
> 8. Use two separate release function for devm helpers.
>
> Inochi Amaoto (4):
> phy: core: Add common helper to add phy phandle device link
> phy: core: Add common helper for get phy phandle by index
> phy: core: Add phy bulk data helper functions
> phy: core: Add managed phy bulk data helper functions
>
> drivers/phy/phy-core.c | 700 +++++++++++++++++++++++++++++++++++++---
> include/linux/phy/phy.h | 186 +++++++++++
> 2 files changed, 850 insertions(+), 36 deletions(-)
>
> --
> 2.55.0
Please include a user of this API in the next patch submission.
We should avoid, as much as possible, to introduce unused code.
Also, please address Sashiko's feedback (excluding the pre-existing
issues).
next prev parent reply other threads:[~2026-09-07 10:28 UTC|newest]
Thread overview: 24+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-04 8:37 Inochi Amaoto
2026-09-04 8:37 ` [PATCH v2 1/4] phy: core: Add common helper to add phy phandle device link Inochi Amaoto
2026-09-05 8:02 ` Andy Shevchenko
2026-09-07 11:01 ` Vladimir Oltean
2026-09-07 11:33 ` Inochi Amaoto
2026-09-04 8:37 ` [PATCH v2 2/4] phy: core: Add common helper for get phy phandle by index Inochi Amaoto
2026-09-05 8:14 ` Andy Shevchenko
2026-09-07 11:03 ` Vladimir Oltean
2026-09-07 11:30 ` Inochi Amaoto
2026-09-04 8:37 ` [PATCH v2 3/4] phy: core: Add phy bulk data helper functions Inochi Amaoto
2026-09-07 10:56 ` Vladimir Oltean
2026-09-07 11:37 ` Inochi Amaoto
2026-09-07 11:48 ` Vladimir Oltean
2026-09-07 12:15 ` Inochi Amaoto
2026-09-07 12:43 ` Vladimir Oltean
2026-09-07 22:20 ` Inochi Amaoto
2026-09-04 8:37 ` [PATCH v2 4/4] phy: core: Add managed " Inochi Amaoto
2026-09-07 10:28 ` Vladimir Oltean [this message]
2026-09-07 11:29 ` [PATCH v2 0/4] phy: core: Add phy bulk helpers support Inochi Amaoto
2026-09-07 11:57 ` Vladimir Oltean
2026-09-07 12:05 ` Inochi Amaoto
2026-09-07 12:16 ` Vladimir Oltean
2026-09-07 13:04 ` Vladimir Oltean
2026-09-07 22:28 ` Inochi Amaoto
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260907102849.w7yn43x6m3f2rnuj@skbuf \
--to=olteanv@gmail.com \
--cc=andriy.shevchenko@linux.intel.com \
--cc=dlan@gentoo.org \
--cc=inochiama@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-phy@lists.infradead.org \
--cc=looong.bin@gmail.com \
--cc=mani@kernel.org \
--cc=neil.armstrong@linaro.org \
--cc=vkoul@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®