mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: SJ Park <sj@kernel.org>
To: SJ Park <sj@kernel.org>
Cc: Andrew Morton <akpm@linux-foundation.org>,
	damon@lists.linux.dev, linux-kernel@vger.kernel.org,
	linux-mm@kvack.org
Subject: Re: [RFC PATCH v2 2/7] mm/damon/core: extend probe_hits_wsum() for moving sum based calculation
Date: Mon,  7 Sep 2026 12:21:18 -0700	[thread overview]
Message-ID: <20260907192119.111740-1-sj@kernel.org> (raw)
In-Reply-To: <20260907171218.101430-3-sj@kernel.org>

On Mon,  7 Sep 2026 10:12:11 -0700 SJ Park <sj@kernel.org> wrote:

> damon_probe_hits_wsum() is being called only in aggregation time.  In
> future, it could also be used by DAMOS.  In this case, since DAMOS uses
> its own apply_interval, it could be called in sampling time.  Then using
> the not yet fully aggregated probe_hits could result in suboptimum
> outcomes.  Extend damon_probe_hits_wsum() to get the weighted sum based
> on moving sum to prepare the DAMOS usage.
[...]
> --- a/mm/damon/vaddr.c
> +++ b/mm/damon/vaddr.c
> @@ -704,7 +704,7 @@ static unsigned int damon_va_apply_probes(struct damon_ctx *ctx,
>  			__damon_va_apply_probes(ctx, mm, r);
>  			if (return_max_wsum)
>  				max_wsum = max(damon_probe_hits_wsum(r, false,
> -							ctx), max_wsum);
> +							false, ctx), max_wsum);
>  		}
>  		if (mm)
>  			mmput(mm);

This cannot be applied on latest mm-new, because this relies on a
not-yet-merged patch series [1].  Hence Sashiko also failed [2] at reviewing
this series.  I will post another RFC after rebasing to latest mm-new.

[1] https://lore.kernel.org/20260906184417.96621-1-sj@kernel.org
[2] https://sashiko.dev/#/patchset/20260907171218.101430-1-sj%40kernel.org


Thanks,
SJ

[...]

  reply	other threads:[~2026-09-07 19:21 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-07 17:12 [RFC PATCH v2 0/7] mm/damon: introduce probe_hits_wsum DAMOS core filter SJ Park
2026-09-07 17:12 ` [RFC PATCH v2 1/7] mm/damon/api: introduce DAMOS_FILTER_TYPE_PROBE_HITS_WSUM SJ Park
2026-09-07 17:12 ` [RFC PATCH v2 2/7] mm/damon/core: extend probe_hits_wsum() for moving sum based calculation SJ Park
2026-09-07 19:21   ` SJ Park [this message]
2026-09-07 17:12 ` [RFC PATCH v2 3/7] mm/damon/core: support probe_hits_wsum damos core filter SJ Park
2026-09-07 17:12 ` [RFC PATCH v2 4/7] mm/damon/sysfs-schemes: rename sysfs_filter->sz_range to range_{min,max} SJ Park
2026-09-07 17:12 ` [RFC PATCH v2 5/7] mm/damon/sysfs-schemes: support probe_hits_wsum damos core filter SJ Park
2026-09-07 17:12 ` [RFC PATCH v2 6/7] Docs/mm/damon/design: update for probe_hits_wsum DAMOS " SJ Park
2026-09-07 17:12 ` [RFC PATCH v2 7/7] Docs/admin-guide/mm/damon/usage: update for probe_hits_wsum DAMOS filter SJ Park

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260907192119.111740-1-sj@kernel.org \
    --to=sj@kernel.org \
    --cc=akpm@linux-foundation.org \
    --cc=damon@lists.linux.dev \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®