mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jakub Kicinski <kuba@kernel.org>
To: Hangbin Liu <hangbin.liu@linux.dev>
Cc: "David S. Miller" <davem@davemloft.net>,
	Eric Dumazet <edumazet@google.com>,
	Paolo Abeni <pabeni@redhat.com>, Simon Horman <horms@kernel.org>,
	Shuah Khan <shuah@kernel.org>, David Ahern <dsahern@kernel.org>,
	Ido Schimmel <idosch@nvidia.com>,
	Andrea Mayer <andrea.mayer@uniroma2.it>,
	netdev@vger.kernel.org, linux-kselftest@vger.kernel.org,
	linux-kernel@vger.kernel.org, Hangbin Liu <liuhangbin@kylinos.cn>
Subject: Re: [PATCH net-next v2] selftests: net: move log_test to lib file and remove duplicate code
Date: Fri, 11 Sep 2026 16:08:12 -0700	[thread overview]
Message-ID: <20260911160812.3aaed4f9@kernel.org> (raw)
In-Reply-To: <aqN2K7rAm-S6QI86@fedora>

On Fri, 11 Sep 2026 11:31:55 +0800 Hangbin Liu wrote:
> Hi everyone,
> 
> This patch is a bit too long for review, and maybe cause conflicts for
> stable backports. I plan to split it into small frags. But there are 2
> ways to split it.
> 
> 1. Split based on the test name. e.g. srv6 part, fib part, test_* part, and
>    others.
> 2. Split based on the changes. e.g. group the tests that using exactly same
>    log_test functions into one patch.
> 
> Does anyone has any suggestion?

I don't think it makes sense to split this.

      reply	other threads:[~2026-09-11 23:08 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-31  9:21 Hangbin Liu
2026-08-31 15:03 ` Jakub Kicinski
2026-09-01  6:26   ` Hangbin Liu
2026-09-11  3:31 ` Hangbin Liu
2026-09-11 23:08   ` Jakub Kicinski [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260911160812.3aaed4f9@kernel.org \
    --to=kuba@kernel.org \
    --cc=andrea.mayer@uniroma2.it \
    --cc=davem@davemloft.net \
    --cc=dsahern@kernel.org \
    --cc=edumazet@google.com \
    --cc=hangbin.liu@linux.dev \
    --cc=horms@kernel.org \
    --cc=idosch@nvidia.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-kselftest@vger.kernel.org \
    --cc=liuhangbin@kylinos.cn \
    --cc=netdev@vger.kernel.org \
    --cc=pabeni@redhat.com \
    --cc=shuah@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®