mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: sashiko-bot@kernel.org
To: "Jinjie Ruan" <ruanjinjie@huawei.com>,
	lizhengyu3@huawei.com, dave.hansen@linux.intel.com,
	mark.rutland@arm.com, bgwin@google.com, npiggin@gmail.com,
	mingo@redhat.com, mclapinski@google.com, thuth@redhat.com,
	ruirui.yang@linux.dev, sourabhjain@linux.ibm.com,
	linuxppc-dev@lists.ozlabs.org, catalin.marinas@arm.com,
	dakr@kernel.org, linux-kernel@vger.kernel.org,
	vishal.l.verma@intel.com, pasha.tatashin@soleen.com,
	robh@kernel.org, sshegde@linux.ibm.com, chao.gao@intel.com,
	rppt@kernel.org, seanjc@google.com, chleroy@kernel.org,
	liukexin@kylinos.cn, linux-mm@kvack.org,
	takahiro.akashi@linaro.org, piliu@redhat.com,
	akpm@linux-foundation.org, pratyush@kernel.org,
	ruanjinjie@huawei.com, kees@kernel.org, hpa@zytor.com,
	rafael@kernel.org, ritesh.list@gmail.com, blum@kernel.org,
	linux-arm-kernel@lists.infradead.org, coxu@redhat.com,
	maddy@linux.ibm.com, eric.devolder@oracle.com,
	palmer@rivosinc.com, tglx@kernel.org, adityag@linux.ibm.com,
	kas@kernel.org, chenhuacai@kernel.org, yeoreum.yun@ arm.com,
	maqianga@uniontech.com, gshan@redhat.com, guodongtai@kylinos.cn,
	gregkh@linuxfoundation.org, x86@kernel.org,
	zhangtianyang@loongson.cn, jbouron@amazon.com, bp@alien8.de,
	tangyouling@kylinos.cn, loongarch@lists.linux.dev,
	james.morse@arm.com, ardb@kernel.org, mpe@ellerman.id.au,
	leitao@debian.org, will@kernel.org, baoquan.he@linux.dev,
	hbathini@linux.ibm.com, me@linux.beauty, graf@amazon.com,
	linux-fsdevel@vger.kernel.org, kernel@xen0n.name,
	driver-core@lists.linux.dev
Cc: kexec@lists.infradead.org
Subject: Re: [PATCH v5 14/17] elf: Introduce elf64_phdr_size() helper
Date: Fri, 18 Sep 2026 10:25:26 +0000	[thread overview]
Message-ID: <20260918102527.170481F000FF@smtp.kernel.org> (raw)
In-Reply-To: <20260918100442.3841135-15-ruanjinjie@huawei.com>

> Add a common helper to compute the total size of an ELF64 header
> (Ehdr + program headers) from the number of program headers.
> Replace open-coded calculations in powerpc, x86, vmcore,
> and crash_core.
> 
> On ppc64, struct elfhdr maps to elf64_hdr, so the powerpc change
> is a pure cleanup.
> 
> No functional change intended.
> 
> Cc: Madhavan Srinivasan <maddy@linux.ibm.com>
> Cc: Michael Ellerman <mpe@ellerman.id.au>
> Cc: Nicholas Piggin <npiggin@gmail.com>
> Cc: "Christophe Leroy (CS GROUP)" <chleroy@kernel.org>
> Cc: Thomas Gleixner <tglx@kernel.org>
> Cc: Ingo Molnar <mingo@redhat.com>
> Cc: Borislav Petkov <bp@alien8.de>
> Cc: Dave Hansen <dave.hansen@linux.intel.com>
> Cc: "H. Peter Anvin" <hpa@zytor.com>
> Cc: Andrew Morton <akpm@linux-foundation.org>
> Cc: Baoquan He <baoquan.he@linux.dev>
> Cc: Mike Rapoport <rppt@kernel.org>
> Cc: Pasha Tatashin <pasha.tatashin@soleen.com>
> Cc: Pratyush Yadav <pratyush@kernel.org>
> Cc: Dave Young <ruirui.yang@linux.dev>
> Cc: Kees Cook <kees@kernel.org>
> Cc: Sourabh Jain <sourabhjain@linux.ibm.com>
> Signed-off-by: Jinjie Ruan <ruanjinjie@huawei.com>

Sashiko has reviewed this patch and found no issues. It looks great!

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/20260918100442.3841135-1-ruanjinjie@huawei.com?part=14


  reply	other threads:[~2026-09-18 10:25 UTC|newest]

Thread overview: 36+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-18 10:04 [PATCH v5 00/17] crash: Rework and add arm64 crash hotplug support Jinjie Ruan
2026-09-18 10:04 ` [PATCH v5 01/17] kexec: Fix CMA segment address translation with non-zero text_offset Jinjie Ruan
2026-09-18 10:22   ` sashiko-bot
2026-09-18 10:04 ` [PATCH v5 02/17] kexec: Record allocated CMA pages to fix release size mismatch Jinjie Ruan
2026-09-18 10:16   ` sashiko-bot
2026-09-18 10:04 ` [PATCH v5 03/17] kexec: Extract kexec_free_segment_cma() from kimage_free_cma() Jinjie Ruan
2026-09-18 10:18   ` sashiko-bot
2026-09-18 10:04 ` [PATCH v5 04/17] arm64: kexec_file: Fix CMA page leaks in segment placement retry loops Jinjie Ruan
2026-09-18 10:15   ` sashiko-bot
2026-09-18 10:04 ` [PATCH v5 05/17] arm64: kexec_file: Fix elf_headers memory leak in retry loop Jinjie Ruan
2026-09-18 10:16   ` sashiko-bot
2026-09-18 10:04 ` [PATCH v5 06/17] LoongArch: kexec_file: Fix CMA page leaks in segment placement retry loops Jinjie Ruan
2026-09-18 10:16   ` sashiko-bot
2026-09-18 10:04 ` [PATCH v5 07/17] LoongArch: kexec_file: Fix elf_headers memory leak in retry loop Jinjie Ruan
2026-09-18 10:21   ` sashiko-bot
2026-09-18 10:04 ` [PATCH v5 08/17] LoongArch: kexec_file: Fix a modified_cmdline leak Jinjie Ruan
2026-09-18 10:18   ` sashiko-bot
2026-09-18 10:04 ` [PATCH v5 09/17] x86/crash: Fix massive out-of-bounds write on 32-bit Highmem Jinjie Ruan
2026-09-18 10:16   ` sashiko-bot
2026-09-18 10:04 ` [PATCH v5 10/17] crash: Extract crash_get_memory_ranges() helper Jinjie Ruan
2026-09-18 10:11   ` sashiko-bot
2026-09-18 10:04 ` [PATCH v5 11/17] crash: Normalize the kexec_load elfcorehdr at load time Jinjie Ruan
2026-09-18 10:27   ` sashiko-bot
2026-09-18 10:04 ` [PATCH v5 12/17] crash: Fix TOCTOU race in crash memory range collection Jinjie Ruan
2026-09-18 10:34   ` sashiko-bot
2026-09-18 10:04 ` [PATCH v5 13/17] crash: Assert device_hotplug_lock in crash_get_memory_ranges_nolock() Jinjie Ruan
2026-09-18 10:26   ` sashiko-bot
2026-09-18 10:04 ` [PATCH v5 14/17] elf: Introduce elf64_phdr_size() helper Jinjie Ruan
2026-09-18 10:25   ` sashiko-bot [this message]
2026-09-18 10:04 ` [PATCH v5 15/17] crash: Introduce crash_extra_elfcorehdr_size() helper Jinjie Ruan
2026-09-18 10:31   ` sashiko-bot
2026-09-18 10:04 ` [PATCH v5 16/17] arm64: kexec_file: Simplify load_other_segments() Jinjie Ruan
2026-09-18 10:27   ` sashiko-bot
2026-09-18 10:04 ` [PATCH v5 17/17] arm64: crash: Add crash hotplug support Jinjie Ruan
2026-09-18 10:36   ` sashiko-bot
2026-09-18 10:41 ` [PATCH v5 00/17] crash: Rework and add arm64 " Breno Leitao

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260918102527.170481F000FF@smtp.kernel.org \
    --to=sashiko-bot@kernel.org \
    --cc=adityag@linux.ibm.com \
    --cc=akpm@linux-foundation.org \
    --cc=ardb@kernel.org \
    --cc=baoquan.he@linux.dev \
    --cc=bgwin@google.com \
    --cc=blum@kernel.org \
    --cc=bp@alien8.de \
    --cc=catalin.marinas@arm.com \
    --cc=chao.gao@intel.com \
    --cc=chenhuacai@kernel.org \
    --cc=chleroy@kernel.org \
    --cc=coxu@redhat.com \
    --cc=dakr@kernel.org \
    --cc=dave.hansen@linux.intel.com \
    --cc=driver-core@lists.linux.dev \
    --cc=eric.devolder@oracle.com \
    --cc=graf@amazon.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=gshan@redhat.com \
    --cc=guodongtai@kylinos.cn \
    --cc=hbathini@linux.ibm.com \
    --cc=hpa@zytor.com \
    --cc=james.morse@arm.com \
    --cc=jbouron@amazon.com \
    --cc=kas@kernel.org \
    --cc=kees@kernel.org \
    --cc=kernel@xen0n.name \
    --cc=kexec@lists.infradead.org \
    --cc=leitao@debian.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=liukexin@kylinos.cn \
    --cc=lizhengyu3@huawei.com \
    --cc=loongarch@lists.linux.dev \
    --cc=maddy@linux.ibm.com \
    --cc=maqianga@uniontech.com \
    --cc=mark.rutland@arm.com \
    --cc=mclapinski@google.com \
    --cc=me@linux.beauty \
    --cc=mingo@redhat.com \
    --cc=mpe@ellerman.id.au \
    --cc=npiggin@gmail.com \
    --cc=palmer@rivosinc.com \
    --cc=pasha.tatashin@soleen.com \
    --cc=piliu@redhat.com \
    --cc=pratyush@kernel.org \
    --cc=rafael@kernel.org \
    --cc=ritesh.list@gmail.com \
    --cc=robh@kernel.org \
    --cc=rppt@kernel.org \
    --cc=ruanjinjie@huawei.com \
    --cc=ruirui.yang@linux.dev \
    --cc=sashiko-reviews@lists.linux.dev \
    --cc=seanjc@google.com \
    --cc=sourabhjain@linux.ibm.com \
    --cc=sshegde@linux.ibm.com \
    --cc=takahiro.akashi@linaro.org \
    --cc=tangyouling@kylinos.cn \
    --cc=tglx@kernel.org \
    --cc=thuth@redhat.com \
    --cc=vishal.l.verma@intel.com \
    --cc=will@kernel.org \
    --cc=x86@kernel.org \
    --cc=yeoreum.yun@arm.com \
    --cc=zhangtianyang@loongson.cn \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®