From: Heiko Carstens <hca@linux.ibm.com>
To: Alexander Gordeev <agordeev@linux.ibm.com>,
Sven Schnelle <svens@linux.ibm.com>,
Vasily Gorbik <gor@linux.ibm.com>,
Christian Borntraeger <borntraeger@linux.ibm.com>,
Mete Durlu <meted@linux.ibm.com>,
Peter Zijlstra <peterz@infradead.org>,
Mark Rutland <mark.rutland@arm.com>,
Juergen Christ <jchrist@linux.ibm.com>,
Ilya Leoshkevich <iii@linux.ibm.com>
Cc: linux-kernel@vger.kernel.org, linux-s390@vger.kernel.org
Subject: [PATCH v4 00/11] s390: More this_cpu_*() changes
Date: Mon, 21 Sep 2026 17:57:54 +0200 [thread overview]
Message-ID: <20260921155806.2447506-1-hca@linux.ibm.com> (raw)
v4:
- With the change to la instead of agrk also the register pair cannot be
mapped to gpr0/gpr1 anymore, since all three registers involved in pcpu
operations are now used as base or index registers. If gpr0 is used as
base or index register the corresponding instructions treat the content
of that register as zero, instead of using its real content. Fix that
by using the "a" instead if "d" constraint for register pairs. Also add
another sanity check to cover this. [Sashiko]
v3:
- Add various sanity checks to enforce correct register usage
[Mark Rutland]
- Use %N instead of %M operand modifier to access odd register of a
register pair in inline assemblies. Strictly speaking this is not
correct, since %N is supposed to be used for DImode operands and %M for
TImode operands. However both gcc and clang handle them identical, and
there is an existing user of %N in the kernel since many years.
Therefore use %N to get rid of the not yet released clang 24
dependency. [Christian Borntraeger]
- Use la (load address) instruction with base and index register to
generate a CPUs percpu variable address instead of agrk. la is
available for all architecture levels. This removes the z196
dependency as minimum architecture level. [Christian Borntraeger]
- Change coding style at some places, and fix various typos in commit
messages and comments.
- Fix compile error caused by missing semicolon.
v2:
- Yet another brown paper bug: Re-add CPU migration check to last
patch. Unconditionally recalculating and updating the percpu variable
address and percpu offset register can corrupt previous context
register state in several cases (not only the single case reported by
Sashiko).
v1:
Most of this is only about cleaning up the percpu code after preemptible
this_cpu_*() operations have been implemented. The first ten patches are
all more or less trivial cleanup patches trying to make the code shorter
and more readable.
The only non-trivial patch is the last one, which converts s390's
this_cpu_*() operations to use a similar scheme like Mark Rutland
provided it for arm64 [1]. This allows to simplify the irq entry and exit
path, however at the cost of slightly worse code for this_cpu_*()
operations.
The simplified irq entry and exit code seems to be worth it. Usable
performance numbers are not available yet, however I don't expect big
difference to before.
[1] https://lore.kernel.org/all/20260904161758.376504-1-mark.rutland@arm.com/
Thanks,
Heiko
Heiko Carstens (11):
s390/percpu: Fix comment typo
s390/percpu: Add sanity check to GEN_MVIY macro
s390/lowcore: Remove _AC() from LOWCORE_ALT_ADDRESS
s390/percpu: Let MVIY_PERCPU() calculate alternative displacement
s390/percpu/lowcore: Add and use LC_PERCPU lowcore offset defines
s390/percpu: Rename inline assembly symbolic names
s390/percpu: Use __PCPU_BEGIN() and __PCPU_END() for inline assemblies
s390/percpu: Use percpu code section for this_cpu_cmpxchg128()
s390/percpu: Use percpu code section for this_cpu_xchg()
s390/percpu: Use percpu code section for this_cpu_cmpxchg()
s390/percpu: Rework to simplify percpu_entry() and percpu_exit()
arch/s390/include/asm/entry-percpu.h | 71 ++----
arch/s390/include/asm/lowcore.h | 5 +-
arch/s390/include/asm/percpu.h | 354 +++++++++++++++++----------
arch/s390/kernel/irq.c | 10 +-
arch/s390/kernel/nmi.c | 4 +-
arch/s390/kernel/traps.c | 4 +-
6 files changed, 248 insertions(+), 200 deletions(-)
--
2.53.0
next reply other threads:[~2026-09-21 15:58 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-21 15:57 Heiko Carstens [this message]
2026-09-21 15:57 ` [PATCH v4 01/11] s390/percpu: Fix comment typo Heiko Carstens
2026-09-21 15:57 ` [PATCH v4 02/11] s390/percpu: Add sanity check to GEN_MVIY macro Heiko Carstens
2026-09-21 15:57 ` [PATCH v4 03/11] s390/lowcore: Remove _AC() from LOWCORE_ALT_ADDRESS Heiko Carstens
2026-09-21 15:57 ` [PATCH v4 04/11] s390/percpu: Let MVIY_PERCPU() calculate alternative displacement Heiko Carstens
2026-09-21 15:57 ` [PATCH v4 05/11] s390/percpu/lowcore: Add and use LC_PERCPU lowcore offset defines Heiko Carstens
2026-09-21 15:58 ` [PATCH v4 06/11] s390/percpu: Rename inline assembly symbolic names Heiko Carstens
2026-09-21 15:58 ` [PATCH v4 07/11] s390/percpu: Use __PCPU_BEGIN() and __PCPU_END() for inline assemblies Heiko Carstens
2026-09-21 15:58 ` [PATCH v4 08/11] s390/percpu: Use percpu code section for this_cpu_cmpxchg128() Heiko Carstens
2026-09-21 15:58 ` [PATCH v4 09/11] s390/percpu: Use percpu code section for this_cpu_xchg() Heiko Carstens
2026-09-21 15:58 ` [PATCH v4 10/11] s390/percpu: Use percpu code section for this_cpu_cmpxchg() Heiko Carstens
2026-09-21 15:58 ` [PATCH v4 11/11] s390/percpu: Rework to simplify percpu_entry() and percpu_exit() Heiko Carstens
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260921155806.2447506-1-hca@linux.ibm.com \
--to=hca@linux.ibm.com \
--cc=agordeev@linux.ibm.com \
--cc=borntraeger@linux.ibm.com \
--cc=gor@linux.ibm.com \
--cc=iii@linux.ibm.com \
--cc=jchrist@linux.ibm.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-s390@vger.kernel.org \
--cc=mark.rutland@arm.com \
--cc=meted@linux.ibm.com \
--cc=peterz@infradead.org \
--cc=svens@linux.ibm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®