From: sashiko-bot@kernel.org
To: "Jonathan Corbet" <corbet@lwn.net>,
"Rob Herring" <robh@kernel.org>,
"Pasha Tatashin" <pasha.tatashin@soleen.com>,
"Pratyush Yadav" <pratyush@kernel.org>,
"Michal Hocko" <mhocko@suse.com>,
"Ard Biesheuvel" <ardb@kernel.org>,
"Borislav Petkov" <bp@alien8.de>,
"Suren Baghdasaryan" <surenb@google.com>,
"Thomas Gleixner" <tglx@kernel.org>,
"Saravana Kannan" <saravanak@kernel.org>,
"Alexander Graf" <graf@amazon.com>,
"David Hildenbrand" <david@kernel.org>,
"Ingo Molnar" <mingo@redhat.com>,
"Dave Hansen" <dave.hansen@linux.intel.com>,
"Shuah Khan" <skhan@linuxfoundation.org>,
"H. Peter Anvin" <hpa@zytor.com>,
"Vlastimil Babka" <vbabka@kernel.org>,
"Mike Rapoport" <rppt@kernel.org>,
"Arnd Bergmann" <arnd@arndb.de>,
"Andrew Morton" <akpm@linux-foundation.org>,
"Baoquan He" <baoquan.he@linux.dev>,
"Ilias Apalodimas" <ilias.apalodimas@linaro.org>,
"Liam R. Howlett" <liam@infradead.org>,
"Lorenzo Stoakes" <ljs@kernel.org>
Cc: robh@kernel.org, kexec@lists.infradead.org,
linux-arch@vger.kernel.org, linux-doc@vger.kernel.org,
linux-mm@kvack.org, linux-efi@vger.kernel.org,
linux-kernel@vger.kernel.org, devicetree@vger.kernel.org,
x86@kernel.org, conor+dt@kernel.org
Subject: Re: [PATCH v3 2/4] memblock: rename KHO_SCRATCH to KHO_NOPRSRV
Date: Tue, 22 Sep 2026 04:19:16 +0000 [thread overview]
Message-ID: <20260922041916.A84161F00893@smtp.kernel.org> (raw)
In-Reply-To: <20260922041321.233986-3-pratyush@kernel.org>
> From: "Pratyush Yadav (Google)" <pratyush@kernel.org>
>
> The term "KHO scratch" is vague. It does not accurately describe what
> the memory is for. Generally, scratch is for things that don't contain
> anything useful. This is not true.
>
> For memblock, KHO_SCRATCH is the _only_ useful memory during a KHO boot.
> It is memory passed by the previous kernel that is guaranteed to have no
> preserved pages, and so is the only thing safe to allocate from early in
> boot.
>
> In addition, KHO now has the ability to discover other "scratch" areas.
> These aren't directly passed by the previous kernel. Instead, they are
> found by searching the KHO preserved memory map.
>
> Memblock does not care about the difference between the two. From
> memblock's perspective, both are memory areas with no preservations and
> so they are safe to allocate from before KHO fully initializes.
>
> Rename MEMBLOCK_KHO_SCRATCH to MEMBLOCK_KHO_NOPRSRV. This name clearly
> shows what the memory is for from memblock's perspective. Update
> memblock functions and comments that refer to scratch to use noprsrv.
>
> There are no functional changes apart from the flag name change in
> debugfs.
>
> Signed-off-by: Pratyush Yadav (Google) <pratyush@kernel.org>
Sashiko has reviewed this patch and found no issues. It looks great!
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260922041321.233986-1-pratyush@kernel.org?part=2
next prev parent reply other threads:[~2026-09-22 4:19 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-22 4:13 [PATCH v3 0/4] kho: rename "scratch" to "bootmem" Pratyush Yadav
2026-09-22 4:13 ` [PATCH v3 1/4] memblock: get rid of CONFIG_MEMBLOCK_KHO_SCRATCH Pratyush Yadav
2026-09-22 4:21 ` sashiko-bot
2026-09-22 4:13 ` [PATCH v3 2/4] memblock: rename KHO_SCRATCH to KHO_NOPRSRV Pratyush Yadav
2026-09-22 4:19 ` sashiko-bot [this message]
2026-09-22 4:13 ` [PATCH v3 3/4] kho: rename KHO scratch to KHO bootmem Pratyush Yadav
2026-09-22 4:21 ` sashiko-bot
2026-09-22 4:13 ` [PATCH v3 4/4] kho: rename kho_scratch= commandline parameter to kho_bootmem= Pratyush Yadav
2026-09-22 4:19 ` sashiko-bot
2026-09-24 8:35 ` [PATCH v3 0/4] kho: rename "scratch" to "bootmem" Mike Rapoport
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260922041916.A84161F00893@smtp.kernel.org \
--to=sashiko-bot@kernel.org \
--cc=akpm@linux-foundation.org \
--cc=ardb@kernel.org \
--cc=arnd@arndb.de \
--cc=baoquan.he@linux.dev \
--cc=bp@alien8.de \
--cc=conor+dt@kernel.org \
--cc=corbet@lwn.net \
--cc=dave.hansen@linux.intel.com \
--cc=david@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=graf@amazon.com \
--cc=hpa@zytor.com \
--cc=ilias.apalodimas@linaro.org \
--cc=kexec@lists.infradead.org \
--cc=liam@infradead.org \
--cc=linux-arch@vger.kernel.org \
--cc=linux-doc@vger.kernel.org \
--cc=linux-efi@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=ljs@kernel.org \
--cc=mhocko@suse.com \
--cc=mingo@redhat.com \
--cc=pasha.tatashin@soleen.com \
--cc=pratyush@kernel.org \
--cc=robh@kernel.org \
--cc=rppt@kernel.org \
--cc=saravanak@kernel.org \
--cc=sashiko-reviews@lists.linux.dev \
--cc=skhan@linuxfoundation.org \
--cc=surenb@google.com \
--cc=tglx@kernel.org \
--cc=vbabka@kernel.org \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®