mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Alex Elder <elder@linaro.org>
To: Will Cunningham <wjcunningham7@gmail.com>, johan@kernel.org
Cc: elder@kernel.org, gregkh@linuxfoundation.org,
	devel@driverdev.osuosl.org, linux-kernel@vger.kernel.org,
	joe@perches.com
Subject: Re: [PATCH v2] Staging: greybus: usb: Fixed a coding style error
Date: Mon, 1 Apr 2019 09:25:42 -0500	[thread overview]
Message-ID: <21036602-c062-8f32-ee81-7eb80f348982@linaro.org> (raw)
In-Reply-To: <20190401142208.GA12744@titus.pi.local>

On 4/1/19 9:22 AM, Will Cunningham wrote:
> Line was >80 characters.

This looks fine, but "tmp" is not a meaningful name.
That argument to gb_connection_create() is a cport id,
so "cport_id" would be a much better name for the variable.

It seems picky, but details like this make the code much
more understandable.

					-Alex


> Signed-off-by: Will Cunningham <wjcunningham7@gmail.com>
> ---
> Changes in v2:
>  - Created a tmp variable to shorten line length.
> ---
>  drivers/staging/greybus/usb.c | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/drivers/staging/greybus/usb.c b/drivers/staging/greybus/usb.c
> index 1c246c73a085..c09793b48850 100644
> --- a/drivers/staging/greybus/usb.c
> +++ b/drivers/staging/greybus/usb.c
> @@ -163,14 +163,14 @@ static int gb_usb_probe(struct gbphy_device *gbphy_dev,
>  	struct gb_usb_device *gb_usb_dev;
>  	struct usb_hcd *hcd;
>  	int retval;
> +	u16 tmp;
>  
>  	hcd = usb_create_hcd(&usb_gb_hc_driver, dev, dev_name(dev));
>  	if (!hcd)
>  		return -ENOMEM;
>  
> -	connection = gb_connection_create(gbphy_dev->bundle,
> -					  le16_to_cpu(gbphy_dev->cport_desc->id),
> -					  NULL);
> +	tmp = le16_to_cpu(gbphy_dev->cport_desc->id);
> +	connection = gb_connection_create(gbphy_dev->bundle, tmp, NULL);
>  	if (IS_ERR(connection)) {
>  		retval = PTR_ERR(connection);
>  		goto exit_usb_put;
> 


  reply	other threads:[~2019-04-01 14:25 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-04-01 14:22 Will Cunningham
2019-04-01 14:25 ` Alex Elder [this message]
2019-04-02  6:07 ` Dan Carpenter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=21036602-c062-8f32-ee81-7eb80f348982@linaro.org \
    --to=elder@linaro.org \
    --cc=devel@driverdev.osuosl.org \
    --cc=elder@kernel.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=joe@perches.com \
    --cc=johan@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=wjcunningham7@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®