From: David Brownell <david-b@pacbell.net>
To: Alan Cox <alan@lxorguk.ukuu.org.uk>
Cc: Anton Vorontsov <cbouatmailru@gmail.com>,
Andrew Morton <akpm@linux-foundation.org>,
Samuel Ortiz <sameo@linux.intel.com>,
Mark Brown <broonie@opensource.wolfsonmicro.com>,
David Brownell <dbrownell@users.sourceforge.net>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH] gpio: Add generic driver for simple memory mapped controllers
Date: Thu, 26 Aug 2010 10:34:58 -0700 (PDT) [thread overview]
Message-ID: <216397.86259.qm@web180306.mail.gq1.yahoo.com> (raw)
In-Reply-To: <20100826174822.75094415@lxorguk.ukuu.org.uk>
--- On Thu, 8/26/10, Alan Cox <alan@lxorguk.ukuu.org.uk> wrote:
> > Just rename it to match the IP block used.
>
> There are zillions of IP blocks that have that interface,
If there are "zillions" that suggests the HW
engineers have version/naming issues just like
certain software engineers. Only goes to show
how close Verilog and VHDL are to software! :)
> how exactly do
> you propose to rename it.
My suggestion was to use the name provided/used
by the hardware engineers. (E.g. whatever the
Verilog or VHDL equivalent of a module name is.)
So -- NO RENAME -- except for the driver.
If I understand you correctly, those engineers
are not reusing a named module; they are at best
just copying/pasting some Verilog/VHDL and adding
ASIC/SoC/.../FPGA-specific hacks. (Which calls into
question just how much assurance there can be that
one driver will work reliably for all instances...
> > That removes all confusion. Engineers will
> > be able to know more easily whether this
> > driver is even relevant to them.
>
> Not unless its got a name about 1000 characters long
> listing all the
> devices it might drive - and changes name weekly.
Someone should have a few words with those hardware
engineers about module naming and consistency, so
software doesn't need to work around such issues.
Such problems have been solved for decades, and
there's no reason to create confusion higher up
the system stack. (or force workarounds.)
> > An example might be "amba-9999 (a made-up
> > number, likely not matching a GPIO controller).
Note that such names are already used in Linux
with IP blocks from AMBA; Designware blocks, as
I noted, aren't dissimilar (dw_foo.c in at least
a few cases).
> What's wrong with a sensible generic name like
> gpio-mmio-table ?
That's a much better name. I'ts got technical
content, even! (vs "simple" being "marketing",
including easy confusion with other entities).
All I'll say is that it might
be *too* generic a name. I know I can come up
with current examples of GPIO done via MMIO
(tables) that this driver won't fit at all.
That can probably be worked around via docs and
conventions.
There'd need to be good docs on what this
gpio-mmio-table interface expects. Some of that
belongs in Kconfig, not much; mostly I'd think
it belongs in driver header comments, but also
some in the patch comment itself. I hear you
strongly implying that there's no generic hardware
doc to reference. (As theree would be if this
block came from the AMBA or DesignWare families.)
next prev parent reply other threads:[~2010-08-26 17:35 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2010-08-25 19:42 Anton Vorontsov
[not found] ` <921098.64431.qm@web180306.mail.gq1.yahoo.com>
2010-08-26 5:17 ` Anton Vorontsov
2010-08-26 16:22 ` David Brownell
2010-08-26 16:48 ` Alan Cox
2010-08-26 17:34 ` David Brownell [this message]
2010-08-26 18:36 ` Mark Brown
2010-08-26 21:07 ` Alan Cox
2010-08-26 22:58 ` David Brownell
2010-08-27 0:15 ` Alan Cox
2010-08-26 17:26 ` [PATCH v2] gpio: Add driver for Anton GPIO controllers Anton Vorontsov
2010-08-26 17:57 ` David Brownell
2010-08-26 21:20 ` Anton Vorontsov
2010-08-26 22:48 ` David Brownell
2010-08-27 15:57 ` [PATCH v3] gpio: Add driver for basic memory-mapped " Anton Vorontsov
2010-08-28 19:08 ` David Brownell
2010-08-29 21:28 ` [PATCH v4] " Anton Vorontsov
2010-08-30 20:23 ` David Brownell
2010-08-31 17:58 ` [PATCH v5] " Anton Vorontsov
2010-08-31 18:21 ` Mark Brown
2010-08-31 20:32 ` David Brownell
2010-09-01 19:52 ` [PATCH v6] " Anton Vorontsov
2010-09-07 14:01 ` [PATCH v7] " Anton Vorontsov
2010-09-21 22:23 ` Anton Vorontsov
2010-09-24 21:45 ` Andrew Morton
2010-09-28 12:40 ` [PATCH v7-fix] gpio: Add driver for basic memory-mapped GPIO controllers (fix) Anton Vorontsov
2010-08-26 18:38 ` [PATCH] gpio: Add generic driver for simple memory mapped controllers Mark Brown
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=216397.86259.qm@web180306.mail.gq1.yahoo.com \
--to=david-b@pacbell.net \
--cc=akpm@linux-foundation.org \
--cc=alan@lxorguk.ukuu.org.uk \
--cc=broonie@opensource.wolfsonmicro.com \
--cc=cbouatmailru@gmail.com \
--cc=dbrownell@users.sourceforge.net \
--cc=linux-kernel@vger.kernel.org \
--cc=sameo@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®