From: Chanwoo Choi <chanwoo@kernel.org>
To: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
Chanwoo Choi <cw00.choi@samsung.com>,
chanwoo@kernel.org, MyungJoo Ham <myungjoo.ham@samsung.com>,
y0.cho@samsung.com, yuni.seo@samsung.com
Subject: [GIT PULL] extcon next for 6.5
Date: Mon, 19 Jun 2023 23:33:18 +0900 [thread overview]
Message-ID: <2164491b-973d-3e54-fd28-f00d6efa3cce@kernel.org> (raw)
Dear Greg,
This is extcon-next pull request for v6.5. I add detailed description of
this pull request on below. Please pull extcon with following updates.
Best Regards,
Chanwoo Choi
The following changes since commit 7877cb91f1081754a1487c144d85dc0d2e2e7fc4:
Linux 6.4-rc4 (2023-05-28 07:49:00 -0400)
are available in the Git repository at:
git://git.kernel.org/pub/scm/linux/kernel/git/chanwoo/extcon.git tags/extcon-next-for-6.5
for you to fetch changes up to 94da3da96c35744001adfdb65e501e633a64cb51:
dt-bindings: extcon: wlf,arizona: drop unneeded quotes (2023-06-10 22:06:45 +0900)
----------------------------------------------------------------
Update extcon next for v6.5
Detailed description for this pull request:
1. Clean-up extcon core without any behavior changes
- Add extcon_alloc_cables/muex/groups to improve the readability
of extcon_dev_register.
- Fix kernel doc of property and property capability fields to aovid warnings
and add missing description of struct extcon_dev.
- Use DECLARE_BITMAP macro and sysfs_emit instead of sprintf
- Use device_match_of_node helper instead of accessing the .of_node
- Use ida_alloc/free to get the unique id for extcon device
2. Update extcon-usbc-tusb320.c to support usb_role_switch and accessory detection
- Add usb_role_switch support on extcon-usbsc-tusb320.
- Add additional accessory detection for audio/debug accessory
and then pass the deteced accessory information to typec subsystem
on extcon-usbsc-tusb320.c.
- Add the support of unregistration of typec port on both error handling
and driver removal step on
3. Update extcon provider drivers (apx288/qcom-spmi-misc/palmas)
- Replace put_device with acpi_dev_put on extcon-axp288.c
- Use platform_get_irq_byname_optional for getting irq of
usb_id and usb_vbus on extcon-qcom-spmi-misc.c.
- Remove unused of_gpio.h on extcon-palmas.c.
4. Fix the devicetree binding document
- Rename misc node name to 'usb-dect@900' on pm8941-misc.yam
- Fix usb-id and usb_vbus defintion on pm8941-misc.yaml
- Drop unneeded quotes from extcon-arizona.c devicetree documentation
----------------------------------------------------------------
Alvin Šipraga (3):
extcon: usbc-tusb320: Unregister typec port on driver removal
extcon: usbc-tusb320: add accessory detection support
extcon: usbc-tusb320: add usb_role_switch support
Andy Shevchenko (13):
extcon: axp288: Replace open coded acpi_dev_put()
extcon: palmas: Remove unused of_gpio.h
extcon: Fix kernel doc of property fields to avoid warnings
extcon: Fix kernel doc of property capability fields to avoid warnings
extcon: Use DECLARE_BITMAP() to declare bit arrays
extcon: Use sysfs_emit() to instead of sprintf()
extcon: Amend kernel documentation of struct extcon_dev
extcon: Use device_match_of_node() helper
extcon: Use dev_of_node(dev) instead of dev->of_node
extcon: Remove dup device name in the message and unneeded error check
extcon: Use unique number for the extcon device ID
extcon: Use sizeof(*pointer) instead of sizeof(type)
extcon: Drop unneeded assignments
Arnd Bergmann (1):
extcon: usbc-tusb320: add USB_ROLE_SWITCH dependency
Bryan O'Donoghue (2):
dt-bindings: pm8941-misc: Fix usb_id and usb_vbus definitions
extcon: qcom-spmi: Switch to platform_get_irq_byname_optional
Bumwoo Lee (4):
extcon: Remove redundant null checking for class
extcon: Add extcon_alloc_cables to simplify extcon register function
extcon: Add extcon_alloc_muex to simplify extcon register function
extcon: Add extcon_alloc_groups to simplify extcon register function
Krzysztof Kozlowski (1):
dt-bindings: extcon: wlf,arizona: drop unneeded quotes
Luca Weiss (1):
dt-bindings: pm8941-misc: rename misc node name
Uwe Kleine-König (1):
extcon: Switch i2c drivers back to use .probe()
.../bindings/extcon/qcom,pm8941-misc.yaml | 14 +-
.../devicetree/bindings/extcon/wlf,arizona.yaml | 14 +-
drivers/extcon/Kconfig | 1 +
drivers/extcon/extcon-axp288.c | 2 +-
drivers/extcon/extcon-fsa9480.c | 2 +-
drivers/extcon/extcon-palmas.c | 1 -
drivers/extcon/extcon-ptn5150.c | 2 +-
drivers/extcon/extcon-qcom-spmi-misc.c | 4 +-
drivers/extcon/extcon-rt8973a.c | 2 +-
drivers/extcon/extcon-sm5502.c | 2 +-
drivers/extcon/extcon-usbc-tusb320.c | 155 +++++++--
drivers/extcon/extcon.c | 368 ++++++++++++---------
drivers/extcon/extcon.h | 8 +-
13 files changed, 366 insertions(+), 209 deletions(-)
next reply other threads:[~2023-06-19 14:33 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-06-19 14:33 Chanwoo Choi [this message]
2023-06-19 15:12 ` Greg Kroah-Hartman
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2164491b-973d-3e54-fd28-f00d6efa3cce@kernel.org \
--to=chanwoo@kernel.org \
--cc=cw00.choi@samsung.com \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=myungjoo.ham@samsung.com \
--cc=y0.cho@samsung.com \
--cc=yuni.seo@samsung.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®