From: Yunsheng Lin <yunshenglin0825@gmail.com>
To: Alexander Duyck <alexander.duyck@gmail.com>
Cc: davem@davemloft.net, kuba@kernel.org, pabeni@redhat.com,
netdev@vger.kernel.org, linux-kernel@vger.kernel.org,
Yunsheng Lin <linyunsheng@huawei.com>,
Eric Dumazet <edumazet@google.com>,
David Ahern <dsahern@kernel.org>
Subject: Re: [PATCH net-next v19 09/14] net: rename skb_copy_to_page_nocache() helper
Date: Mon, 7 Oct 2024 22:29:13 +0800 [thread overview]
Message-ID: <218513be-857b-4457-8bd8-c12e170233b7@gmail.com> (raw)
In-Reply-To: <CAKgT0UfY5JtfqsFUG-Cj6ZkOOiWFWJ3w9=35c6c0QWbktKbvLg@mail.gmail.com>
On 10/7/2024 12:18 AM, Alexander Duyck wrote:
...
>
> I could probably live with sk_copy_to_skb_data_nocache since we also
> refer to the section after the page section with data_len. The basic
> idea is we are wanting to define what the function does with the
> function name rather than just report the arguments it is accepting.
Yes, looking more closely:
skb_add_data_nocache() does memcpy'ing to skb->data and update skb->len
only by calling skb_put(), and skb_copy_to_page_nocache() does
memcpy'ing to skb frag by updating both skb->len and skb->data_len
through the calling of skb_len_add().
Perhaps skb_add_frag_nocache() might seems a better name for now, and
the 'sk_' prefix might be done in the future if it does make sense.
next prev parent reply other threads:[~2024-10-07 14:29 UTC|newest]
Thread overview: 24+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-10-01 7:58 [PATCH net-next v19 00/14] Replace page_frag with page_frag_cache for sk_page_frag() Yunsheng Lin
2024-10-01 7:58 ` [PATCH net-next v19 01/14] mm: page_frag: add a test module for page_frag Yunsheng Lin
2024-10-01 7:58 ` [PATCH net-next v19 02/14] mm: move the page fragment allocator from page_alloc into its own file Yunsheng Lin
2024-10-01 7:58 ` [PATCH net-next v19 03/14] mm: page_frag: use initial zero offset for page_frag_alloc_align() Yunsheng Lin
2024-10-01 7:58 ` [PATCH net-next v19 04/14] mm: page_frag: avoid caller accessing 'page_frag_cache' directly Yunsheng Lin
2024-10-01 7:58 ` [PATCH net-next v19 05/14] xtensa: remove the get_order() implementation Yunsheng Lin
2024-10-01 7:58 ` [PATCH net-next v19 06/14] mm: page_frag: reuse existing space for 'size' and 'pfmemalloc' Yunsheng Lin
2024-10-03 22:40 ` Alexander Duyck
2024-10-05 13:05 ` Yunsheng Lin
2024-10-06 16:07 ` Alexander Duyck
2024-10-01 7:58 ` [PATCH net-next v19 07/14] mm: page_frag: some minor refactoring before adding new API Yunsheng Lin
2024-10-01 7:58 ` [PATCH net-next v19 08/14] mm: page_frag: use __alloc_pages() to replace alloc_pages_node() Yunsheng Lin
2024-10-03 23:52 ` Alexander Duyck
2024-10-01 7:58 ` [PATCH net-next v19 09/14] net: rename skb_copy_to_page_nocache() helper Yunsheng Lin
2024-10-04 3:00 ` Alexander Duyck
2024-10-05 13:44 ` Yunsheng Lin
2024-10-06 16:18 ` Alexander Duyck
2024-10-07 14:29 ` Yunsheng Lin [this message]
2024-10-07 18:49 ` Alexander Duyck
2024-10-01 7:58 ` [PATCH net-next v19 10/14] mm: page_frag: introduce prepare/probe/commit API Yunsheng Lin
2024-10-01 7:58 ` [PATCH net-next v19 11/14] mm: page_frag: add testing for the newly added prepare API Yunsheng Lin
2024-10-01 7:58 ` [PATCH net-next v19 12/14] net: replace page_frag with page_frag_cache Yunsheng Lin
2024-10-01 7:58 ` [PATCH net-next v19 13/14] mm: page_frag: update documentation for page_frag Yunsheng Lin
2024-10-01 7:58 ` [PATCH net-next v19 14/14] mm: page_frag: add an entry in MAINTAINERS " Yunsheng Lin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=218513be-857b-4457-8bd8-c12e170233b7@gmail.com \
--to=yunshenglin0825@gmail.com \
--cc=alexander.duyck@gmail.com \
--cc=davem@davemloft.net \
--cc=dsahern@kernel.org \
--cc=edumazet@google.com \
--cc=kuba@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linyunsheng@huawei.com \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®