From: David Howells <dhowells@redhat.com>
To: Vitaly Chikunov <vt@altlinux.org>
Cc: dhowells@redhat.com, Herbert Xu <herbert@gondor.apana.org.au>,
davem@davemloft.net, keyrings@vger.kernel.org,
linux-crypto@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [RFC PATCH] akcipher: Introduce verify2 for public key algorithms
Date: Wed, 16 Jan 2019 16:22:37 +0000 [thread overview]
Message-ID: <21904.1547655757@warthog.procyon.org.uk> (raw)
In-Reply-To: <20190104102035.42qwwv4komjvnswh@sole.flsd.net>
Vitaly Chikunov <vt@altlinux.org> wrote:
> This will be hard to do since there is at least tree device that use
> this interface (and who know how much out of tree):
>
> drivers$ git grep cra_name.*rsa
> crypto/caam/caampkc.c: .cra_name = "rsa",
> crypto/ccp/ccp-crypto-rsa.c: .cra_name = "rsa",
> crypto/qat/qat_common/qat_asym_algs.c: .cra_name = "rsa",
>
> Interface seems to be designed that verify() call is interchangeable
> with encrypt().
>
> Two verify does not seem that bad since there is common code for the old
> interface that removes code duplication and simplifies driver
> implementation (RSA drivers only need to implement encrypt).
You could move the comparison into core crypto code if it's makes more sense
than moving the comparison to the crypto algorithm ->verify() call. It makes
more sense than the upper layers having to cover the differences between the
algo modules.
David
next prev parent reply other threads:[~2019-01-16 16:22 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-12-11 16:59 Vitaly Chikunov
2018-12-13 10:12 ` Herbert Xu
2019-01-04 10:20 ` Vitaly Chikunov
2019-01-16 16:22 ` David Howells [this message]
2018-12-13 10:26 ` Tudor.Ambarus
2018-12-13 11:58 ` Vitaly Chikunov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=21904.1547655757@warthog.procyon.org.uk \
--to=dhowells@redhat.com \
--cc=davem@davemloft.net \
--cc=herbert@gondor.apana.org.au \
--cc=keyrings@vger.kernel.org \
--cc=linux-crypto@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=vt@altlinux.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome