From: Aaron Sierra <asierra@xes-inc.com>
To: Jean Delvare <khali@linux-fr.org>
Cc: Guenter Roeck <guenter@roeck-us.net>,
Peter Tyser <ptyser@xes-inc.com>,
Grant Likely <grant.likely@secretlab.ca>,
LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 1/3 v3] mfd: Add LPC driver for Intel ICH chipsets
Date: Fri, 17 Feb 2012 16:03:48 -0600 (CST) [thread overview]
Message-ID: <23e491f9-cb12-4bba-b5b0-a9948b17c984@zimbra> (raw)
In-Reply-To: <20120217222155.435195d2@endymion.delvare>
> > +static void __devexit lpc_ich_remove(struct pci_dev *dev)
> > +{
> > + mfd_remove_devices(&dev->dev);
> > +
> > + if (lpc_ich_gpio_save > 0)
> > + pci_write_config_byte(dev, GPIOCTRL, (u8)lpc_ich_gpio_save);
> > + if (lpc_ich_acpi_save > 0)
> > + pci_write_config_byte(dev, ACPICTRL, (u8)lpc_ich_acpi_save);
>
> I think you really mean >= 0 above. And the casts aren't needed. You
> should also reset lpc_ich_gpio_save and lpc_ich_acpi_save to -1 after
> restoring the values, it matters if the device is removed and re-added
> through sysfs.
I seriously almost changed that compare in this patch... I wish I had. I've
made these changes, now.
> This cleanup is missing from the error path in lpc_ich_probe, BTW.
> You may want to move it to a separate function so that you can call it
> from both lpc_ich_probe and lpc_ich_remove.
Good point. I've got this change ready to go, too. Thanks.
-Aaron S.
prev parent reply other threads:[~2012-02-17 22:04 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <0080ec60-4f91-4642-bf3b-42ab667b3b13@zimbra>
2012-02-17 18:18 ` Aaron Sierra
2012-02-17 21:21 ` Jean Delvare
2012-02-17 22:03 ` Aaron Sierra [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=23e491f9-cb12-4bba-b5b0-a9948b17c984@zimbra \
--to=asierra@xes-inc.com \
--cc=grant.likely@secretlab.ca \
--cc=guenter@roeck-us.net \
--cc=khali@linux-fr.org \
--cc=linux-kernel@vger.kernel.org \
--cc=ptyser@xes-inc.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®